Как конвертировать звуковые файлы в ulaw, alaw, gsm, g722 и т.д. для Asterisk

После заказа озвучки у профессионального диктора и нарезки в звуковом редакторе, понадобилось сохранить звуки в разных форматах, оригинал был в wav, так вот приведу пример конвертации через sox (он уже был в системе с Asterisk):

sox -V vm-intro.wav -r 8000 -c 1 -t ul vm-intro.ulaw
sox -V vm-intro.wav -r 8000 -c 1 -t al vm-intro.alaw
sox -V vm-intro.wav -r 8000 -c 1 -t gsm vm-intro.gsm

Кодек g722 вроде он не поддерживает, по крайней мере в man sox не нашел, поэтому установил ffmpeg (в системе Ubuntu Server):

sudo apt-get install ffmpeg

И выполнил конвертирование:

ffmpeg -i vm-intro.wav -ar 16000 -acodec g722 vm-intro.g722

Стандартная директория со звуками Asterisk — /usr/share/asterisk/sounds

Список SNMP OID и MIB для интерфейсов

Приведу ниже список стандартных OID и MIB с описанием для получения по SNMP различной статистики сетевых интерфейсов коммутаторов, маршрутизаторов, точек доступа, сетевых плат в серверах и т.д.

Проверить OID и MIB можно из Linux например командой (где .1, это OID):
snmpwalk -v2c -c комьюнити 192.168.1.2 .1

Посмотреть описание сетевых интерфейсов можно через OID (в скобках MIB):

.1.3.6.1.2.1.2.2.1.2 (ifDescr)

Список индексов интерфейсов портов:

.1.3.6.1.2.1.17.1.4.1.2 (ifIndex)

Статус порта, есть линк или нет (1-up, 2-down, 3-testing, 4-unknown, 5-dormant, 6-notPresent, 7-lowerLayerDown):

1.3.6.1.2.1.2.2.1.8 (ifOperStatus)

Статус порта, включен или отключен программно (1-up, 2-down, 3-testing):

ifAdminStatus

Время последнего изменения порта:

1.3.6.1.2.1.2.2.1.9 (ifLastChange)

Трафик портов:

1.3.6.1.2.1.2.2.1.10 (ifInOctets)
1.3.6.1.2.1.2.2.1.16 (ifOutOctets)

Для 64-битных счетчиков трафика используется MIB:

ifHCInOctets
ifHCOutOctets

Количество пакетов содержащих ошибки:

1.3.6.1.2.1.2.2.1.20 (ifOutErrors)
1.3.6.1.2.1.2.2.1.20 (ifInErrors)

Количество отброшенных пакетов, которые по сути без ошибок, но были отброшены например для освобождения буферного пространства:

ifInDiscards
ifOutDiscards

Физический адрес:

ifPhysAddress

Размер наибольшего пакета, который может быть отправлен:

ifMtu

Тип интерфейса:

ifType

Unicast пакеты:

ifIntUcastPkts
ifOutUcastPkts

Скорость порта:

1.3.6.1.2.1.2.2.1.5 (ifSpeed)

Список VLAN:

.1.3.6.1.2.1.17.7.1.4.3.1.1

Время работы устройства:

1.3.6.1.2.1.1.3 (sysUpTime)

Описание устройства:

1.3.6.1.2.1.1.1.0

Настройка агрегации каналов на Cisco Catalyst 6500

Для теста настрою агрегацию на Cisco Catalyst 6509-E.

Допустим я настроил первый порт как мне нужно, прописал нужные VLAN, теперь последней командой добавим порт в канал агрегации:

interface GigabitEthernet1/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
channel-group 1 mode on

Второй порт должен быть настроен аналогично и тоже последней командой добавим его в канал агрегации:

interface GigabitEthernet1/8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
channel-group 1 mode on

После команд выше автоматически создался выключенный интерфейс Port-channel1, командой description добавим примечание и включим его:

interface Port-channel1
description GPON OLT link aggregation
no shutdown

Настройка агрегации портов завершена, к ним можно подключаться.

Смотри также:
Настройка агрегации каналов на Huawei SmartAX MA5600

Настройка агрегации каналов на Huawei SmartAX MA5600

На тесте настрою агрегацию на двух портах Huawei SmartAX MA5683T и Cisco Catalyst 6509-E.

У меня трафик идет на один SFP порт 0/8/0, настроим агрегацию на него и следующий свободный порт 0/8/1:

link-aggregation 0/8 0 0/8 1 egress-ingress

Либо настроим на один порт, а потом добавим следующий:

link-aggregation 0/8 0 egress-ingress
link-aggregation add-member 0/8/0 0/8 1

Проверим:

display link-aggregation 0/8/0
display link-aggregation 0/8/1

Отменить можно агрегацию можно так:

undo link-aggregation 0/8/0

Или удалить командой порт из агрегации:

link-aggregation delete-member

На Huawei SmartAX MA5683T настройка агрегации двух портов завершена, в процессе настройки и после перебоев с трафиком не будет.

Теперь перейду к настройкt портов на Cisco Catalyst 6509-E.

Настрою первый порт как мне нужно, пропишу нужные VLAN и последней командой добавим порт в канал агрегации:

interface GigabitEthernet1/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
channel-group 1 mode on

Второй порт должен быть настроен аналогично и тоже последней командой добавим его в канал агрегации:

interface GigabitEthernet1/8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
channel-group 1 mode on

После команд выше автоматически создался выключенный интерфейс Port-channel1, командой description добавим ему примечание и включим его:

interface Port-channel1
description GPON OLT link aggregation
no shutdown

Теперь можно соединить оба порта Cisco с портами OLT MA5683T.

Все.

Смотрите также:
Настройка Huawei SmartAX MA5683T через консоль

Почему функциональных клавиш Mac работают без fn и вместо F1-F12

Заметил что на многих ноутбуках, в том числе и MacBook функциональные клавиши (уровень яркости дисплея, громкости и т.д.) стандартно можно использовать без клавиши fn (function). А сами клавиши от F1 до F12 приходится использовать с клавишей fn (она находится в левом нижнем углу клавиатуры).

Чтобы клавиши от F1 до F12 работали как обычно, а функциональные только с клавишей fn — откроем «Системные настройки» — «Клавиатура«, далее во вкладке «Клавиатура» выберем «Использовать функциональные клавиши F1, F2 и др. как стандартные«.

Все.

Смотрите также:
Функциональные клавиши Fn на ноутбуке работают наоборот

Функциональные клавиши Fn на ноутбуке работают наоборот

Обычно для расширения функциональности, на клавиатурах ноутбуков есть специальная клавиша Fn.
Если ее держать и нажимать клавиши например от F1 до F12, то они будут выполнять совсем другие функции, изменять яркость экрана, уровень громкости, переводить систему в спящий режим, выключать/включать Wi-Fi адаптер и т.д.

Но в моем случае все было наоборот, когда мне нужны были клавиши F1-F12, вместо них срабатывали функциональные, которые обычно работают с зажатой Fn, а чтобы нажать F4 например приходилось зажимать также клавишу Fn.

Как оказалось в BIOS была опция Action Keys Mode, значение которой по умолчанию было Enable, в следствие чего функциональные клавиши работали без нажатия Fn.
Чтобы клавиши F1-F12 работали как обычно, выставим значение на Disable.

Кстати, если у вас функциональные клавиши вовсе не работают, то скорее в системе не установлен драйвер.

Все.

Смотрите также:
Почему функциональных клавиш Mac работают без fn и вместо F1-F12

Настройка VPN IPSec/L2TP сервера на Mikrotik

Приведу пример настройки VPN IPSec/L2TP сервера на Mikrotik, чтобы можно было подключаться к нему из Windows, MacBook, iPhone и т.д.

1) Добавим диапазон IP-адресов для DHCP открыв «IP» — «Pool» и указав:
Name: vpn_pool
Addresses: 192.168.5.1-192.168.5.15
Next pool: none
Из терминала так:

ip pool add name=vpn_pool ranges=192.168.5.1-192.168.5.15

2) Добавим профиль в «PPP» — «Profiles»
Name: l2tp_profile
Local address: vpn_pool (можно указать default 192.168.88.1)
Remote address: vpn_pool
Change TCP MSS: yes
Остальное не трогаем и оставим в default
Из терминала так:

ppp profile add change-tcp-mss=yes local-address=vpn_pool name=l2tp_profile remote-address=vpn_pool

3) Добавим пользователя в «PPP» — «Secrets»
Name: ЛОГИН
Password: ПАРОЛЬ
Service: l2tp
Profile: l2tp_profile
Из терминала так:

ppp secret add name=ЛОГИН password=ПАРОЛЬ profile=l2tp_profile service=l2tp

4) Включим сервер в «PPP» — «Interface» — «L2TP Server»
Enabled: yes
MTU/MRU: 1450
Keepalive Timeout: 30
Default profile: l2tp_profile
Authentication: mschap2
Use IPSec: yes
IPSec Secret: КЛЮЧ_ШИФРОВАНИЯ (также указывается в клиентах)
Из терминала так:

interface l2tp-server server set authentication=mschap2 default-profile=l2tp_profile enabled=yes ipsec-secret=КЛЮЧ use-ipsec=yes

5) «IP» — «IPSec» — «Peers»
Address: 0.0.0.0/0
Port: 500
Auth method: pre shared key
Exchange mode: main l2tp
Passive: yes (set)
Secret: КЛЮЧ_ШИФРОВАНИЯ (также указывается в клиентах)
Policy template group: default
Send Initial Contact: yes
NAT Traversal: yes
My ID Type: auto
Generate policy: port override
Lifitime: 1d 00:00:00
DPD Interval: 120
DPD Maximum failures: 5
Proposal check: obey
Hash algorithm: sha1
Encryption Algorithm: 3des aes-128 aes-256
DH Group: modp 1024
Из терминала так:

ip ipsec peer add address=0.0.0.0/0 enc-algorithm=aes-256,aes-128,3des exchange-mode=main-l2tp generate-policy=port-override passive=yes secret=КЛЮЧ

6) «IP» — «IPSec» — «Proposals»
Name: default
Auth algorithms: sha1
Enrc. algorithms: 3des, aes-256 cbc, aes-256 ctr
Life time: 00:30:00
PFS Group: mod 1024
Из терминала так:

ip ipsec proposal set [ find default=yes ] enc-algorithms=aes-256-cbc,aes-256-ctr,3des

7) «Firewall» — «Add New»
Добавим первое правило разрешающее входящие VPN соединения:
Chain: Input
Protocol: udp
Any. Port: 1701,500,4500
Action: Accept
И второе:
Chain: Input
Protocol: ipsec-esp
Action: Accept
Из терминала так:

ip firewall filter add chain=input action=accept protocol=udp port=1701,500,4500
ip firewall filter add chain=input action=accept protocol=ipsec-esp

Правила должны находится в начале списка.

На этом настройка завершена, можно подключаться.