Понижение версии Apache 2.4 до 2.2

Пришлось как-то раз понизить чтобы заработал веб-интерфейс биллинга ABillS.

Для начала любой из команд удалим apache2 если он установлен:

sudo aptitude remove apache2
sudo apt-get remove apache2

Создадим файл в папке /etc/apt/sources.list.d/:

sudo nano /etc/apt/sources.list.d/ubuntu1204.list

Вставим в него текст:

deb http://ru.archive.ubuntu.com/ubuntu/ precise main

Создадим еще файл:

sudo nano /etc/apt/preferences.d/apache22

Вставим в него содержимое:

Package: apache*
Pin: release a=precise
Pin-Priority: 500

Выполним:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install apache2

Все.

Понижение версии Apache 2.4 до 2.2: 2 комментария

  1. для запуска abillsa есть решение на apache2.4 делается так автор «Dendj» взято с abills.net.ua, само решение:
    «замените
    # Apache 2.2
    Order deny,allow
    Allow from all
    на
    # Apache 2.4
    Require all granted»
    где менять «/etc/apache2/sites-enabled/abills_httpd.conf»

Добавить комментарий