Configuring IGMP snooping on Cisco

I will give an example of setting up IGMP snooping on Cisco, there was a Cisco WS-C2960-24TT-L switch at hand and also some Cisco Nexus.

First of all, let’s switch to configuration mode:

enable
configure t

Enable igmp snooping (enabled by default):

ip igmp snooping

I used the switch to connect the tuner and the Teleste Luminato so that Multicast starts to go through, we’ll point at the source ports with Multicast:

ip igmp snooping vlan 229 mrouter interface gigabitEthernet 0/2
ip igmp snooping vlan 229 mrouter interface FastEthernet0/1
ip igmp snooping vlan 229 mrouter interface FastEthernet0/2

Combined ports with tuners into one VLAN:

interface FastEthernet0/1
 switchport access vlan 229
 switchport mode access
interface FastEthernet0/2
 switchport access vlan 229
 switchport mode access
interface GigabitEthernet0/2
 switchport access vlan 229
 switchport mode access

Let’s look at the statistics and make sure that everything worked:

show ip igmp snooping mrouter
show ip igmp snooping querier
show ip igmp snooping querier detail

Let’s see who gets what multicast:

show ip igmp snooping groups

Check the CPU load:

show processes cpu sorted 1
show processes cpu hist

I left the default parameters as is:

ip igmp query-interval 60
ip igmp query-max-response-time 10
ip igmp querier-timeout 120
ip igmp snooping vlan 229 querier version 2

Configure IGMP querier (if not configured, all will receive multicast traffic, even those who do not request):

interface vlan 229
ip address 192.168.2.99 255.255.255.0
exit
ip igmp snooping vlan 229
ip igmp snooping vlan 229 querier
ip igmp snooping querier address 192.168.2.99
ip igmp snooping querier

Save the configuration:

exit
write
copy running-config startup-config

If any port floods multicast or unicast traffic, then you can block it, for example:

interface ethernet 1/28
switchport block multicast
switchport block unicast
storm-control multicast level 0.10

See also my articles:
Configure Cisco Catalyst 2960
Configuring Protected Ports

Leave a comment

Leave a Reply

Discover more from IT Blog

Subscribe now to keep reading and get access to the full archive.

Continue reading