Configuring Multicast on Eltex MES2324B

Once I needed to receive Multicast traffic from different TV providers and from different VLANs, so I had to use access-list in order to correctly transmit the igmp-report from the client to the required VLAN. If Multicast is in only one VLAN, then you can do without access-list.

I will give an example of my settings:

qos advanced ports-trusted
qos advanced-mode trust dscp
show qos
show qos interface GigabitEthernet1/0/23

ip access-list extended Cosmonova
 permit ip any any any 228.0.0.0 0.255.255.255 ace-priority 20
 permit ip any any any 235.0.0.0 0.255.255.255
exit
!
ip access-list extended Mediagroup
 permit ip any any any 239.32.4.0 0.0.0.255 ace-priority 20
 permit ip any any any 239.32.7.0 0.0.0.255
 permit ip any any any 239.32.11.0 0.0.0.255 
 permit ip any any any 239.32.44.0 0.0.0.255
 permit ip any any any 239.39.1.0 0.0.0.255
exit
!
class-map class2
 match access-group Cosmonova
exit                                                  
!
class-map class3
 match access-group Mediagroup
exit  
!
policy-map POL2
 class class2
  set vlan 2359
 exit
 class class3
  set vlan 2555
 exit
exit

show access-lists
show class-map
show policy-map
show multicast snooping groups count
show ip igmp counters
show ip igmp snooping groups
show ip igmp snooping mrouter
show ip igmp snooping interface 229

I will give an example of setting up ports, for example, I had various local Multicast tuners connected from ports 1 to 20, as well as devices that received Multicast from them, for example Teleste Luminato. Several VLANs from TV providers came to port 24, and clients who received this Multicast on ports 22-23:

interface gigabitethernet1/0/1
 loopback-detection enable 
 switchport access vlan 229 
exit
!
interface gigabitethernet1/0/2
 loopback-detection enable 
 switchport access vlan 229 
exit
!
...
interface gigabitethernet1/0/22
 loopback-detection enable 
 description DIPSYS_IPM6100
 service-policy input POL2 
 switchport mode customer 
 switchport customer vlan 3 
 switchport customer multicast-tv vlan add 2359,2555 
exit
!
interface gigabitethernet1/0/23
description TELESTE_LUMINATO_PORT_2
service-policy input POL2
switchport mode customer 
switchport customer vlan 3 
switchport customer multicast-tv vlan add 2359,2555
exit
!
interface gigabitethernet1/0/24
 loopback-detection enable 
 description UPLINK_MULTICAST
 switchport mode trunk 
 switchport trunk allowed vlan add 2359,2555 

Let’s make sure that the processor’s performance is sufficient and that it is not heavily loaded:

show cpu utilization

I will give an example of my IGMP settings:

bridge multicast filtering
ip igmp snooping
ip igmp snooping vlan 229 querier 
ip igmp snooping vlan 229 querier address 192.168.2.99 
ip igmp snooping vlan 2 
ip igmp snooping vlan 3 
ip igmp snooping vlan 229 
ip igmp snooping vlan 2359 
ip igmp snooping vlan 2359 mrouter interface gi1/0/24 
ip igmp snooping vlan 2555 
ip igmp snooping vlan 2555 mrouter interface gi1/0/24 

interface vlan 229
 ip address 192.168.2.99 255.255.255.0 
 ip igmp version 2 
exit

Note that in the Eltex MES2324B switch all ports are 1 Gbit/s, which is very important, since many devices are used and Multicast traffic from or to them can be more than 100 Mbit/s.

See also my article:
Configuring Eltex MES2324B

Leave a comment

Leave a Reply