Добавление ONT в Huawei iManager U2000

Приведу пример добавления ONT через Huawei iManager U2000.
На тесте использую ONT Alcatel-Lucent I-010G и OLT Huawei SmartAX MA5683T, на некоторых других ONT типа TP-Link возможно в последних пунктах нужно немного по другому настроить Service Port.

Предположим что мы настроили профили в iManager U2000 либо в консоли Huawei OLT, я же настроил их через консоль как писал в этой статье — Настройка Huawei SmartAX MA5683T через консоль.

Если настроили через консоль, то профили нужно сгенерировать в iManager U2000 открыв «NE Profile Management» — «GPON Profile«, далее где «GPON Line Profile«, «GPON Service Profile» и «DBA Profile» выбрать напротив нужных профилей «Generate Global Profile«.

И так, для добавления ONT после открытия U2000 Client:

1) Открываем Main Topology
2) Два раза нажимаем левой клавишей мыши по нужному OLT (например MA5683T)
3) Два раза нажимаем левой клавишей мыши по нужной GPBD плате
4) Один раз нажимаем левой клавишей мыши по нужному GPON порту чтобы выделить его
5) Внизу выбираем вкладку «ONU Info» и в правом нижнем углу жмем клавишу «Auto Discover ONUs»
6) В открывшемся окне выберем новый непрописанный ONT и нажмем кнопку «Confirm»
7) Укажем сгенерированные ранее профили «GPON Line Profile» и «GPON Service Profile«, в «Alias» напишем английскими буквами описание ONT, например адрес клиента, жмем «ОК«.
8) Теперь вверху два раза нажимаем левой клавишей мыши по нужному GPON порту, чтобы открыть его.
9) Скорее всего в самом низу списка будет новый прописанный только что ONT, выделим его левой клавишей мыши, выберем внизу вкладку «Service Port Info«, нажмем правую клавишу мыши по пустому месту этой вкладки и выберем «Add…»
10) В поле «Network Side«, где «VLAN ID (1-4095)» укажем номер клиентского VLAN, а в «User Side«, где «Service Type» выберем «Multi-Service VLAN» и укажем тот же номер клиентского VLAN, жмем «ОК».

Все, ONT прописан.
Осталось сохранить настройки, вернувшись вверху во вкладку «Main Topology» и после нажатия правой кнопки мыши по OLT (например MA5683T), выберем «Save Date Immediately«.

Настройка агрегации каналов на Huawei SmartAX MA5600

На тесте настрою агрегацию на двух портах Huawei SmartAX MA5683T и Cisco Catalyst 6509-E.

У меня трафик идет на один SFP порт 0/8/0, настроим агрегацию на него и следующий свободный порт 0/8/1:

link-aggregation 0/8 0 0/8 1 egress-ingress

Либо настроим на один порт, а потом добавим следующий:

link-aggregation 0/8 0 egress-ingress
link-aggregation add-member 0/8/0 0/8 1

Проверим:

display link-aggregation 0/8/0
display link-aggregation 0/8/1

Отменить можно агрегацию можно так:

undo link-aggregation 0/8/0

Или удалить командой порт из агрегации:

link-aggregation delete-member

На Huawei SmartAX MA5683T настройка агрегации двух портов завершена, в процессе настройки и после перебоев с трафиком не будет.

Теперь перейду к настройкt портов на Cisco Catalyst 6509-E.

Настрою первый порт как мне нужно, пропишу нужные VLAN и последней командой добавим порт в канал агрегации:

interface GigabitEthernet1/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
channel-group 1 mode on

Второй порт должен быть настроен аналогично и тоже последней командой добавим его в канал агрегации:

interface GigabitEthernet1/8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
channel-group 1 mode on

После команд выше автоматически создался выключенный интерфейс Port-channel1, командой description добавим ему примечание и включим его:

interface Port-channel1
description GPON OLT link aggregation
no shutdown

Теперь можно соединить оба порта Cisco с портами OLT MA5683T.

Все.

Смотрите также:
Настройка Huawei SmartAX MA5683T через консоль

Изоляция портов на коммутаторах Huawei

На тесте возьму коммутатор Huawei Quidway S2326TP-EI, в котором uplink порт GigabitEthernet 0/0/1 (на него приходит интернет), все остальные порты находятся в одном VLAN и нужно запретить им видеть друг друга. Для этого выполним команду port-isolate enable для каждого интерфейса (порта), кроме uplink GigabitEthernet 0/0/1.

Подключимся к коммутатору через консоль или telnet и перейдем в режим повышенных привилегий:

system-view

Выполним команду для интерфейсов:

interface Ethernet 0/0/1
port-isolate enable
interface Ethernet 0/0/2
port-isolate enable
interface Ethernet 0/0/3
port-isolate enable
и т.д.
interface Ethernet 0/0/24
port-isolate enable
quit
interface GigabitEthernet 0/0/2
port-isolate enable

Выйдем из режима настройки интерфейса:

quit

Выйдем из режима повышенных привилегий:

quit

Сохраним конфигурацию:

save

Теперь порты на которых прописана команда port-isolate enable не видят другие порты на которых тоже прописана эта команда, они видят только порты где она не прописана, то есть в нашем случае uplink порт GigabitEthernet 0/0/1, а он, так как на нем не прописана эта команда, видит все порты с командой и без.

Настройка коммутатора Huawei Quidway S2326TP-EI
Настройка Protected Ports на Cisco
Изоляция портов на коммутаторе ZyXEL

Установка Huawei iManager U2000 NMS в Windows Server

Опишу процедуру установки серверного программного обеспечения Huawei iManager U2000 NMS в Windows Server:

1) Запустим от имени администратора файла install.bat

2) Copyright. Читаем и соглашаемся с лицензионным соглашением выбрав «I accept the terms».

3) Select Language. Выбираем язык.

4) Select Installation Type. Укажем путь к файлу лицензий или снимем галочку чтобы указать его позже.

5) Configure Server. Укажем куда устанавливать сервер, вверху указан текущий IP-адрес под которым он будет работать.

6) Select Domain. Укажем галочку только на «Access domain».

7) Configure Parameters. Укажем «Default style», потом «Sequential mode».

8) Configure Database. Укажем путь где хранить данные и установим стандартные пароли «Changeme_123«.

По окончанию процесса установки откажемся от перезагрузки.
Изменим имя компьютера на U2000SERVER
Перезагрузим

Запустим U2000 Client
Введем логин admin и пароль Changeme_123, после чего будет предложено изменить его.
После изменения пароля укажем путь к файлу лицензий.

Пример SNMP параметров для OLT:

snmp-agent sys-info version v2c
snmp-agent community read public
snmp-agent community write private
snmp-agent target-host trap-hostname U2000SERVER address 10.11.x.x udp-port 162 trap-paramsname NMS
snmp-agent target-host trap-paramsname NMS v2c securityname NMS
snmp-agent trap enable standard

Откроем Main Topology, далее «File» — «Discovery» — «NE…»
В Default SNMP Parameter укажем шаблон default во вкладке SNMPv2 и нажмем ОК
Кнопкой Add укажем IP OLT и нажем Next, после чего OLT должен обнаружится и добавится в список.

Возможно будет мешать фаервол Windows, настроим правила SNMP Trap Service (UDP In) и другие, либо из командной строки Windows разрешим все входящие соединения для IP адреса OLT:

netsh advfirewall firewall add rule name="Allow from 192.168.1.25" dir=in action=allow protocol=ANY remoteip=192.168.1.25

В «Performance Monitoring Management» можно поставить на мониторинг сигналы ONT (NE — Access — GPON ONT — GPON ONU) и загрузку CPU, состояние памяти и температуру плат (NE — Access — Card — Board Health), после чего можно будет просматривать историю изменений в виде графиков или таблицы.

Примеры конфигурации для коммутаторов серии Huawei Sx300

Скачать Sx300_Series_Switches_Typical_Configuration_Examples(pdf)
Размер: 29Мб
Формат: PDF

Другая документация на официальном сайте

Причина сообщений «Failure: System is busy, please retry after a while» на Huawei OLT

Однажды при выполнении команд в консоли Huawei SmartAX MA5683T, начал часто замечать сообщение:

Failure: System is busy, please retry after a while

Как оказалось, причиной в моём случае был Zabbix, который ежечасно получал по SNMP уровни ONT и рисовал графики. SNMP запросы от него слались пачками по 30-50, отдельно для каждого порта. Решил проблему увеличив timeout в конфигурации Zabbix сервера и период проверки на больше часов, так как OLT медленно выдавал информацию, Zabbix недождавшись считал его недоступным, делал короткую паузу и снова слал запросы.
Также в настройках узла Zabbix нужно снять галочку «Использовать массовые запросы».