Резервное копирование конфигурации Cisco Catalyst 6500

Для теста набросал скрипт автоматического резервного копирования конфигурации Cisco Catalyst 6509-E.

Собственно сам скрипт:

#!/bin/bash
# Backup CISCO config
(
sleep 5
echo "user"
sleep 4
echo "password"
sleep 4
echo "copy running-config tftp:"
sleep 2
echo "192.168.1.4"
sleep 2
echo "cisco.cfg"
sleep 6

echo "exit"
) | telnet 192.168.1.5
mv /srv/tftp/cisco.cfg /backups/devices/cisco/`date +%Y-%m-%d`_cisco.cfg

find /backups/devices/cisco/ -type f -mtime +30 -exec rm {} \;

Содержимое скрипта добавим например в файл backup_cisco.sh и добавим его в cron, добавив указанную ниже строку в файл /etc/crontab:

0 2 * * * root /backups/scripts/backup_cisco.sh > /dev/null 2>&1

Файл можно открыть например в текстовом редакторе nano (Ctrl+X для выхода, y/n для сохранения или отмены изменений):

sudo nano /etc/crontab

Скрипт выполняет подключение по telnet к 192.168.1.5 и копирует конфигурацию на tftp сервер 192.168.1.4, потом файл перемещается в удобную директорию для хранения.
Последняя строчка в скрипте удаляет файлы старее 30 дней.
Как запустить tftp сервер смотрите в моих статьях: Установка и настройка TFTP сервера в Ubuntu или Запуск TFTP сервера на Windows.
Смотрите также: Использование и настройка CRON.

Настройка портов в коммутаторах Cisco

Для теста настрою порты на Cisco Catalyst 6509-E.

Приведу пример настройки Access порта (трафик идет только по одному указанному vlan без тега):

interface GigabitEthernet1/1
description TEXT
switchport
switchport access vlan 226
switchport mode access
no shutdown

Теперь приведу пример настройки Trunk порта (трафик идет по одному или нескольким vlan только с тегом):

interface GigabitEthernet1/2
description TEXT
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 207,228
switchport mode trunk
no shutdown

И третий вариант, Hybrid порт (трафик идет только по одному vlan без тега и по одному или нескольким vlan с тегом):

interface GigabitEthernet1/3
description TEXT
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 226
switchport trunk allowed vlan 207,226
switchport mode trunk
no shutdown

Чтобы указать параметры сразу для нескольких портов:

interface range GigabitEthernet1/1-24

Запретим автоматическое переключение порта в режим access или trunk:

interface range GigabitEthernet1/1-24
switchport nonegotiate
exit

Смотрите также мою статью — Настройка агрегации каналов на Cisco Catalyst 6500

Настройка Cisco PowerVu D9850

Основные функции можно настроить через клавиши и дисплей на передней панели устройства.
Стандартный IP-адрес обычно 192.131.244.5/24, шлюз 192.131.244.254.
Для входа в web-интерфейс используется стандартный логин user (маленькими буквами) и пароль USER (большими буквами).
Далее уже заполняются только телевизионные параметры.