Как ловить широковещательный флуд на коммутаторах FoxGate

Первым делом посмотрим статистику активного трафика на портах:

show interface ethernet counter rate

Потом посмотрим счетчики пакетов, особенно обратим внимание на колонку BroadCast(pkts):

show interface ethernet counter packet

Для конкретного порта несколько раз выполним команду просмотра статистики сетевого интерфейса:

show interface ethernet 1/25

И обратим внимание как изменяются входящие и исходящие значения broadcast packets, если не изменяются — значит широковещательные пакеты не идут через этот порт, если цифра быстро увеличивается, то возможно есть широковещательный шторм.

При необходимости перейдем в режим конкурирования и для нужных портов установим лимит передаваемых широковещательных пакетов в килобитах (минимальное значение 1):

config
Interface Ethernet1/1
storm-control broadcast 50
Interface Ethernet1/2
storm-control broadcast 50
Interface Ethernet1/3
storm-control broadcast 50
...

Замечу, что при низком лимите широковещательного трафика, широковещательные DHCP запросы от клиентов также могут блокироваться.

Смотрите также:
Блокировка DHCP серверов на коммутаторах FoxGate
Настройка коммутатора Foxgate S6224-S2

Изоляция портов на коммутаторах Foxgate

Для теста выполню настройку на коммутаторах Foxgate S6224-S4, S6224-S2, S6208 и т.д..

Подключимся к коммутатору через консоль или telnet и перейдем в режим конфигурации:

enable
config

Создадим группу изолированных портов и добавим в нее порты которые не должны видеть друг друга (в моем случае клиентские с 1 по 24):

isolate-port group users
isolate-port group users switchport interface ethernet 1/1-24

Команда аналогична на всех коммутаторах Foxgate, но могут отличатся номера портов, например на S6224-S2 я настраивал так:

isolate-port group users
isolate-port group users switchport interface ethernet 0/0/1-24

После добавления портов в группу они не будут видеть друг друга, но будут видеть порты которые не в группе, у меня 25 порт является аплинком по которому приходит интернет, так как он не в группе, то видит все порты, а порты которые в группах видят его.

Посмотрим список портов находящихся в группе users:

show isolate-port group users

Выйдем из режима конфигурации и сохраним настройки:

exit
write

Обновление прошивки FoxGate S6224-S4 R5

На тесте прошью коммутатор FoxGate S6224-S4(R5) с прошивкой 7.0.3.1(R0058.0010).
Заметил что на этой прошивке на нем часто отваливался Vlan интерфейс управления, при этом коммутатор функции свои выполнял, но был недоступен.

Посмотреть версию прошивки можно указанной ниже командой либо в web-интерфейсе на главной странице:

show version

Новые прошивки можно найти на сайте support.deps.ua.
Я прошивал этой — https://drive.google.com/open?id=0B6jR5-c775m9RGM5Ukc3QXl6eGs

Файл прошивки с расширением .img распакуем из архива и закачаем на tftp сервер.

Теперь на коммутаторе выполним команду копирования прошивки с tftp сервера:

copy tftp://192.168.1.5/FoxGate-S6224-S4(R5)_7.0.3.5(R0217.0104)_10.3.108.img nos.img

По завершению копирования перезагрузим его командой:

reload

Все. Коммутатор должен загрузится с новой прошивкой.
Настройки коммутатора после обновления прошивки не были изменены.

Можно также прошить через Web-интерфейс в меню Switch basic configurationFirmware updateTFTP client service, где тоже нужно указать адрес tftp сервера и имена файлов.

Смотрите также:
Запуск TFTP сервера на Windows
Установка и настройка TFTP сервера в Ubuntu

Настройка коммутатора Foxgate S6208

На тесте настрою коммутатор Foxgate S6208-S1(R2.0)

Подключимся к нему через консоль и перейдем в режим конфигурирования:

enable
config

Добавим пользователя:

username ПОЛЬЗОВАТЕЛЬ privilege 15 password 0 ПАРОЛЬ

Включим telnet:

telnet-server enable

Включим web интерфейс:

ip http server
authentication line web login local

Разрешим управлять коммутатором только с указанных IP:

authentication securityip 192.168.0.5
authentication securityip 172.16.99.99

Настроим SNMP и разрешим подключение только с указанных IP:

snmp-server enable
snmp-server securityip 192.168.0.5
snmp-server securityip 172.16.99.99
snmp-server community ro 0 public

Включим dhcp snooping, в дальнейшем мы будем им блокировать чужие DHCP:

ip dhcp snooping enable

Укажем время восстановления после обнаружения петли на порту:

loopback-detection control-recovery timeout 300

Добавим VLAN для управления (у меня он 207):

vlan 207
name core
exit

Добавим VLAN для пользователей:

vlan 226
name local_smart
exit

Настроим порты для пользователей (226 vlan без тега):

Interface Ethernet1/1-8
switchport access vlan 226
loopback-detection control shutdown
ip dhcp snooping action blackhole recovery 60

Настроим uplink порт (с него будет приходить интернет, все vlan с тегом):

Interface Ethernet1/9
switchport mode trunk
ip dhcp snooping trust

Пропишем IP в управляемом VLAN, чтобы подключатся к коммутатору дистанционно:

interface Vlan207
ip address 192.168.0.137 255.255.255.0

Если потребуется пропишем шлюз для IP который только что прописали:

ip default-gateway 192.168.0.1

Настроим параметры времени:

sntp polltime 12400
sntp server x.x.x.x
clock timezone Kiev add 2 0

Просмотреть информациию о коммутаторе можно командой:

show version

Посмотреть конфигурацию:

show running-config

Выходим из режима конфигурирования и сохраняем конфигурацию:

exit
write

Смотрите также:
Блокировка DHCP серверов на коммутаторах FoxGate

Инструкция по прошивке коммутаторов FoxGate через BootROM

Для прошивки коммутаторов FoxGate через BootROM опишу несколько простых шагов.

Шаг 1: Подключимся через консольный порт к коммутатору. Имеется ввиду что файлы прошивки у нас уже есть и они находятся на FTP/TFTP сервере.
Как запустить TFTP можно посмотреть в этих статьях:
Запуск TFTP сервера на Windows
Установка и настройка TFTP сервера в Ubuntu

Шаг 2: При включении коммутатора нажмем комбинацию клавиш «Ctrl+B«, это запустит BootROM меню.

Шаг 3: Выполним «setconfig» для назначения IP-адреса и маски сети коммутатору, указания IP адреса TFTP или FTP сервера. Дла проверки связи с сервером можно выполнить команду «ping».

Шаг 4: Выполним команды загрузки файлов прошивки в коммутатор:

load nos.img
write nos.img
load boot.rom
write boot.rom

Шаг 5: Выполним команду run или reboot для возврата в командный интерфейс. И укажем стартовые файлы:

config run
Boot File: [nos.img] nos.img
Config File: [boot.conf]

Все.

Список OID для коммутаторов FoxGate

Напишу ниже несколько популярных OID для коммутаторов FoxGate.

Использование процессора:

SNMPv2-SMI::enterprises.6339.100.1.11.10
switchCpuUsage

Температура:

SNMPv2-SMI::enterprises.6339.100.1.11.9
switchTemperature

Простой процессора в среднем за 5 секунд:

SNMPv2-SMI::enterprises.6339.100.1.11.2
switchCPUFiveSecondIdle

Простой процессора в среднем за 30 секунд:

SNMPv2-SMI::enterprises.6339.100.1.11.3
switchCPUThirtySecondIdle

Простой процессора в среднем за 5 минут:

SNMPv2-SMI::enterprises.6339.100.1.11.4

Простой процессора:

SNMPv2-SMI::enterprises.6339.100.1.11.5
switchCPUIdle

Размер памяти:

SNMPv2-SMI::enterprises.6339.100.1.11.6
switchMemorySize

Использовано памяти:

SNMPv2-SMI::enterprises.6339.100.1.11.7
switchMemoryBusy

Размер Flash:

SNMPv2-SMI::enterprises.6339.100.1.11.8
switchFlashSize

FDB таблица

.1.3.6.1.2.1.17.4.3.1
.1.3.6.1.2.1.17.7.1.2

Смотрите также:
Список SNMP OID и MIB для интерфейсов

Установка блока питания Mean Well PSC-60A с функцией UPS в Foxgate S6224-S4

Решили недавно установить блок питания Mean Well PSC-60A + не обслуживаемый свинцово-кислотный аккумулятор 12V 20Ah на коммутатор Foxgate S6224-S4.

В итоге:
Плата блока питания не совпадает по размерам с платой оригинального блока, из-за чего крепить ее пришлось на 1 болт.
Разъем со стороны 220V подошел (2pin), а разъем питания 12V (4pin, из которых идут сомкнутые на плате 2 плюс и так же 2 минус) не подошел.
Пришлось поменять местами в разъеме провода (без распайки, одним движением отвёртки) чтобы одной стороной надеть его на контакты блока (2pin, один плюс и один минус).
Контакты на блоке AC и Bat Low остались без использования.

При подключению аккумулятора к уже установленному блоку коммутатор не включился, после подключения кабеля 220V коммутатор начал работать, при отключении 220V коммутатор продолжал работать.

Вот так вот, в вообще лучше ставить блоки которые подходят по разъемам и размеру :)

Инструкция по прошивке коммутаторов FoxGate

На примере буду использовать коммутатор Foxgate S6224-S2.

Файлы прошивки закачиваем на tftp сервер и выполняем следующие команды на коммутаторе:

1) Копируем с tftp сервера загрузчик в коммутатор и перезагружаем его.

copy tftp://192.168.1.5/FoxGate-S6224-S2(S4)-4.12.1_boot.rom boot.rom
copy tftp://192.168.1.5/FoxGate-S6224-S2(S4)-4.12.1_config.rom config.rom
reload

2) Копируем с tftp сервера файл прошивки в коммутатор и снова перезагружаем его.

copy tftp://192.168.1.5/FoxGate-S6224-S2(S4)-6.2.139.45_nos.img nos.img
reload

Коммутатор должен загрузится с новой закачанной прошивки. Посмотреть ее версию можно выполнив на коммутаторе:

show version

Все. Настройки коммутатора после прошивки не были изменены.

Смотрите также:
Запуск TFTP сервера на Windows
Установка и настройка TFTP сервера в Ubuntu

Блокировка DHCP серверов на коммутаторах FoxGate

На примере возьму коммутатор FoxGate S6224-S4, на других моделях настройка почти аналогична.

Для начала включим функцию dhcp snooping:

ip dhcp snooping enable

Настроим режим блокировки на необходимых портах (выключение порта / отбрасывание пакетов):

interface ethernet 1/1-24
ip dhcp snooping action shutdown/blackhole
ip dhcp snooping action blackhole recovery 60
exit
interface ethernet 1/26-28
ip dhcp snooping action shutdown/blackhole
ip dhcp snooping action blackhole recovery 60
exit

Порт 25 в моем случае входящий, поэтому на нем разрешим прохождение DHCP пакетов от DHCP сервера:

interface ethernet 1/25
ip dhcp snooping trust
exit

Проверим сделанные настройки:

show ip dhcp snooping

Все, на данном примере блокируются пакеты от DHCP серверов на портах с 1 по 24 и с 26 по 28.

Для FoxGate S6224-S2 интерфейсы выбираются так:

interface ethernet 0/0/1-24
...
exit
interface ethernet 0/0/26
...
exit

Смотрите также:
Как ловить широковещательный флуд на коммутаторах FoxGate

Руководства для серии коммутаторов Foxgate 6200

Размер файла: 0.5 Мб
Скачать руководство по установке Foxgate 6200

Размер файла: 9 Мб
Скачать руководство по настройке Foxgate 6200

Размер файла: 6 Мб
Скачать руководство по командам Foxgate 6200