Обновление прошивки MikroTik устройств

Обновление прошивки MikroTik устройств достаточно легко выполнить, достаточно открыть web-интерфейс устройства или WinBox, выбрать в меню «System» — «Packages» и нажать кнопку «Check For Updates», если будет найдена новая прошивка, то жмем «Download & Upgrade», устройство само скачает прошивку с официального сайта и запустится с нее.

Для прошивки MikroTik устройств не на самую новую версию, или когда с устройства нет доступа в интернет, предлагаю выполнить следующие действия:

1) Скачать прошивку с официального сайта
https://www.mikrotik.com/download

2) Подключится через WinBox (не через web интерфейс!), в меню выбрать «Files», появится окно, в него просто перетащить мышкой файл прошивки с расширением *.npk и дождаться загрузки файла.

3) Перезагрузить маршрутизатор. Он должен будет запустится уже с новой прошивкой.

Готово.

Для понижения версии прошивки необходимо выполнить пункты 1 и 2, потом подключится к устройству через telnet и выполнить команду:

/system package downgrade

В случае неполадок можно восстановить маршрутизатор по следующей инструкции Восстановление MikroTik (RouterOS) с помощью NetInstall

Восстановление MikroTik (RouterOS) с помощью NetInstall

NetInstall используется для переустановки RouterOS когда она повреждена, неверно установлена или неизвестен пароль доступа.

Коротко опишу основные шаги:

1) Скачать NetInstall с официального сайта
https://mikrotik.com/download

2) Прописать компьютеру статический IP адрес, например 192.168.88.254

3) Соединить Ethernet кабелем маршрутизатор через ETH1 порт с компьютером используя коммутатор или напрямую.

4) Запустить приложение NetInstall. Нажать кнопку «Net booting», поставить галочку «Boot Server enabled» и ввести IP-адрес из той же подсети где находится компьютер, например 192.168.88.200, его NetInstall временно назначит маршрутизатору. Любой брандмауэр на компьютере должен быть отключен.

5) На отключенном от сети электропитания маршрутизаторе нажать кнопку «reset» и продолжая держать ее включить питание, ждать около пол минуты пока в программе NetInstall в списке устройств не появится новое устройство.

6) В «Packages» нажать кнопку «Browse» и указать директорию с прошивкой. В списке устройств (Routers/Drives) выбрать маршрутизатор, внизу в списке поставить галочку на прошивке которую нужно закачать в маршрутизатор и нажать кнопку «Install». Прошивка закачается в маршрутизатор и в статусе будет написано «Waiting for reboot», после чего вместо кнопки install будет кнопка reboot, ее и необходимо нажать.

Маршрутизатор загрузится с новой прошивкой. Если возникнут какие либо проблемы с загрузкой маршрутизатора, можно попробовать сбросить его на стандартные настройки подержав кнопку reset, либо если есть дисплей, выбрать «Restore settings» и ввести стандартный пин код 1234. Либо восстановить через Netinstall с снятой галочкой «Keep Old Configuration» и указав ниже свой «Configure script».

Настройка удаленного доступа в маршрутизаторах Mikrotik

Открыть «IP» — «Firewall» — вкладку «Filter Rules».
Нажать «Add new» для добавления нового правила.

Читать далее «Настройка удаленного доступа в маршрутизаторах Mikrotik»

Mikrotik CLI

Приведу некоторые примеры команд:

ПОЛЬЗОВАТЕЛИ.
По умолчанию для входа используется логин admin без пароля.
Добавление пользователя:

use add name=имя password=пароль group=full

Отключаемся чтобы зайти под новым пользователем:

quit

Отключение пользователя:

user disable admin

Просмотр пользователей:

user print

ИНТЕРФЕЙСЫ.
Просмотр интерфейсов:

interface print

Активация интерфейса:

interface enable 0

Назначение интерфейсу IP адреса:

ip address add address 172.17.1.199/24 interface ether1

Просмотр IP адресов:

ip address print

Изменение MTU интерфейсов:

interface set 0,1,2 mtu=1500

Изменение mac адреса интерфеса:

/interface ethernet set ether1 mac-address=00:01:02:03:04:05

Сброс mac адреса интерфеса:

/interface ethernet reset-mac ether1

Установка шлюза по умолчанию:

ip route add gateway=172.16.1.131

Просмотр маршрутов:

ip route print

Устанавливаем первичный и вторичный адреса DNS серверов:

ip dns set primary-dns=8.8.8.8 secondary-dns=8.8.4.4 allow-remote-requests=yes

Просмотр DNS параметров:

ip dns print

БЕСПРОВОДНЫЕ ИНТЕРФЕЙСЫ.
Просмотр беспроводных интерфейсов:

/interface wireless print

ВРЕМЯ.
Установка часового пояса:

system clock set time-zone=+2

Установка ip адреса ntp сервера с которым будет сверяться время:

system ntp client set enabled=yes primary-ntp=172.16.1.131

Просмотр времени:

/system clock print

ФАЕРВОЛ.
Настройка маскарадинга, чтобы чтобы внутренняя сеть не была видна с WAN порта:

ip firewall nat add chain=srcnat action=masquerade out-interface=интерфейс провайдера

Просмотр правил:

ip firewall filter print

Пример ограничения количества соединений с одного IP:

/ip firewall rule forward add protocol=tcp tcp -options=syn-only connection-limit=5 action=drop

Пример блокировки всех TCP пакетов идущих на порт 135:

/ip firewall rule forward add dst -port=135 protocol=tcp action=drop

Пример проброса портов:

/ip firewall dst-nat add action=nat protocol=tcp dst-address=10.0.0.217/32:80 to-dst-address=192.168.0.4

СИСТЕМА:
Просмотр стандартных настроек:

/system default-configuration print

Сброс настроек:

/system reset-configuration

Просмотр истории:

/system history print

СЛУЖБЫ.
Просмотр служб:

/ip service print

ПРОЧЕЕ.
Переход на уровень выше:

/

Выполнение команды из другого уровня без смены текущего:

/.

Помощь:

?

Настройка маршрутизатора с помощью мастера настроек:

setup

Пинг:

ping 192.168.1.2 count 3 size 512

Ctrl+X — вход и выход из безопасного режима.

Официальная страница загрузок http://www.mikrotik.com/download