Настройка Cisco Catalyst 2960

На тесте настрою Cisco Catalyst WS-C2960-24TT-L с прошивкой 12.2(25)FX

Подключимся к коммутатору консольным кабелем.
Из Windows для этого можно использовать программу Putty, из Linux можно использовать Minicom.

При первом подключении если будут задаваться вопросы — отвечаем no.

Перейдем в режим конфигурирования:

enable
configure terminal

Установим пароль на enable:

enable password PASSWORD

Включим хранение паролей в шифрованном виде:

service password-encryption

Если необходимо отменить какую нибудь команду, наберем её еще раз добавив перед ней no, например:

no service password-encryption

По желанию можно указать имя устройству:

hostname IXNFO

Настроим интерфейс для управления коммутатором в отдельном VLAN (я использую 207), ну или во VLAN 1 если у вас один коммутатор, а не большая сеть:

vlan 207
interface vlan 207
ip address 192.168.1.2 255.255.255.0
exit

При необходимости можно указать шлюз чтобы коммутатор можно было увидеть из других сетей (например в сети 192.168.1.0/24 его видно и без шлюза так как ему назначен IP адрес 192.168.1.2):

ip default-gateway 192.168.1.1

Настроим 25 входящий Uplink порт (vlan 207 для управления с tag, а vlan 226 для пользователей тоже с тегом):

interface gigabitEthernet 0/1
switchport trunk allowed vlan 207,226
switchport mode trunk
no shutdown
exit

Укажем vlan 226 без тега для портов клиентов:

interface range fastEthernet 0/1-24
switchport access vlan 226
switchport mode access
no shutdown
exit

Запретим автоматическое переключение порта в режим access или trunk:

interface range fastEthernet 0/1-24
switchport nonegotiate
exit

26 порт тоже настроим для клиентов:

interface gigabitEthernet 0/2
switchport access vlan 226
switchport mode access
no shutdown
exit

Как настраивать порты я описывал также в этой статье:
Настройка портов в коммутаторах Cisco

Настроим access-list со списком IP-адресов с которых будет разрешено управлять коммутатором:

ip access-list standard 11
permit 192.168.1.1
permit 192.168.1.50
exit

Установим пароль для входа по telnet, укажем timeout сессии и укажем созданный access-list чтобы разрешить управлять только указанным в нем IP-адресам:

line vty 0 4
login
password PASSWORD
exec-timeout 5 0
access-class 11 in
exit
line vty 0 15
password PASSWORD
login
exec-timeout 5 0
access-class 11 in
exit

Настроим SNMP (11 означает номер access-list, public — пароль для доступа по SNMP, RO (read only) — доступ только для чтения):

snmp-server community public RO 11

Настроим синхронизацию времени с NTP сервером и период обновления в секундах:

ntp server 192.168.1.1 version 2 source vlan 207
ntp clock-period 36028811
ntp max-associations 1
service timestamps log datetime localtime

По желанию можно отключить web интерфейс:

no ip http server

Любой из команд сохраним конфигурацию:

copy running-config startup-config
write

Пример просмотра текущей конфигурации и сохраненной:

show running-config
show running-config interface gigabitEthernet 0/1
show configuration
Did my article help you? How about buying me a cup of coffee as an encouragement? Buy me a coffe.

Оставьте комментарий

Добавить комментарий