Настройка Juniper MX204

В этой статье я приведу пример настройки Juniper MX204, аналогично можно настроить и другие Juniper серии MX (JunOS).

Подключимся к устройству консольным кабелем и запусти интерфейс командной строки (Command Line Interface, CLI):

cli

По умолчанию логин root без пароля.

Посмотрим текущую конфигурацию:

show configuration

Посмотрим информацию про комплектующие, использование CPU и памяти, температуру, версию JunOS и т.д.

show chassis hardware
show chassis routing-engine
show system memory
show system storage
show chassis environment
show version
show system information

Еще несколько примеры команд для просмотра прочей информации:

show system alarms
show system uptime
show system connections
show system errors active
show system users
show system resource-monitor summary
show system processes extensive
show subscribers summary
show subscribers extensive
show bridge mac-table

Переходим к конфигурированию:

configure

Чтобы выполнить команды CLI, не возвращаясь в CLI, добавим перед командой «run», например:

run show configuration

Укажем пароль пользователю root (после ввода команды понадобится ввести пароль):

set system root-authentication plain-text-password

Создадим нового пользователя admin (например, этим пользователем в дальнейшем будем подключаться по SSH):

set system login user admin authentication plain-text-password
set system login user admin class super-user

set system login user admin class ?
operator        permissions [ clear network reset trace view ]
read-only       permissions [ view ]
super-user      permissions [ all ]
unauthorized    permissions [ none ]

Укажем hostname:

set system host-name "test"
set system domain-name "ixnfo.com"

Назначим IP адрес для Ethernet порта управления (в него позже подключим кабель), а также укажем DNS сервер и маршрут по умолчанию:

set interfaces fxp0 unit 0 family inet address 192.168.24.200/24
set system name-server 1.1.1.1
set routing-options static route 0.0.0.0/0 next-hop 192.168.24.1
run show route

Чтобы применить любые изменения в конфигурации, необходимо выполнить команду «commit», например проверим конфигурацию и применим:

commit check
commit
commit ?
commit comment "ixnfo.com"

Если вы предполагаете что после подтверждения потеряется связь с устройством, то можно использовать команду «commit confirm», которая применит изменения и если не подтвердить второй раз, то изменения будут отменены например через 5 минут (10 минут по умолчанию если не указывать количество минут):

commit confirmed 5
commit

Отменить сделанные изменения можно командой rollback 0, или можно вернуть более старую конфигурацию:

run show system commit
rollback ?
rollback 0
rollback 1

Проверим связь командой ping:

run ping 192.168.24.1

Посмотрим конфигурацию сетевых интерфейсов:

edit interfaces
show

fxp0 {
    unit 0 {
        family inet {
            address 192.168.24.200/24;
        }
    }
}

Приведу пример удаления команды, например удалим IP адрес и применим изменения:

delete fxp0 unit 0 family inet address 192.168.24.200/24
commit
exit

Активируем ssh или telnet:

set system services ssh
set system services ssh port 2222
run show system connections extensive | match "22|2222" | match LISTEN
set system services telnet
show system services

Посмотреть кто еще редактирует конфигурацию можно командой:

status

Настроим время:

set system ntp server 192.168.5.5
set system time-zone Europe/Kiev

Пример сброса настроек и полной очистки конфигурации, лог файлов и прочего:

load factory defaults
request system zeroize

Примеры просмотра логов:

show log messages | last 30
show log cli-comands | last 30
show log user admin
show log ?
show system alarms
show system boot-messages

Перезагрузить устройство:

request system reboot

Смотрите также мои статьи:

Оставьте комментарий

Добавить комментарий