Настройка Juniper QFX5100

Для примера выполню настройку коммутатора Juniper QFX5100-24Q-AFO.

При подключении консольным кабелем скорость по умолчанию 9600, пользователь root без пароля.

Отключим автоматическое обновление ПО как я описывал в статье и укажем пароль root пользователю:
Решение failing auto-image upgrade

Перейдем в режим CLI:

cli

Посмотрим текущие параметры устройства:

show chassis hardware
show chassis fpc
show chassis fpc 0 detail
show chassis pic fpc-slot 0 pic-slot 0
show interfaces
show interfaces ?

Перейдем в режим конфигурирования:

configure

Настроим SSH и Telnet при необходимости:

set system services ssh
set system services ssh port 2222
run show system connections extensive | match "22|2222" | match LISTEN
set system services telnet
show system services

Добавим администратора которым будем подключаться по SSH или Telnet (замечу, что пользователем root нельзя подключаться):

set system login user admin authentication plain-text-password
set system login user admin class super-user

Настроим синхронизацию времени:

set system ntp server 192.168.5.5
set system time-zone Europe/Kiev

Время хранения arp записей в минутах:

set system arp aging-timer 5

Настроим SNMP:

set snmp community IXNFO.COM clients 192.168.5.5/32

Пример просмотра логов:

exit
show log ?
show log messages | last 50
show log user | last 50
show log chassisd | last 50
show log chassisd_snmp | last 50
show log cosd | last 50
show log interactive-commands | last 50
show log jddosd | last 50

show log dhcp_logfile | last 50
file list /var/log/
file delete /var/log/dhcp_logfile

Создадим необходимые списки vlan (на примере я создал users и core):

set vlans users vlan-id-list [226-228 301-302 501 599-612 700-776 778-800 943-1001 1050-1060]
set vlans core vlan-id 500
run show vlans

Приведу пример настройки Trunk порта (чтобы не перечислять vlan, можно указать имена списков vlan):

set interface et-0/0/7 vlan-tagging
set interface et-0/0/7 unit 0 family ethernet-switching interface-mode trunk
set interface et-0/0/7 unit 0 family ethernet-switching vlan members [ core users ]
edit interface et-0/0/7
set description UPLINK
set interface et-0/0/8 vlan-tagging
set interface et-0/0/8 unit 0 family ethernet-switching interface-mode trunk
set interface et-0/0/8 unit 0 family ethernet-switching vlan members users

Пример изменения MTU:

set interfaces et-0/0/7 mtu 9216

Для массовой настройки можно использовать команду «wildcard», приведу например удаления интерфейсов xe-0/0/9:0-3, а также xe-0/0/0-23:

edit interfaces
wildcard range delete xe-0/0/9:[0-3]
wildcard range delete xe-0/0/[0-23]:[0-3]

Еще пример:

wildcard range set interfaces et-0/0/[8-9] unit 0 family ethernet switching

Настроим порт управления em0 (С0), также коммутатор имеет SFP порт C1 для управления:

edit interfaces em0
set unit 0 family inet address 10.0.5.2/24
exit
set routing-options static route default next-hop 10.0.5.1

Проверим и применим конфигурацию (в этот момент пропадет связь примерно на 1 секунду):

commit check
commit confirmed 1
commit

Приведу примеры просмотра таблицы MAC адресов:

run show ethernet-switching table
exit
show ethernet-switching table vlan-id 220
show ethernet-switching table 3c:fd:00:bb:7f:00

Просмотр статистики:

show chassis routing-engine
show system processes extensive

Смотрите также мои статьи:
Настройка LAG на Juniper QFX5100
Другие мои статьи про Juniper

Оставьте комментарий

Добавить комментарий