Настройка коммутаторов Huawei Quidway S3900

Для примера возьму коммутатор Huawei Quidway S3928P-EI, настройки по сути подходят ко всей серии Huawei Quidway S3900, но могут немного отличатся в зависимости от версии прошивки. Если что-то не получается прописать, то можно посмотреть варианты команд набрав знак вопроса через пробел после любой команды.

У меня при включении коммутатора, через консоль отобразились следующие характеристики:

Creation date: Aug 25 2006
CPU type: BCM4704
CPU Clock Speed: 200MHz
BUS Clock Speed: 33MHz
Memory Size: 64MB

Посмотрим текущую конфигурацию командой:

display current-configuration

Чтобы перейти в режим конфигурации наберем:

system-view

По желанию укажем имя коммутатору:

sysname NAME

Добавим vlan для управления:

vlan 207
description Management
quit
management-vlan 207

Добавим vlan для пользователей:

vlan 226
description Users
quit

Добавим интерфейс в управляемом vlan:

interface Vlan-interface 207
ip address 192.168.1.2 255.255.255.0
quit

Добавим маршрут по умолчанию:

ip route 0.0.0.0 0.0.0.0 192.168.1.1

Настроим первый SFP порт как UPLINK:

interface GigabitEthernet 1/1/1
port link-type trunk
port trunk permit vlan 207 226
quit

Активируем функцию защиты от петель:

loopback-detect enable
loopback-detection interval-time 300

Настроим порты для абонентов, укажем нужные vlan и тип порта, настроим защиту от петель loopback-detect, ограничим широковещательный трафик до 30 pps:

interface Ethernet 1/0/1
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/2
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/3
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/4
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/5
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/6
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/7
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/8
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/9
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/10
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/11
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/12
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/13
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/14
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/15
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/16
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/17
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/18
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/19
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/20
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/21
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/22
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/23
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
interface Ethernet 1/0/24
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 30
quit

Также настроим оставшиеся гигабитные порты для клиентов:

interface GigabitEthernet 1/1/2
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 50
interface GigabitEthernet 1/1/3
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 50
interface GigabitEthernet 1/1/4
port link-type access
port access vlan 226
loopback-detect enable
loopback-detection shutdown enable
broadcast-suppression pps 50
quit

Добавим пароль администратора:

user-interface vty 0 4
authentication-mode password
set authentication password cipher PASSWORD
user privilege level 3
quit

Укажем NTP сервер для синхронизации времени:

ntp-service unicast-server 192.168.1.1 source-interface Vlan-interface 207

Настроим SNMP (например public с доступом для чтения):

snmp-agent
snmp-agent sys-info version v2c
snmp community read public

Когда все настроили выйдем в начальный режим, сохраним конфигурацию и укажем что она загрузочная:

quit
save config.cfg
startup saved-configuration config.cfg

Перезагрузим коммутатор:

reboot

Посмотреть таблицу MAC-адресов можно командой:

display mac-address

Смотрите также мои статьи:
Изоляция портов на коммутаторах Huawei
Блокировка сторонних DHCP серверов на Huawei Quidway S2300

Did my article help you? How about buying me a cup of coffee as an encouragement? Buy me a coffe.

Вливайтесь в общение

2 комментария

Добавить комментарий

  1. Подскажите реализацию dhcp relay option82 (а именно для s3952)

  2. Процентное ограничение
    interface Ethernet 1/0/1
    broadcast-suppression 10
    #Allow incoming broadcast traffic on the Ethernet1/0/1 port to occupy at most 10% of
    the bandwidth on the port.

    Ограничение в pps
    interface Ethernet 1/0/1
    broadcast-suppression pps 1000
    #Set the maximum number of broadcast packets that can be received per second by
    the Ethernet1/0/1 port to 1000 pps.

    Нужно проверить работает ли в Вашей конфигурации loopback-detection
    Зачастую без loopback-detect packet vlan XXX у Huawei не работает
    Так же loopback-detection shutdown
    Потушит порт, придётся включать только ручками
    Опять таки не уверен что для этой модели есть команда для восстановления состояния порта
    loopback-detect recovery-time 300
    Может не работать… нужно проверять