Однажды после очередного обновления в Medoc при заполнении данных контрагента из справочника возникла ошибка, меня попросили разобраться, это оказался баг, патч мне прислала поддержка Medoc и через пару дней выложили обновление для других пользователей, но пока я искал причину, обнаружил что в базе данных есть ошибки.
Читать далее «Medoc. Исправление ошибок базы данных»Архивы рубрик:Windows Server
DiskSpd. Меряем IOPS в Windows
DiskSpd — утилита для генерации нагрузки на дисковую систему и измерения ее производительности.
Читать далее «DiskSpd. Меряем IOPS в Windows»Решение ошибки «System error 1231 has occurred» при подключении сетевого диска
Однажды мне нужно было подключить сетевой диск чтобы сделать на него резервную копию системы, но возникла ошибка когда я выполнил команду подключения:
C:\Users\Administrator>net use K:\\192.168.0.5\dir /persistent:no /user:name password System error 1231 has occurred. The network location cannot be reached. For information about network troublesho oting, see Windows Help.
Позже я определил, что в свойствах подключения по локальной сети (также может называться Ethernet и Local Area Connection) сняты галочки с «Клиент для сетей Microsoft» и «Общий доступ к файлам и принтерам для сетей Microsoft».
После того как я отметил галочками эти компоненты и применил, диск успешно подключился:
C:\Users\Administrator>net use K:\\192.168.0.5\dir /persistent:no /user:name password The command completed successfully.
Ошибка 1231 может также отобразится, если например в фаерволе или на оборудовании провайдера блокируются порты Netbios, чтобы пользователи не видели общих дисков.
Смотрите также мою статью — Установка и настройка Samba в Linux
Настройка FTP-сервера в Windows Server 2008 R2
На тесте выполню настройку FTP-сервера в Windows Server 2008 R2.
Откроем «Диспетчер сервера», его можно найти в меню «Пуск» — «Администрирование».
Если установлена роль «Веб-сервер (IIS)», то выберем её и ниже нажмем «Добавить службы ролей» (не Добавить роли) отметим галочкой «FTP-Сервер» нажмем «Далее» и «Установить».
Если роль «Веб-сервер (IIS)» не установлена, то в «Роли» нажмем «Добавить роли», выберем «Веб-сервер (IIS)», снимем галочки с ненужных компонентов и отметим «FTP-Сервер», потом нажмем «Далее» и «Установить».
Откроем «Диспетчер служб IIS», нажмем «Добавить FTP сайт…», укажем любое имя и путь к директории где будут храниться данные, в следующем окне укажем каким пользователям разрешено подключаться.
Слева выберем созданный FTP сайт, откроем «Проверка подлинности FTP» и активируем «Обычная проверка подлинности».
На этом основная настройка FTP-сервера закончена и к нему можно подключаться.
Смотрите другие мои статьи на тему Windows Server.
Резервное копирование Windows Server 2008 R2
Для примера сделаю резервную копию Windows Server 2008 R2 и опишу процесс по пунктам:
1) Откроем «Диспетчер сервера (Server Manager)».
2) Выберем «Компоненты (Features)» — «Добавить компоненты (Add Features)», ставим галочки напротив «Система архивации данных Windows Server (Windows Server Backup)» и «Программы командной строки (Command-line Tools)», нажимаем кнопку «Установить (Install)» и ждем завершения установки.
3) Открываем меню «Пуск (Start)» и выберем «Система архивации данных Windows Server (Windows Server Backup)».
Для теста я нажал «Однократная архивация (Backup Once)», в появившемся окне выберем тип конфигурации «Настраиваемый (Custom)» и отметил галочками диск C и все кроме остальных локальных дисков если они есть (например диск D), в следующем окне можно выбрать тип хранилища куда будет записана резервная копия, например «Локальные диски» и указать диск D, либо «Удаленная общая папка (Remote shared folder) и указать путь, у меня как раз была запущена Samba на одном из Linux серверов, поэтому я подключил сетевую папку и выбрал этот вариант.
Смотрите также мою статью — Установка и настройка Samba в Linux
После завершения процесса на диске или сетевой общей папке появится папка «WindowsImageBackup» с резервной копией.
Для восстановления системы с этой резервной копии можно аналогично нажать меню «Пуск (Start)» — «Система архивации данных Windows Server (Windows Server Backup)» и выбрать эту резервную копию, либо если сервер не запускается, то запустить загрузочный диск с Windows, выбрать «Восстановление системы» и указать эту резервную копию.
Как добавить пользователя Windows из командной строки
Понадобилось однажды добавить пользователя в Windows 10 из командной строки, так как при нажатии кнопки добавления из панели управления ничего не происходило.
Первым делом запустим командную строку от имени администратора, для этого в меню пуск наберем «cmd» или просто найдем ярлык «Командная строка» и нажав по нему правой кнопкой мыши выберем «Запуск от имени администратора«.
В командной строке выполним команду добавления пользователя (где NAME — имя пользователя):
net user NAME /add
Все, нового пользователя уже можно увидеть в «Панель управления\Учетные записи пользователей\Учетные записи пользователей\Управление учетными записями«
Настройка VPN-сервера в Windows Server
На тесте приведу пример настройки VPN-сервера в Windows Server 2008 R2.
Первым делом установим роль:
1) Открываем диспетчер сервера и нажимаем на ссылку «Добавить роль«.
2) Выбираем роль «Службы политики сети и доступа» и нажимаем «Далее«.
3) Выбираем «удаленного доступа» и нажимаем «Далее«.
4) Нажимаем «Установить» и по завершению установки кнопку «Закрыть«.
Теперь перейдем к настройке:
1) Открываем диспетчер сервера, раскрываем ветку «Роли«, выбираем роль «Службы политики сети и доступа«, правой кнопкой мыши жмем по «Маршрутизация и удаленный доступ«, выбираем «Настроить и включить маршрутизацию и удаленный доступ«.
2) В первом окошке жмем «Далее«, в следующем выберем «Особая конфигурация«, жмем кнопку «Далее«, отметим галочками три пункта: «Доступ к виртуальной частной сети (VPN)«, «Преобразование сетевых адресов (NAT)» и «Маршрутизация локальной сети«, жмем «Далее» и «Готово«.
В появившемся окне нажмем «Запустить службу«.
3) Добавим пул адресов для клиентов, открыв «Диспетчер сервера» — «Роли» — «Службы политики сети и доступа«, правой кнопкой мыши жмем по «Маршрутизация и удаленный доступ» и выбираем «Свойства«.
Во вкладке «IPv4» выберем «Статический пул адресов» и добавим любой диапазон после нажатия кнопки «Добавить«.
Чтобы можно было подключиться к VPN серверу например с iPhone (по L2TP), во вкладке «Безопасность» поставим галочку на «Разрешить особые IPSec-политики для L2TP подключения» и укажем ключ.
4) Теперь настроим разрешения для пользователей. Переходим в «Диспетчер сервера — Конфигурация — Локальные пользователи и группы — Пользователи«:
Открываем «Свойства» нужного пользователя и во закладке «Входящие звонки«, где «Права доступа к сети» выбираем «Разрешить доступ«.
5) Добавим NAT правила, нужные маршруты и перезапустим службу, нажав правой кнопкой мыши по «Маршрутизация и удаленный доступ» — «Все задачи» — «Перезапуск«.
Для работы VPN используются и должны быть открыты порты:
TCP 1723 (для PPTP)
TCP 1701 и UDP 500 (для L2TP)
TCP 443 (для SSTP)
Готово.
Логи подключений можно увидеть в директории C:\Windows\System32\LogFiles
Решение ошибки «Virtual machine could not be started because the hypervisor is not running»
Заметил однажды на одном HP сервере, после установки Hyper-V, что не запускаются виртуальные рабочие станции выдавая при этом следующую ошибку:
Hyper-V Manager
An error occurred while attempting to start the selected virtual machine(s).
…
Virtual machine could not be started because the hypervisor is not running.
…
Как оказалось, проблемой была не включена в BIOS функция «Intel(R) Virualization Tech«, после изменения с «Disabled» на «Enabled» и запуска системы, виртуальные рабочие станции успешно запустились.
Установка Hyper-V
Опишу процедуру добавления роли Hyper-V в Windows Server:
Читать далее «Установка Hyper-V»Как разрешить Ping в Windows Server
Чтобы система Windows Server отвечала на PING запросы, необходимо разрешить их в брандмауэре.
Для этого, в брандмауэре откроем правило «File and Printer Sharing (Echo Request — ICMPv4-In)» и поставим галочку на «Включено(Enabled)«, аналогично для шестой версии «File and Printer Sharing (Echo Request — ICMPv6-In)«.
Чтобы система отвечала на PING запросы только конкретным IP, там же в настройках правила во вкладке «Scope«, где «Remote IP Address» нажимая «Add» укажем нужные IP-адреса.
Из командной строки настроить это правило можно так:
netsh advfirewall firewall set rule name= "File and Printer Sharing (Echo Request — ICMPv4-In)" new enable=yes action=allow profile=any remoteip=192.168.5.0/24
Либо так (включение/выключение):
netsh firewall set icmpsetting 8 netsh firewall set icmpsetting 8 disable
Из PowerShell так:
Set-NetFirewallRule -Name FPS-ICMP-ERQ-In -Enabled True -Profile Any -Action Allow