Zabbix. Мониторинг непрочитанных email

В подпапку VoiceMail во Входящих email приходили сообщения голосовой почты, которые должны прослушивать операторы и отвечать на обращения пользователей, но иногда никто их не читал, по этому понадобилось мониторить количество непрочитанных email.

Читать далее «Zabbix. Мониторинг непрочитанных email»

Zabbix. Слежение за изменениями прав директории

Допустим вы указали права и владельца на определённую директорию и хотите чтобы никто их не изменял, для этого будем следить за ней через Zabbix-agent.

Читать далее «Zabbix. Слежение за изменениями прав директории»

Не завершается процесс Zabbix-server

Однажды я выполнил обновление Ubuntu server и Zabbix-server выполнив apt update, apt upgrade, по окончанию обновления согласился с перезапуском всех обновленных служб, но Zabbix-server продолжал быть запущенным 20 минут и не перезапускался.

Читать далее «Не завершается процесс Zabbix-server»

Zabbix ERROR 1273 (HY000) at line 483: Unknown collation: ‘utf8mb4_unicode_ci’

Однажды я переносил базу данных Zabbix сервера на другой сервер и возникла ошибка:

Читать далее «Zabbix ERROR 1273 (HY000) at line 483: Unknown collation: ‘utf8mb4_unicode_ci’»

Can’t open PID file /run/zabbix/zabbix_server.pid (yet?) after start: No such file or directory

Однажды на одном Ubuntu 18.04.6 LTS я обновлял Zabbix сервер до версии 6.0 LTS и новая версия не запустилась.

Читать далее «Can’t open PID file /run/zabbix/zabbix_server.pid (yet?) after start: No such file or directory»

Мониторинг размера директории Linux в Zabbix

Однажды мне понадобилось мониторить размер директории в Zabbix и сделать триггер, чтобы Zabbix оповещал когда размер директории будет увеличен.

Читать далее «Мониторинг размера директории Linux в Zabbix»

Zabbix: icmpping «Ping item must have target or host interface specified»

Однажды обновил Zabbix до версии 6.4 и заметил, что шаблон «Template ICMP Ping» перестал работать на новых устройствах, на старых он продолжал работать, а вот если добавить новое устройство, то отображалось предупреждение:

Читать далее «Zabbix: icmpping «Ping item must have target or host interface specified»»

Zabbix. Обновление базы данных до первичных ключей

Начиная с версии Zabbix 6.0 первичные ключи используются для всех таблиц в новых установках, но так как я обновлял Zabbix сервер до версии 6.4, то после обновления мне пришлось еще вручную обновить таблицы.

Перед обновлением в первую очередь откроем меню «Отчет» — «Информация о системе» и убедимся что ключи не используются, об этому будет свидетельствовать запись — «Database history tables use primary key — Нет», если ключи используются, то этой записи просто не будет.

Читать далее «Zabbix. Обновление базы данных до первичных ключей»