How to Configure Cisco C1121X-8P

Once I was asked to configure Cisco ISR C1121X-8P, this router model had only a MicroUSB console port, a regular cable was suitable for connection, a COM8 port appeared in the device manager, to which I was able to connect via putty at a speed of 9600.

enable
show running-config
configure terminal

hostname ixnfo.com
enable secret PASSWORD

ip domain-name myrouter.local
crypto key generate rsa modulus 2048
username admin secret PASSWORD
ip ssh version 2
line vty 0 4
 login local
 transport input ssh

Then I configured the WAN port:

interface GigabitEthernet0/0/0
description WAN
ip address dhcp
ip nat outside
no shutdown

Configured DHCP and NAT:

ip dhcp excluded-address 192.168.100.1 192.168.100.10
ip dhcp pool LAN-POOL
 network 192.168.100.0 255.255.255.0
 default-router 192.168.100.1
 dns-server 1.1.1.1 8.8.4.4

access-list 1 permit 192.168.100.0 0.0.0.255
ip nat inside source list 1 interface GigabitEthernet0/0/0 overload

The second one was configured as a backup WAN, since the switchport command is not applicable to it and it cannot be combined with the other eight ports (or I think you can configure a separate IP address with a separate DHCP on it, in theory it should work):

interface GigabitEthernet0/0/1
description WAN2
ip address dhcp
ip nat outside
no shutdown

Created interface vlan 1:

interface vlan 1
ip address 192.168.100.1 255.255.255.0
ip nat inside

Example of setting up eight LAN ports (default ports are in vlan 1, it is enough to specify mode access):

interface GigabitEthernet0/1/0
switchport mode access
switchport access vlan 1
no shutdown

interface range GigabitEthernet0/1/0 - 0/1/7
switchport mode access
switchport access vlan 1
no shutdown
exit

Examples of saving configuration:

write memory
copy running-config startup-config

Example of viewing various information:

show interfaces GigabitEthernet0/0/1 switchport
show ip interface brief
show ip route
show version
show ip interface brief
show running-config

An example of enabling an http server where you can view various statistics:

ip http server
ip http authentication local

See my other articles about Cisco

Leave a comment

Leave a Reply