Configuring Storm Control on Alcatel OmniStack LS 6224

In this article I will give an example of setting up broadcast and multicast control on the Alcatel OmniStack LS 6224 switch.

Connect to the switch and go into the configuration mode:

enable
configure

Select the ports on which you want to enable Storm Control:

interface range ethernet e1-24

Turn on the control of broadcast traffic and specify a limit of 70 kilobits per second:

port storm-control broadcast enable
port storm-control broadcast rate 70

If you want to limit also multicast traffic, then execute the following command:

port storm-control include-multicast

The standard value is 3500, the possible range for ethernet ports is 70 – 100000, for gigabit ports 3500 – 1000000.

Now it remains to exit the configuration mode and save the configuration:

exit
exit
copy running-config startup-config

To see the data of the packet counters on the port, for example:

show interfaces counters ethernet g1

Firmware Upgrade Alcatel OmniStack LS 6224

I will describe the process of updating the firmware on Alcatel OmniStack LS 6224.

Let’s connect to the device and switch to the mode of elevated privileges:

enable

See the current firmware version:

show version

We look at what firmware versions are downloaded and what is active:

show bootvar

See how much memory is free:

dir

Run the command to copy the firmware file from the TFTP server to the switch:

copy tftp://10.0.0.18/alc6224-1.7.1.12.img image-2

I had an active firmware image-1, so I saved a new one like image-2.
I used this version of the firmware – 1.7.1.12

Let’s make an active uploaded firmware:

boot system image-2
show bootvar

We reboot the switch:

reload

After reboot, the switch will boot with the new firmware.

If necessary, the firmware file can also be copied from the switch to TFTP:

copy image-1 tftp://10.10.0.18/image-1

How to start the TFTP server I described in these articles:
Installing and Configuring a TFTP Server in Ubuntu
Starting a TFTP server in Windows

Reset Alcatel OmniStack LS 6224

I will describe examples of resetting the settings on the Alcatel OmniStack LS 6224 in several ways.

1) Connect to the device and execute the command to delete the configuration and restart:

enable
delete startup-config
reload

Just in case, before deleting the configuration, you can make a backup copy to the tftp server or locally:

copy startup-config tftp://10.10.0.18/startup-config 
copy startup-config startup-config-backup
dir

To return it is possible so:

copy tftp://10.10.0.18/startup-config startup-config
copy startup-config-backup startup-config

2) If the password for the switch is unknown, then connect to it with a console cable, the speed is usually 9600.
Turn on the power switch, waiting for the message:

Autoboot in 2 seconds – press RETURN or Esc. to abort and enter prom.

When the message appears – press the “Enter” or “Esc” key, in the resulting menu select “[3] Password Recovery Procedure”, then “[7] Back” and wait for the device to start.

After that, the switch will start and will not ask for the password, just delete the configuration as I wrote above or change the password to the user:

enable
configure
username admin password PASSWORD level 15
exit
copy running-config startup-config
reload

Configuring Loopback Detection on Alcatel OS-LS 6200

For example, configure Loopback Detection on the Alcatel OmniStack LS 6224 switch.

Let’s look at the current settings for Loopback Detection:

enable
show loopback-detection

Let’s go into the configuration mode, enable and specify some parameters of Loopback Detection:

configure
loopback-detection enable
loopback-detection mode src-mac-addr
loopback-detection interval 30

Turn on the client ports Loopback Detection:

interface range ethernet e1-24,g2-4
loopback-detection enable
exit

g1 I have an uplink, so I did not enable Loopback Detection on it.

Let’s configure automatic activation of the port after 3000 seconds, if it was turned off due to the loop (you can specify the value in seconds 30-86400, standard 300):

errdisable recovery interval 3000
errdisable recovery cause loopack-detection
show errdisable recovery
show errdisable interfaces

Exit the configuration mode and save the configuration:

exit
copy running-config startup-config

Configuring the Alcatel OmniStack LS 6224

By the way, console cable for Huawei and D-Link switches (for example S2326TP, DES-3200) did not approach the Alcatel OmniStack LS 6224, because it does not use the first contact.
When I assembled the working cable according to the scheme, it did not work through the Chinese USB-RS232 adapter, so I had to connect directly to the COM port of the computer.
The standard connection speed is 9600-8-N-1.

The circuit on which I assembled the cable:
1 – white-brown
2 – green
3 – white-green
4 – orange
5 – blue and white-blue
6-4 – jumper
7 – white-orange
8 – brown

Where the digits are RS-232, but I crimped the RJ45 according to the standard)

After connecting to the switch, we will switch to the mode of elevated privileges:

enable

Let’s look at the existing configuration:

show running-config
show startup-config

Now go into the configuration mode:

configure

Add the necessary VLANs (207 for my management, 226 for clients):

vlan database
vlan 207
vlan 226
exit

We will configure the incoming uplink port as a trunk and specify the necessary VLANs:

interface ethernet g1
switchport mode trunk
switchport trunk allowed vlan add 207
switchport trunk allowed vlan add 226
exit

Let’s configure the ports for clients:

interface range ethernet e1-24,g2-4
switchport mode access
switchport access vlan 226
exit

The specific port can be configured as follows:

interface ethernet e24
switchport mode access
switchport access vlan 226
exit

Assign an IP switch to the VLAN to manage:

interface vlan 207
name core
ip address 10.0.20.20 255.255.255.0
exit

Configure authorization (without login by password):

aaa authentication login default line
aaa authentication enable default line
line console
password PASSWORD
line telnet
password PASSWORD
line ssh
password PASSWORD
exit

If necessary, generate a key and enable the ssh-server:

crypto key generate dsa
ip ssh server

If necessary, to authorize via HTTP, add the user (level 15 is the highest):

ip http authentication local
username admin password PASSWORD level 15

You can also configure HTTPS:

ip https authentication local
username admin password PASSWORD level 15

Generate the certificate and enable HTTPS:

crypto certificate generate key_generate
ip https server

Exit the configuration mode and save the configuration:

exit
copy running-config startup-config

See also:
Configuring Loopback Detection on Alcatel OS-LS 6200
Configuring Storm Control on Alcatel OmniStack LS 6224

How to crimp a twisted pair connector RJ45 / 8P8C

Crimping the connector is carried out with a special crimping tool (crimping pliers), in extreme cases if they are not available you can use a flat thin screwdriver. First carefully remove the 3 centimeters of the upper braid cable, weave pairs of conductors and align in a row according to the standard that we need. Superfluous ends cut off to about 1cm remained. We put it into the connector so that the conductors have reached the very end of the connector and have rested, the outer insulation of the cable should also as far as possible go into the connector. We check that the colors are not messed up when inserting, we insert it into the crimper and squeeze. Done.

Twisted pair crimp standards:
1) direct link, the most used, is often used to connect a computer with a switch, a router, etc. Both connectors are crimped the same way.
white-orange / orange / white-green / blue / white-blue / green / white-brown / brown

rj45

2) cross-link, it is used to connect two computers to each other, but in our time computers can be connected and the cable is compressed by the standard above, so it is used quite rarely. One connector is crimped as indicated below, the second as indicated above.
white-green / green / white-orange / blue / white-blue / orange / white-brown / brown

How to find iPhone from a computer?

To see from the computer where the iPhone is located:

1) The iPhone must be allowed access to the Find iPhone service.
You can check this by opening Settings – Privacy – Geolocation Services – System Services – Find iPhone.

2) The Internet should work on the iPhone.

3) To view the location of the iPhone, you must sign in to iCloud using your login and password, select on the page that opens “Find iPhone”, then the map with the marked iPhone location will open. You can also see the level of battery power, remotely play an audio signal, erase all data, or enable the loss mode.

The Find iPhone service can also be enabled on other Apple devices, such as the iPad, MacBook, Apple Watch, etc.
Through the installed standard application “Find iPhone” you can see these devices.
By the way, to share your location with other users, there is a separate application “Find Friends”.

The solution of the “System error 1231 has occurred” when connecting a network drive

I once needed to connect a network drive to make a backup copy of the system, but an error occurred when I executed the connection command:

C:\Users\Administrator>net use K:\\192.168.0.5\dir /persistent:no /user:name password
System error 1231 has occurred.
The network location cannot be reached. For information about network troublesho
oting, see Windows Help.

Later I determined that in the connection properties on the local network (also called Ethernet and Local Area Connection), the checkboxes for “Client for Microsoft Networks” and “File and Printer Sharing for Microsoft Networks” were removed.

After I ticked these components and applied, the disk successfully connected:

C:\Users\Administrator>net use K:\\192.168.0.5\dir /persistent:no /user:name password
The command completed successfully.

Error 1231 can also be displayed if, for example, the Netbios ports are blocked on the firewall or on the provider’s equipment so that users do not see the shared disks.

See also my article – Installing and Configuring Samba on Linux

Solving the problem of resetting the contrast after upgrading Windows 10

Once my Windows 10 installed another update, at the end of 2017, I did not remember which version the update was made on.
Immediately after the update, the computer rebooted and at startup I noticed that the screen became darker, the contrast increased, the black color became really black, almost like on Apple devices, but in fact the colors became not natural and it was not really possible to work with graphics.
For the test, I ran a few games and noticed that when moving a character to CS:GO for example, on some maps, the chart becomes so dark that you can forget about the game.
At that time, the Asus GeForce GTX 1060 Dual 6GB video card was installed on the computer, tried to switch color profiles in the NVIDIA panel, auto contrast correction turned off, but after restarting the computer the problem appeared again.
After I pulled out the video card, the integrated Intel® HD Graphics 630 had the same problem and setting parameters in the panel did not help.
Updating drivers for both video cards did not work either.

As it turned out, along with the update, Microsoft added Calibration Loader to the autorun via Task Scheduler, it just spoiled everything.

To solve the problem, I disabled it in the task scheduler.

You can find the “Calibration Loader” by clicking “Start” – “Task Scheduler”, go to \Microsoft\Windows\WindowsColorSystem, where I saw:

Name: Calibration Loader
Location: \Microsoft\Windows\WindowsColorSystem
Author: Microsoft Corporation
Description: This task uses color calibration options.

In the “Triggers” tab, you must disable both the “Log on” and “When connecting to a user session” flip-flops. This can be done by selecting the trigger, clicking the “Change” button below and unchecking the “Enabled” checkbox.

After that, without the Calibration Loader everything began to be displayed well.