Once on one mail server I noticed a message delivery error:
Undelivered Mail Returned to Sender
SMTPUTF8 is required, but was not offered by host
In my case, the error occurred due to the fact that a mail server that accepted a letter of a very old version and does not support SMTPUTF8, by default SMTPUTF8 is enabled in newer Postfix versions (> 3.0). As defined in RFC 6531 (SMTPUTF8 extension), RFC 6532 (Internationalized email headers), RFC 6533 (Internationalized delivery status notifications).
Let’s see the current Postfix version:
postconf mail_version
postconf -d | grep mail_version
You can disable SMTPUTF8 by specifying in the /etc/postfix/main.cf file:
smtputf8_enable = no
To apply the changes, run the command:
postfix reload
If the smtputf8_enable option is not present in the /etc/postfix/main.cf configuration file and Postfix is newer than 3.0, then SMTPUTF8 is enabled by default. Personally, I have SMTPUTF8 enabled on mail servers.
Also if the error occurs on the local server, for example:
SMTPUTF8 is required, but was not offered by host 127.0.0.1
then this may mean that for example SMTPUTF8 is enabled in Postfix but disabled in Amavis.
