Настройка Cisco N3K-C3064PQ-10GX

Для примера настрою коммутатор Cisco Nexus N3K-C3064PQ-10GX.

Коммутатор имеет 48 портов SFP+ 10 Gb/s и 4 QSFP+ 40 Gb/s, для соединения между коммутатором и серверами я использую DAC кабеля до 5м, но можно также использовать более длинные AOC оптические.

При первом подключении через консоль, я указал пароль для пользователя admin:

2020 Oct 12 08:42:06 switch %$ VDC-1 %$ %POAP-2-POAP_INFO:   - Abort Power On Auto Provisioning [yes - continue with normal setup, skip - bypass password and basic configuration, no - continue with Power On Auto Provisioning] 

Do you want to enforce secure password standard (yes/no): yes

  Enter the password for "admin":
  Confirm the password for "admin":
  
  Would you like to enter the basic configuration dialog (yes/no): no

Переключился в режим конфигурирования и указал файл прошивки:

configure terminal
show incompatibility nxos bootflash:nxos.7.0.3.I4.6.bin
boot nxos bootflash:/nxos.7.0.3.I4.6.bin
exit

Сохранил конфигурацию, перезагрузил коммутатор и убедился что он загрузился с указанной ранее прошивки:

copy running-config startup-config
 reload
This command will reboot the system. (y/n)?  [n] y

Далее посмотрим текущую и сохраненную конфигурации:

show running-config
show startup-config

Во время включении коммутатора при необходимости можно перейти в режим загрузчика:

Press  ctrl L to go to loader prompt in 2 secs

Из загрузчика также можно вручную запустить коммутатор с указанной прошивки:

loader>boot bootflash:nxos.7.0.3.I4.6.bin

Или так:

switch(boot)#load bootflash:nxos.7.0.3.I4.6.bin

Сразу выберем режим портов, так как после этого действия необходима перезагрузка устройства (например я обычно использую 48x10g+4x40g):

hardware profile portmode ?
hardware profile portmode 64x10G
hardware profile portmode 48x10g+4x40g
exit
reload

Добавим необходимые VLAN и при необходимости описания:

vlan 207
name Management
vlan 300
name Users
exit

Приведу примеры настройки access и trunk портов:

interface Ethernet1/1
switchport
switchport mode access
description ixnfo_com
switchport access vlan 300
storm-control broadcast level 0.50

interface Ethernet1/2
switchport
switchport mode trunk
switchport trunk allowed vlan 207,300

Приведу пример настройки гибридного порта, Vlan 300 без тега, а все остальные vlan с тегом:

switchport mode trunk
  switchport trunk native vlan 300
  switchport trunk allowed vlan 207-209,300

По умолчанию порты 1-48 настроены на скорость 10 Gb/s, чтобы подключить 1 Gb/s укажем:

interface ethernet 1/1-44
speed 1000
interface ethernet 1/45-48
speed 10000

Укажем часовой пояс и ntp сервер для синхронизации времени:

ntp server 192.168.5.50
clock timezone UTC 2 0
show clock

Настроим SNMP:

snmp-server community ixnfo ro

Если будут создаваться interface vlan (SVI), то активируем feature interface-vlan:

show feature
feature interface-vlan

Приведу пример создания interface vlan (SVI):

vlan 207
exit
interface vlan 207
description ixnfo.com
ip address 10.0.0.2/24
ip address 192.168.5.5/24 secondary
no ip redirects
no shutdown
exit

Пример указания маршрута по умолчанию:

ip route 0.0.0.0/0 10.0.0.1

Или:

vrf context default
ip route 0.0.0.0/0 10.0.0.1

Пример настройки mgmt порта:

int mgmt 0
ip address 192.168.5.5/24
exit
vrf context management
ip route 0.0.0.0/0 192.168.5.1
exit
ping 192.168.5.55 vrf management

Можно указать hostname:

hostname IXNFO_COM

Приведу примеры просмотра различной информации:

show version
show system uptime
show system resources
show boot variables
show banner motd
show feature
show vdc membership
show running-config copp all
show running-config interface ethernet 1/1-10
show interface ethernet 1/1 transceiver details
show interface ethernet 1/1 capabilities
show interface ethernet 1/1-10
show int status mod 3
show interface status
show interface brief
show interface Ethernet1/52
show interface Ethernet1/52 brief
show processes cpu
show processes log
show processes log details
show processes memory
show logging
show cli history
show install all status
dir
show sprom all
show inventory
show module
show environment
show environment power
show environment fan
show environment fan detail
show environment temperature
show license
show system reset-reason
show terminal

Uptime коммутатора можно посмотреть командой:

show version

Разрешим использование SFP модулей от сторонних производителей:

service unsupported-transceiver

Также при использовании сторонних SFP и DAC кабелей я указывал команды ниже для интерфейсов, так как без них либо не было линка, либо он пропадал через некоторое время, например:

interface ethernet 1/52
no negotiate auto
duplex full

Также можно выключить flow-control если он не выключился автоматически:

no flowcontrol receive
no flowcontrol send

Настроим завершение консольных сессий через 30 минут:

line console
exec-timeout 30

Пример ограничения доступа к коммутатору по IP адресам:

ip access-list ixnfo
permit ip 10.0.0.1/32 any
permit ip 192.168.15.15/32 any

line vty
exec-timeout 30
access-class ixnfo in

Пример активации telnet (но я рекомендую использовать ssh):

feature telnet

Для очистки конфигурации используется команда:

write erase

Пример копирования текущей и сохраненной конфигурации на TFTP сервер:

copy running-config tftp://ixnfo.com/running-config.bak
copy startup-config tftp://ixnfo.com/startup-config.bak

Пример восстановления конфигурации с TFTP сервера:

copy tftp://ixnfo.com/running-config.bak running-config

Смотрите также мои статьи:
Скрипт резервного копирования Cisco Nexus 3064
Настройка Jumbo Frame на Cisco Nexus 3064
Настройка DHCP Relay на Cisco Nexus 3064
Агрегация каналов LACP на Cisco Nexus 3064
Настройка Cisco Catalyst 6509-E
Настройка Cisco устройств

Вливайтесь в общение

4 комментария

Добавить комментарий

  1. Здравствуйте.
    Вячеслав, процесс настройки в Вашей статье практически полностью совпадает с моими настройками N3K-C3064PQ-10GX. Но моя железка продолжает через 10-25 минут отключать 10G sfp (совместимые). Может сможете помочь советом?

    1. Здравствуйте. Посмотрите логи и детальную статистику по sfp модулю там скорее всего можно увидеть причину, ну и я так понял у Вас указаны вручную скорость, дуплекс, отключено автосогласование, примеры команд в статье есть. Еще может быть плохой оптический сигнал и пропадать линк.

      1. Благодарю за ответ!
        У нас нет возможности обращаться в Cisco TAC за помощью по ряду причин. Поэтому ищем пути решения самостоятельно.

        Да, скорость, дуплекс и автосогласование отключены согласно Ваших рекомендаций.
        Самое интересное, что если использовать 1Г трансиверы, такое поведение отсутствует, даже при включенном автоматическом согласовании.

        «Залипание» портов «лечится» только перезагрузкой. NS-OS уже установили крайнюю, с сайта производителя.

        Software
        BIOS: version 5.0.0
        NXOS: version 9.3(7)
        BIOS compile time: 06/05/2018
        NXOS image file is: bootflash:///n3000-compact.9.3.7.bin
        NXOS compile time: 3/10/2021 3:00:00 [03/10/2021 15:39:29]

      2. Здравствуйте, Вячеслав!
        Благодарю за Ваш отклик!
        Увлекся поиском решения и не ожидал что Вы так быстро ответите.

        Да, порты с двух сторон настроены с отключенным автоматическим согласованием и «прибиты гвоздями» скорость и дуплекс.
        Получается следующее, что при пока невыясненной ситуации происходит «залипание» 10Г портов (с 1Г это не замечается), причем абсолютно всех, которые на данный момент подключены. «Лечится» только перезагрузкой. По индикации порт светится «оранжевым» цветом.
        По объективным причинам, я не могу общаться с Cisco ТАС. Ищем решение самостоятельно.

        Версия установлена крайняя, с сайта производителя.

        Software
        BIOS: version 5.0.0
        NXOS: version 9.3(7)
        BIOS compile time: 06/05/2018
        NXOS image file is: bootflash:///n3000-compact.9.3.7.bin
        NXOS compile time: 3/10/2021 3:00:00 [03/10/2021 15:39:29]

        Хотя до этого была рекомендуемая. Максимум по времени, коммутатор работал без залипания 3 недели. Но последнее время участились случаи отказа, пришлось отключить одно плечо.

        Логи ниже, но пока мне не понятна причина (три последние записи с истории самого порта).
        186) Event:ESQ_REQ length:38, at 648542 usecs after Thu Mar 18 12:42:58 2021
        Instance:0x1A000000, Seq Id:0x1, Ret:SUCCESS
        [E_MTS_TX] Dst:MTS_SAP_TEM(1570), Opc:MTS_OPC_ETHPM_PORT_PRE_CFG(61441)

        187) FSM: Transition at 648626 usecs after Thu Mar 18 12:42:58 2021
        Previous state: [ETH_PORT_FSM_ST_WAIT_PRE_CFG]
        Triggered event: [ETH_PORT_FSM_EV_PRE_CFG_DONE]
        Next state: [ETH_PORT_FSM_ST_LINK_INIT]

        188) FSM: Transition at 615642 usecs after Thu Mar 18 12:43:13 2021
        Previous state: [ETH_PORT_FSM_ST_LINK_INIT]
        Triggered event: [ETH_PORT_FSM_EV_PACER_TIMER_EXPIRED]
        Next state: [FSM_ST_NO_CHANGE]

        Curr state: [ETH_PORT_FSM_ST_LINK_INIT]

        И из общего лога
        2021 Mar 18 12:42:58 dc-core %ETHPORT-5-IF_DOWN_LINK_FAILURE: Interface Ethernet1/1 is down (Link failure)

        К сожалению, оборудование пока не заземлено — работаем в этом направлении.
        Возможно включен DOM на нексусе, буду проверять.

        Благодарю!