For example, I will configure the Cisco Nexus N3K-C3064PQ-10GX switch.
The switch has 48 SFP+ 10 Gb/s ports and 4 QSFP+ 40 Gb/s ports, for the connection between the switch and the servers I use DAC cables up to 5m, but you can also use longer AOC optical ones.
At the first connection via the console, I specified the password for the admin user:
2020 Oct 12 08:42:06 switch %$ VDC-1 %$ %POAP-2-POAP_INFO: - Abort Power On Auto Provisioning [yes - continue with normal setup, skip - bypass password and basic configuration, no - continue with Power On Auto Provisioning]
Do you want to enforce secure password standard (yes/no): yes
Enter the password for "admin":
Confirm the password for "admin":
Would you like to enter the basic configuration dialog (yes/no): no
I switched to the configuration mode and indicated the firmware file:
dir
show incompatibility nxos bootflash:nxos.7.0.3.I4.6.bin
configure terminal
boot nxos bootflash:/nxos.7.0.3.I4.6.bin
exit
I saved the configuration, rebooted the switch and made sure that it booted from the previously specified firmware:
copy running-config startup-config
reload
This command will reboot the system. (y/n)? [n] y
Next, look at the current and stored configuration:
show running-config
show startup-config
When you turn on the switch, if necessary, you can enter bootloader mode:
Press ctrl L to go to loader prompt in 2 secs
You can also manually start the switch from the bootloader with the specified firmware:
loader>boot bootflash:nxos.7.0.3.I4.6.bin
Or like this:
switch(boot)#load bootflash:nxos.7.0.3.I4.6.bin
Let’s immediately select the port mode, since after this action, a device reboot is required (for example, I usually use 48x10g+4x40g):
hardware profile portmode ?
hardware profile portmode 64x10G
hardware profile portmode 48x10g+4x40g
copy running-config startup-config
exit
reload
If you select the 64x10G mode, then four 40G ports can connect QSFP+ to 4 x SFP+ cables. Connecting a 4 x SFP+ to QSFP+ cable to regular 10G ports will not work to increase the number of 40G ports, the link will constantly flap in the logs (Interface Ethernet1/1 is down (Error disabled. Reason:Too many link flaps), unless it is possible on another device, disassemble the 40G port into 4x10G and create an aggregation, or simply use ordinary cables and aggregation on both sides of the 10G ports.
show interface ethernet 1/1 capabilities | i Breakout
Breakout capable: no
Add the necessary VLANs and, if necessary, descriptions:
vlan 207
name Management
vlan 300
name Users
exit
I will give examples of configuring access and trunk ports:
interface Ethernet1/1
switchport
switchport mode access
description ixnfo_com
switchport access vlan 300
storm-control broadcast level 0.50
interface Ethernet1/2
switchport
switchport mode trunk
switchport trunk allowed vlan 207,300
I will give an example of configuring a hybrid port, Vlan 300 without a tag, and all other vlan with a tag:
switchport mode trunk
switchport trunk native vlan 300
switchport trunk allowed vlan 207-209,300
By default, ports 1-48 are configured for 10 Gb/s, to connect 1 Gb/s we will specify:
interface ethernet 1/1-44
speed 1000
interface ethernet 1/45-48
speed 10000
Let’s specify the time zone and ntp server for time synchronization:
ntp server 192.168.5.50
clock timezone UTC 2 0
show clock
Let’s configure SNMP:
snmp-server community ixnfo ro
If interface vlan (SVI) will be created, then activate the feature interface-vlan:
show feature
feature interface-vlan
I will give an example of creating an interface vlan (SVI):
vlan 207
exit
interface vlan 207
description ixnfo.com
ip address 10.0.0.2/24
ip address 192.168.5.5/24 secondary
no ip redirects
no shutdown
exit
An example of specifying a default route:
ip route 0.0.0.0/0 10.0.0.1
Or:
vrf context default
ip route 0.0.0.0/0 10.0.0.1
Example for configuring a mgmt port:
int mgmt 0
ip address 192.168.5.5/24
exit
vrf context management
ip route 0.0.0.0/0 192.168.5.1
exit
ping 192.168.5.55 vrf management
You can specify hostname:
hostname IXNFO_COM
I will give examples of viewing various information:
show version
show system uptime
show system resources
show boot variables
show banner motd
show feature
show vdc membership
show running-config copp all
show running-config interface ethernet 1/1-10
show interface ethernet 1/1 transceiver details
show interface ethernet 1/1 capabilities
show interface ethernet 1/1-10
show int status mod 3
show interface status
show interface brief
show interface Ethernet1/52
show interface Ethernet1/52 brief
show processes cpu
show processes log
show processes log details
show processes memory
show logging
show cli history
show install all status
dir
show sprom all
show inventory
show module
show environment
show environment power
show environment fan
show environment fan detail
show environment temperature
show license
show system reset-reason
show terminal
show ip arp
show ip arp | include b47a.f1a9.0000
Switch uptime can be viewed with the command:
show version
We allow the use of SFP modules from third-party manufacturers:
service unsupported-transceiver
Also, when using third-party SFP and DAC cables, I indicated the commands below for the interfaces, since without them either there was no link, or it disappeared after a while, for example:
interface ethernet 1/52
no negotiate auto
duplex full
You can also turn off flow-control if it did not turn off automatically:
no flowcontrol receive
no flowcontrol send
Let’s configure the end of console sessions after 30 minutes:
line console
exec-timeout 30
An example of restricting access to the switch by IP addresses:
ip access-list ixnfo
permit ip 10.0.0.1/32 any
permit ip 192.168.15.15/32 any
line vty
exec-timeout 30
access-class ixnfo in
An example of activating telnet (but I recommend using ssh):
feature telnet
To clear the configuration, use the command:
write erase
An example of copying the current and saved configuration to a TFTP server:
copy running-config tftp://ixnfo.com/running-config.bak
copy startup-config tftp://ixnfo.com/startup-config.bak
An example of restoring a configuration from a TFTP server:
copy tftp://ixnfo.com/running-config.bak running-config
See also my articles:
- Cisco Nexus 3064 Backup Script
- Configuring Jumbo Frame on Cisco Nexus 3064
- Configuring DHCP Relay on Cisco Nexus 3064
- LACP Link Aggregation on Cisco Nexus 3064
- High CPU load on Cisco Nexus 3064
- Setting up logs
- Configuring Cisco Catalyst 6509-E
- Configuring Cisco devices