Configuring Cisco Catalyst 6509-E

Using an example, I will configure the Cisco Catalyst 6509-E with firmware 12.2 (33) SXJ7.
And so, connect to the console port, the standard speed is 9600 bps, 8N1.

Example of commands to view information about firmware and hardware:

show module
show inventory
show version
show version | in image
show bootvar
show redundancy

Let’s switch to elevated privilege mode:

enable

An example of viewing the current configuration and saved:

show running-config
show running-config interface GigabitEthernet 1/1
show configuration

Let’s go into configuration mode:

configure t

Specify the name of the device:

hostname Router

Add the user (where admin is any name):

username admin privilege 15 password 7 PASSWORD

Add all vlan:

vlan 207
vlan 226

Configure VLAN interfaces (turn off 1 standard, 207 for management, 226 for users, 192.168.0.1 – DHCP server for L3):

interface Vlan1
no ip address
shutdown
exit
interface Vlan207
ip address 192.168.0.5 255.255.255.0
no shutdown
exit
interface Vlan226
ip address 192.168.20.1 255.255.255.0
no shutdown
ip helper-address 192.168.0.1
no ip redirects
no ip unreachables
exit

If necessary, you can specify a gateway so that the switch can be seen from other networks (on a network 192.168.0.0/24 it can be seen without specifying a gateway):

ip default-gateway 192.168.0.1

You can see which VLAN the device firmware is using with the command:

show vlan internal usage

We will make ACLs with IP addresses from which we will later allow us to connect to SNMP, telnet, etc.:

access-list 10 permit 192.168.0.100
access-list 10 permit 192.168.20.110
show access-list
show ip access-lists

Configure the connection parameters and specify the ACL for telnet:

line con 0
 login local
 stopbits 1
line vty 0 4
password
login local
access-class 10 in

Configure SNMP (the number 10 indicates the ACL number in which the IP addresses from which you can connect to SNMP are indicated):

snmp-server community public RO 10
snmp-server ifindex persist
snmp-server location "TEXT"
snmp-server contact test@ixnfo.com
snmp-server enable traps tty
snmp ifmib ifindex persist

View SNMP settings:

show snmp
show snmp engineID [local | remote]
show snmp groups
show snmp user

You can disable SNMP and remove community with the following commands:

no snmp-server
no snmp-server community public

Configure the interfaces (ports), as I described in this article:
Configuring ports in Cisco switches

You can enable/disable interfaces with the following commands:

shutdown
no shutdown

Log settings (logging level from 0 to 7, 0 – minimum information):

logging on
logging buffered 0-7

Set up time synchronization with the NTP server:

clock timezone UTC 2
ntp server 192.168.1.1 version 2
exit
show clock

Example of viewing logs, VLAN, packet statistics on ports:

show log
show vlan id 226
show int GigabitEthernet 1/1
show int gigabitEthernet 1/6 counters

View CPU, memory and power supply loading:

show processes
show processes cpu
sh proc cpu sorted 1
show processes cpu sorted | ex 0.00
sh proc cpu hist
show processes memory
show power
show power available
show power used
show int | inc line protocol | packets/sec

Save the configuration:

copy run start
write

By the way, Xenpak to SFP + interface converters are installed in 10Gb slots, I had to remove them and insert them into the hot one, everything is ok, you can remove and insert boards in the same way.

See also my articles:
How to view ARP and MAC addresses on Cisco
Configuring link aggregation on the Cisco Catalyst 6500
Using third-party SFP modules in Cisco switches
Management Access Restriction

Leave a comment

Leave a Reply