Настройка IGMP snooping на Cisco

Приведу пример настройки IGMP snooping на Cisco, под рукой был коммутатор Cisco WS-C2960-24TT-L.

Первым делом переключимся в режим конфигурации:

enable
configure t

Включим igmp snooping (включен по умолчанию):

ip igmp snooping

Я использовал коммутатор чтобы связать тюнера и Teleste Luminato, чтобы Multicast начал проходить, укажем порты источники с Multicast:

ip igmp snooping vlan 229 mrouter interface gigabitEthernet 0/2
ip igmp snooping vlan 229 mrouter interface FastEthernet0/1
ip igmp snooping vlan 229 mrouter interface FastEthernet0/2

Объединил порты с тюнерами в один VLAN:

interface FastEthernet0/1
 switchport access vlan 229
 switchport mode access
interface FastEthernet0/2
 switchport access vlan 229
 switchport mode access
interface GigabitEthernet0/2
 switchport access vlan 229
 switchport mode access

Посмотрим статистику и убедимся что все заработало:

show ip igmp snooping mrouter
show ip igmp snooping querier
show ip igmp snooping querier detail

Посмотрим кто какой multicast получает:

show ip igmp snooping groups

Проверим загрузку процессора:

show processes cpu sorted 1
show processes cpu hist

Стандартные параметры я оставил как есть:

ip igmp query-interval 60
ip igmp query-max-response-time 10
ip igmp querier-timeout 120 
ip igmp snooping vlan 229 querier version 2

Настроим IGMP querier (если не настроить, то multicast трафик будут получать все, даже те кто не запрашивает):

interface vlan 229
ip address 192.168.2.99 255.255.255.0
exit
ip igmp snooping vlan 229
ip igmp snooping vlan 229 querier
ip igmp snooping querier address 192.168.2.99
ip igmp snooping querier

Сохраним конфигурацию:

exit
write

Смотрите также мои статьи:
Настройка Cisco Catalyst 2960
Настройка Protected Ports

Did my article help you? How about buying me a cup of coffee as an encouragement? Buy me a coffe.

Оставьте комментарий

Добавить комментарий