Настройка IP Unnumbered на Cisco

На тесте настрою IP Unnumbered на Cisco Catalyst 6509E с прошивкой 12.2(33)SXJ7, на других коммутаторах настройка аналогична.
IP Unnumbered полезен например когда нужно поделить большую сеть на несколько VLAN и при этом использовать одни и те же IP адреса, а также чтобы выдавать белые IP в любом VLAN используя один шлюз.

Подключимся к терминалу устройства через консоль, telnet или SSH.

Перейдем в режим конфигурирования:

enable
configure

Допустим имеется VLAN 226 который необходимо поделить на много VLAN и при этом использовать одни и те же IP адреса.

Для VLAN 226 назначен интерфейс с IP-адресом (где 11.11.11.1 — шлюз для белых IP, 172.16.0.1 — шлюз для серых, а в ip helper-address у меня указан IP-адрес DHCP сервера на которых транслируются DHCP запросы):

interface Vlan226
ip address 172.16.0.1 255.255.224.0
ip address 11.11.11.1 255.255.255.192 secondary
ip helper-address 192.168.0.1

Перейдем в настройки VLAN интерфейса и уберем назначенные IP:

interface Vlan226
no ip address 172.16.0.1
no ip address 11.11.11.1

Теперь создадим локальный интерфейс и пропишем те IP-адреса которые были назначены интерфейсу VLAN 226:

interface Loopback2
ip address 172.16.0.1 255.255.224.0
ip address 11.11.11.1 255.255.255.192 secondary
ip helper-address 192.168.0.1
no ip redirects
no ip unreachables
no ip proxy-arp
end

Вернемся к интерфейсу VLAN 226 и настроим ip unnumbered (если интерфейсу прописан IP, то он удалится автоматически):

interface Vlan226
ip unnumbered Loopback2

После этого у пользователей во VLAN 226 интернет должен работать как и прежде.
Теперь можно создать сколько угодно VLAN и выдавать в них те же IP что и во VLAN 226, то есть создадим VLAN интерфейсы без IP и укажем в них ip unnumbered, например:

vlan 500
interface Vlan500
description HOUSE1 
ip unnumbered Loopback2

vlan 501
interface Vlan501
description HOUSE2
ip unnumbered Loopback2

vlan 502
interface Vlan502
description HOUSE3
ip unnumbered Loopback2

Далее пробрасываем эти созданные VLAN куда нужно.
Аналогично можно поделить другие VLAN создав для этого Loopback3, Loopback4 и т.д.

Можно быстро настроить ip unnumbered сразу на нескольких интерфейсах (заранее прописав их IP адреса например на Loopback2):

interface range vlan200-300
ip unnumbered Loopback2

Замечу что после ввода команды «ip unnumbered» отображалось предупреждение:

Warning: dynamic routing protocols will not work on SVI interfaces with IP unnumbered configured.

Проверим конфигурацию:

show running-config interface loopback 2
show running-config interface vlan 226
show ip interface loopback 2

Смотрите также мои статьи:
Настройка портов в коммутаторах Cisco
Блокировка сторонних DHCP на Cisco через DHCP Snooping
Настройка DHCP relay на Cisco

Подписаться на IT Blog (RU) по Email
Subscribe to IT Blog (EN) by Email

Did my article help you? How about buying me a cup of coffee as an encouragement? Buy me a coffe.

Добавить комментарий