Configure IP Unnumbered on Cisco

On the test I will configure IP Unnumbered on Cisco Catalyst 6509E with firmware 12.2(33)SXJ7, on other switches the setup is similar.
IP Unnumbered is useful, for example, when it is necessary to divide a large network into several VLANs and use the same IP addresses and also to issue white IPs in any VLAN using one gateway.

Connect to the terminal device through the console, telnet or SSH.

Go to configuration mode:

enable
configure

Suppose there is a VLAN 226 that needs to be divided into many VLANs and at the same time use the same IP addresses.

For VLAN 226, an interface with an IP address is assigned (where 11.11.11.1 is a gateway for white IPs, 172.16.0.1 is a gateway for grays, and in ip helper-address I have the IP address of a DHCP server on which DHCP requests are send):

interface Vlan226
ip address 172.16.0.1 255.255.224.0
ip address 11.11.11.1 255.255.255.192 secondary
ip helper-address 192.168.0.1

Let’s go to the VLAN settings of the interface and remove the assigned IP:

interface Vlan226
no ip address 172.16.0.1
no ip address 11.11.11.1

Now we will create a local interface and assign the IP addresses that were assigned to the VLAN 226 interface:

interface Loopback2
ip address 172.16.0.1 255.255.224.0
ip address 11.11.11.1 255.255.255.192 secondary
ip helper-address 192.168.0.1
no ip redirects
no ip unreachables
no ip proxy-arp
end

Let’s go back to the VLAN 226 interface and configure ip unnumbered (if the interface is assigned an IP, it will be deleted automatically):

interface Vlan226
ip unnumbered Loopback2

After that, the users in VLAN 226 should work as before.
Now you can create as many VLANs as you want and give them the same IP as in VLAN 226, that is, create VLAN interfaces without IP and specify ip unnumbered in them, for example:

vlan 500
interface Vlan500
description HOUSE1 
ip unnumbered Loopback2

vlan 501
interface Vlan501
description HOUSE2
ip unnumbered Loopback2

vlan 502
interface Vlan502
description HOUSE3
ip unnumbered Loopback2

Further we forward these created VLAN where necessary.
Similarly, you can share other VLANs by creating Loopback3, Loopback4, etc. for this.

You can quickly configure ip unnumbered on several interfaces at once (having previously specified their IP addresses, for example, on Loopback2):

interface range vlan200-300
ip unnumbered Loopback2

I note that after entering the command “ip unnumbered” a warning was displayed:

Warning: dynamic routing protocols will not work on SVI interfaces with IP unnumbered configured.

If the client has a static IP (not using DHCP), then you will have to add a route, for example:

ip route 172.16.5.5 255.255.255.255 vlan 226

Check the configuration:

show running-config interface loopback 2
show running-config interface vlan 226
show ip interface loopback 2
show ip route
show ip route | include 172.16.5
sh proc cpu sorted 1

See also my articles:
Configuring ports in Cisco switches
Blocking third-party DHCP on Cisco via DHCP Snooping
Configuring DHCP relay on Cisco

Leave a comment

Leave a Reply