Configuring Eltex MES2324B

For example, I will configure the Eltex MES2324B switch, I used a standard console cable with a pinout similar to the cable for D-Link, Huawei switches. Connection speed 115200.

The first time I connected, I checked the current configuration, it was empty. By the way, you can reset the password and configuration by pressing and holding the F button on the front panel of the switch for 10 seconds.

show running-config

Then I switched to the configuration mode:

configure terminal

Added admin:

username admin password ixnfo_com

An example of adding an operator:

username operator password pass privilege 1

Configured telnet and password:

aaa authentication login default line
aaa authentication enable default line
ip telnet server
line telnet
login authentication default
enable authentication default
password ixnfo_com

Added the necessary Vlan (for example 209 for management and 229 for users):

vlan database
vlan 209,229
exit

I used vlan 229 to connect multicast tuners and then I will configure the switch in the network core as an igmp querier.

Add a vlan interface with an IP address and a gateway so that the switch can be controlled from other networks:

interface vlan 209
ip address 10.0.22.63 255.255.255.0
exit
ip default-gateway 10.0.22.1
exit
show ip interface vlan 209
configure terminal

An example of removing a vlan interface:

no interface vlan 1

Configured SNMP:

snmp-server server
snmp-server community public ro 192.168.55.55
exit
show snmp
configure terminal

Configured SNTP and time:

clock source sntp
sntp server 192.168.55.55 poll
sntp client poll timer 10800
sntp unicast client enable
clock timezone zone +3

exit
show sntp configuration
show sntp status
show clock
show clock detail
clock set 09:03:00 08 may 2021
configure terminal

Let’s enable loop protection globally and on all user ports:

loopback-detection enable
interface range gigabitethernet 0/1-24
loopback-detection enable
errdisable recovery cause all
errdisable recovery interval 30
no shutdown
exit
exit
show loopback-detection
configure terminal

Let’s configure the incoming UPLINK port:

interface range TengigabitEthernet 1/0/1
no shutdown
switchport mode trunk
switchport trunk allowed vlan add 209

Let’s configure user ports:

interface range gigabitethernet 0/1-24
no shutdown
switchport mode access
switchport access vlan 229
exit

An example of other parameters for ports:

interface range gigabitethernet 0/1-24
duplex full
negotiation 1000f
flowcontrol off
bridge multicast unregistered {forwarding | filtering}
switchport mode (access, trunk,
general, customer)
switchport trunk native vlan
229
switchport general pvid 229
exit
show interfaces
show interfaces status
show interfaces configuration
show interfaces advertise
show interfaces description
show interfaces counters
show interfaces utilization
show interfaces mtu
show ports jumbo-frame
show errdisable recovery
show errdisable interfaces
show green-ethernet detailed
configure terminal
show vlan
show vlan tag 229
show vlan internal usage
show vlan multicast-tv vlan
230

Broadcast storm control:

storm-control multicast [registered | unregistered] {level level | kbps kbps} [trap] [shutdown]
no storm-control multicast

storm-control unicast {level level | kbps kbps} [trap] [shutdown]
no storm-control unicast

storm-control broadcast {level level | kbps kbps} [trap] [shutdown]
no storm-control broadcast

show storm-control interface ...

interface TengigabitEthernet 1/0/2
storm-control broadcast kbps 5000 shutdown
storm-control multicast level 30 trap
storm-control unicast level 70 trap

Configured IGMP Snooping:

ip igmp snooping
ip igmp snooping vlan 229

interface vlan 229
ip address 192.168.2.99 255.255.255.0

ip igmp snooping vlan 229 querier
ip igmp snooping vlan 229 querier version 2
ip igmp snooping vlan 229 querier address 192.168.2.99
bridge multicast filtering
ip igmp snooping vlan 229 mrouter learn pim-dvmrp
ip igmp snooping vlan 229 mrouter interface gigabitethernet ...
ip igmp snooping vlan 229 forbidden mrouter interface gigabitethernet ...

show ip igmp snooping mrouter [interface vlan_id]
show ip igmp snooping interface 229
show bridge multicast address-table format ip

Let’s configure the logs:

logging on
logging host 192.168.5.5 severity warnings

logging console [level]
logging buffered [severity_level]
logging buffered size size

logging file [level]
no logging file

aaa logging login
management logging deny

show logging
show syslog-servers
show logging file

clear logging
clear logging file

Let’s restrict access to switch management:

management access-list ixnfo_com
permit ip-source 192.168.5.5 mask /32 service telnet
permit ip-source 192.168.5.5 mask /32 service snmp
management access-class ixnfo_com
end
show management access-list ixnfo_com
show management access-class

Example of cable and optical transceiver diagnostics:

test cable-diagnostics tdr interface gigabitethernet 1/0/1
show fiber-ports optical-transceiver interface TengigabitEthernet1/0/1

Configuring configuration backup to TFTP server:

backup server server tftp://XXX.XXX.XXX.XXX
backup path path ...
backup time-period timer (1..35791394)/720 min
show backup
show backup history

Let’s save the configuration:

write

Or:

exit
copy running-config startup-config

An example of copying the current configuration to a TFTP server:

copy running-config tftp://192.168.5.5/ixnfo.com

An example of a firmware update:

show version
boot system tftp://192.168.5.5/file.ros
show bootvar
reload

See also my articles:
Configuring Multicast on Eltex MES2324B
Eltex MES2324 backup script
User manual Eltex MES53xx, MES33xx, MES35xx, MES23xx

Leave a comment

Leave a Reply

Discover more from IT Blog

Subscribe now to keep reading and get access to the full archive.

Continue reading