Настройка BDCOM GP3600

В этой статье я приведу пример настройки GPON OLT BDCOM GP3600-08B.

Кстати консольный кабель от BDCOM P3310 не подошел, к счастью в комплекте с устройством был оригинальный и подключился к нему на скорости 9600.
Прошивка устройства была 10.3.0D Build 65417.

Перейдем в режим повышенных привилегий и посмотрим текущую конфигурацию:

enable
config
show running-config

Сначала я настроил пользователя admin и указал пароль (где IXNFO — пароль):

aaa authentication login default local
aaa authentication enable default none
aaa authorization exec default local
username admin password 0 IXNFO
enable password 0 IXNFO
service password-encryption

Далее удалим стандартный IP адрес, создадим необходимые VLAN, создадим VLAN интерфейс с IP адресом для управления устройством и укажем для него маршрут по умолчанию:

interface GigaEthernet0/0
no ip address
no ip directed-broadcast
vlan 208,226
exit
interface vlan 208
description management
ip address 192.168.5.5 255.255.255.0
no ip directed-broadcast
exit
ip route default 192.168.5.1

Настроим первый GigaEthernet как uplink (в него будет приходить интернет):

interface gigaEthernet 0/1
description UPLINK
no shutdown
switchport trunk vlan-allowed 208,226
switchport trunk vlan-untagged none
switchport mode dot1q-tunnel-uplink
dhcp snooping trust
exit

Можем настроить второй порт, например чтобы можно было подключить ноутбук и измерить скорость:

interface gigaEthernet 0/2
description ForTestSpeed
no shutdown
switchport mode access
switchport pvid 226
loopback-detection enable
loopback-detection control shutdown
exit
show loopback-detection
loopback-detection 

Создадим список IP адресов которым мы в дальнейшем разрешим управлять устройством:

ip access-list standard MANAGEMENT
permit 192.168.2.2 255.255.255.255
permit 192.168.5.5 255.255.255.255
exit
ip telnet access-class MANAGEMENT
ip telnet attack-defense
no ip http server

Настроим SNMP с указанием ранее созданного списка MANAGEMENT:

snmp-server community 0 public RO MANAGEMENT
snmp-server contact ixnfo.com
snmp-server location ixnfo.com

Настроим NTP:

time-zone Kyiv 2 0
ntp query-interval 3600
ntp server 192.168.2.2

Создадим нужные профили для ONU:

gpon profile onu-flow-mapping vlan226
 gpon-profile entry 1 uni type eth-uni all
 gpon-profile entry 1 vlan 226
 gpon-profile entry 1 virtual-port 1

gpon profile onu-vlan vlan226
 gpon-profile vlan mode trunk
 gpon-profile vlan pvid 226 0
 gpon-profile vlan trunk vlan-allowed 226

Изменим пиковую и гарантированную скорость, а то в профиле по умолчанию были указаны pir 1244160 cir 1244160:

gpon profile onu-rate-limit ratelimit-default id 1
gpon-profile pir 1000000 cir 5000

Обязательно создадим профиль для MTU, так как на сторонних ONU часть сайтов не открывалась и c большими пакетами не проходил ping (из Windows это можно проверить так ping -t -l 1469 192.168.2.2):

gpon profile onu-uni MTU
gpon-profile max-frame-size 1550

Создадим профиль для авторегистрации ONU (эти команды будут автоматически выполняться после подключения новых ONU, первой всегда должна быть команда с «tcont-virtual-port-bind-profile» иначе не будет работать):

gpon onu-config-template vlan226
cmd-sequence 001 gpon onu tcont-virtual-port-bind-profile tvbind-default
cmd-sequence 002 gpon onu flow-mapping-profile vlan226
cmd-sequence 003 gpon onu uni 1 vlan-profile vlan226
cmd-sequence 004 gpon onu uni 1 uni-profile MTU

Теперь настроим первый GPON порт и аналогично остальные:

interface GPON0/1
description users
gpon pre-config-template vlan226 bind-onuid 1-128
gpon bind-onutype onutype-default-hgu precedence 127
gpon bind-onutype onutype-default precedence 128
filter dhcp
switchport trunk vlan-allowed 226
switchport trunk vlan-untagged none
switchport mode trunk
storm-control broadcast threshold 1000
storm-control multicast threshold 1000
switchport protected 1
no shutdown

Включим DHCP Snooping глобально и для клиентского VLAN:

ip dhcpd enable
ip dhcp-relay snooping
ip dhcp-relay snooping vlan  226
ip dhcp-relay snooping rapid-refresh-bind
show ip dhcp-relay snooping binding all

Активируем функцию предотвращения атак:

filter enable

Настройка завершена, сохраним конфигурацию:

write all

Кстати по умолчанию были созданы такие профили:

gpon profile onu-rate-limit ratelimit-default id 1
 gpon-profile pir 1244160 cir 1244160
!
gpon profile onu-tcont tcont-default id 1
 gpon-profile tcont-type 3 pir 1024000 cir 512
!
gpon profile onu-virtual-port virtual-port-default id 1
 gpon-profile encryption disable
 gpon-profile upstream queue 8
 gpon-profile downstream queue 8
!
gpon profile onu-tcont-virtual-port-bind tvbind-default id 1
 gpon-profile virtual-port 1 profile virtual-port-default tcont 1 profile tcont-
default
!
gpon profile onu-flow-mapping flow-mapping-default id 1
 gpon-profile entry 1 uni type eth-uni all
 gpon-profile entry 1 virtual-port 1
!
gpon profile onu-flow-mapping flow-mapping-default-hgu id 2
 gpon-profile entry 1 uni type veip all
 gpon-profile entry 1 virtual-port 1
!
!
gpon onutype-template onutype-default-hgu
 gpon-onutype match ctc-onu-type HGU
 gpon-onutype config tcont-virtual-port-bind-profile tvbind-default
 gpon-onutype config flow-mapping-profile flow-mapping-default-hgu
!
gpon onutype-template onutype-default
 gpon-onutype config tcont-virtual-port-bind-profile tvbind-default
 gpon-onutype config flow-mapping-profile flow-mapping-default

Пример просмотра различной информации:

show gpon interface gpon 0/1:1 onu basic-info
show gpon interface gpon 0/1:1 onu optical-transceiver-diagnosis
show gpon interface gpon 0/1:1 onu port 1 current-statistics
show gpon interface gpon 0/1:1 onu virtual-port 1 current-statistics
show gpon onu-image-information
show gpon onu-information
show gpon onu-description
show gpon onu-status-count
show gpon onu-update-state
show gpon active-onu
show filter
show filter summary
show dos
show loopback-detection
show loopback-detection interface gigaEthernet 0/1
show system mtu
sh run db-onu
show gpon ?

Пример выполнения различных операций с ONU:

interface GPON 0/1:1
description TEST
gpon onu uni 1 shutdown|noshutdown
gpon onu virtual-port 2 shutdown|noshutdown
gpon onu  disable
no gpon onu  disable

Пример просмотра отладочной информации:

clear logging
debug dhcp detail
debug ip dhcp-relay all
show logging
no debug dhcp detail
no debug ip dhcp-relay all

Кстати заметил проблему на ONU сторонних производителей, что часть клиентов не могли отправить DHCPOFFER, а к серверу от них приходил DHCPDISCOVER.

Смотрите также мои статьи:
Сброс BDCOM GP3600
Настройка BDCOM P3608-2TE
Документация BDCOM GP3600
Error: GPON0/1 allocId 256 has been used

Вливайтесь в общение

2 комментария

Добавить комментарий

  1. «Кстати заметил проблему на ONU сторонних производителей, что часть клиентов не могли отправить DHCPOFFER, а к серверу от них приходил DHCPDISCOVER» — удалось решить проблему?

  2. По Вашей инструкции сразу получилось настроить BDCOM и на удивление заработало с первого раза. Но возник один вопрос, а как тут настроить LoopDetect на самой ONU ?
    loopback-detection-profile на самой голове есть, настройки в нём есть, а вот как правильно его применить к ONU не понял. Пробовал так «cmd-sequence 005 gpon onu loopback-detection-profile loopback-detection-default» , но не заработало.
    Если возможно поделитесь пожалуйста информацией )