In this article I will give an example of GPON OLT BDCOM GP3600-08B configuration.
By the way, the console cable from BDCOM P3310 did not fit, fortunately, the original one was bundled with the device and connected to it at a speed of 9600.
The firmware of the device was 10.3.0D Build 65417.
We’ll go into elevated privilege mode and see the current configuration:
enable
config
show running-config
First, I set up admin and specify a password (where IXNFO is the password):
aaa authentication login default local
aaa authentication enable default none
aaa authorization exec default local
username admin password 0 IXNFO
enable password 0 IXNFO
service password-encryption
Next, delete the standard IP address, create the necessary VLANs, create a VLAN interface with an IP address to control the device, and indicate the default route for it:
interface GigaEthernet0/0
no ip address
no ip directed-broadcast
vlan 208,226
exit
interface vlan 208
description management
ip address 192.168.5.5 255.255.255.0
no ip directed-broadcast
exit
ip route default 192.168.5.1
Let’s configure the first GigaEthernet as uplink (the Internet will come to it):
interface gigaEthernet 0/1
description UPLINK
no shutdown
switchport trunk vlan-allowed 208,226
switchport trunk vlan-untagged none
switchport mode dot1q-tunnel-uplink
dhcp snooping trust
exit
We can configure the second port, for example, so that you can connect a laptop and test the speed:
interface gigaEthernet 0/2
description ForTestSpeed
no shutdown
switchport mode access
switchport pvid 226
loopback-detection enable
loopback-detection control shutdown
exit
show loopback-detection
loopback-detection
Create a list of IP addresses that we will later allow to control the device:
ip access-list standard MANAGEMENT
permit 192.168.2.2 255.255.255.255
permit 192.168.5.5 255.255.255.255
exit
ip telnet access-class MANAGEMENT
ip telnet attack-defense
no ip http server
Configure SNMP with the previously created MANAGEMENT list:
snmp-server community 0 public RO MANAGEMENT
snmp-server contact ixnfo.com
snmp-server location ixnfo.com
Configure NTP:
time-zone Kyiv 2 0
ntp query-interval 3600
ntp server 192.168.2.2
Create the necessary profiles for ONU:
gpon profile onu-flow-mapping vlan226
gpon-profile entry 1 uni type eth-uni all
gpon-profile entry 1 vlan 226
gpon-profile entry 1 virtual-port 1
gpon profile onu-vlan vlan226
gpon-profile vlan mode trunk
gpon-profile vlan pvid 226 0
gpon-profile vlan trunk vlan-allowed 226
Change the peak and guaranteed speed, otherwise pir 1244160 cir 1244160 were specified in the profile by default:
gpon profile onu-rate-limit ratelimit-default id 1
gpon-profile pir 1000000 cir 5000
Be sure to create a profile for MTU, since on third-party ONUs some of the sites did not open and ping did not pass with large packets (from Windows this can be checked like this ping -t -l 1469 192.168.2.2):
gpon profile onu-uni MTU
gpon-profile max-frame-size 1550
Create a profile for ONU auto-registration (these commands will be automatically executed after connecting new ONUs, the first should always be a command with “tcont-virtual-port-bind-profile” otherwise it will not work):
gpon onu-config-template vlan226
cmd-sequence 001 gpon onu tcont-virtual-port-bind-profile tvbind-default
cmd-sequence 002 gpon onu flow-mapping-profile vlan226
cmd-sequence 003 gpon onu uni 1 vlan-profile vlan226
cmd-sequence 004 gpon onu uni 1 uni-profile MTU
Now configure the first GPON port and similarly the rest:
interface GPON0/1
description users
gpon pre-config-template vlan226 bind-onuid 1-128
gpon bind-onutype onutype-default-hgu precedence 127
gpon bind-onutype onutype-default precedence 128
filter dhcp
switchport trunk vlan-allowed 226
switchport trunk vlan-untagged none
switchport mode trunk
storm-control broadcast threshold 1000
storm-control multicast threshold 1000
switchport protected 1
no shutdown
Enable DHCP Snooping globally for the client VLAN:
ip dhcpd enable
ip dhcp-relay snooping
ip dhcp-relay snooping vlan 226
ip dhcp-relay snooping rapid-refresh-bind
show ip dhcp-relay snooping binding all
Activate the attack prevention function:
filter enable
Setup is complete, save the configuration:
write all
By the way, the following profiles were created by default:
gpon profile onu-rate-limit ratelimit-default id 1
gpon-profile pir 1244160 cir 1244160
!
gpon profile onu-tcont tcont-default id 1
gpon-profile tcont-type 3 pir 1024000 cir 512
!
gpon profile onu-virtual-port virtual-port-default id 1
gpon-profile encryption disable
gpon-profile upstream queue 8
gpon-profile downstream queue 8
!
gpon profile onu-tcont-virtual-port-bind tvbind-default id 1
gpon-profile virtual-port 1 profile virtual-port-default tcont 1 profile tcont-
default
!
gpon profile onu-flow-mapping flow-mapping-default id 1
gpon-profile entry 1 uni type eth-uni all
gpon-profile entry 1 virtual-port 1
!
gpon profile onu-flow-mapping flow-mapping-default-hgu id 2
gpon-profile entry 1 uni type veip all
gpon-profile entry 1 virtual-port 1
!
!
gpon onutype-template onutype-default-hgu
gpon-onutype match ctc-onu-type HGU
gpon-onutype config tcont-virtual-port-bind-profile tvbind-default
gpon-onutype config flow-mapping-profile flow-mapping-default-hgu
!
gpon onutype-template onutype-default
gpon-onutype config tcont-virtual-port-bind-profile tvbind-default
gpon-onutype config flow-mapping-profile flow-mapping-default
An example of viewing various information:
show gpon interface gpon 0/1:1 onu basic-info
show gpon interface gpon 0/1:1 onu optical-transceiver-diagnosis
show gpon interface gpon 0/1:1 onu port 1 current-statistics
show gpon interface gpon 0/1:1 onu virtual-port 1 current-statistics
show gpon onu-image-information
show gpon onu-information
show gpon onu-description
show gpon onu-status-count
show gpon onu-update-state
show gpon active-onu
show filter
show filter summary
show dos
show loopback-detection
show loopback-detection interface gigaEthernet 0/1
show system mtu
sh run db-onu
show gpon ?
An example of performing various operations with ONUs:
interface GPON 0/1:1
description TEST
gpon onu uni 1 shutdown|noshutdown
gpon onu virtual-port 2 shutdown|noshutdown
gpon onu disable
no gpon onu disable
An example of viewing debugging information:
clear logging
debug dhcp detail
debug ip dhcp-relay all
show logging
no debug dhcp detail
no debug ip dhcp-relay all
By the way, I noticed a problem on third-party ONUs that some clients could not send DHCPOFFER, and DHCPDISCOVER came to the server from them.
See also my articles:
Reset BDCOM GP3600
Configuring BDCOM P3608-2TE
BDCOM GP3600 Documentation
Error: GPON0/1 allocId 256 has been used
Hello sir,
This is to inform you that I m using BDCOM GP3600-08B GPON OLT . I recently encountered a problem with PON link in all the ONU and ONT’s connected with it. The problem is pon being unstable. The internet connection gets disconnected due to pon being unstable.
I am using BDCOM GP1704-1G , HUAWEI EG8141A5 and HUAWEI HG8546M ONT for internet connection at client side .
Upon restarting the OLT the problem gets resolved and again arises after some time .
please provide me a solution to this problem.
Thank You
Amit Chaudhary
Chaudhary Techno Traders