For the test, I’ll configure BDCOM P3608-2TE with firmware 10.1.0E build 46085.
I connected to the device with an original console cable at a speed of 9600, also the IP address 192.168.1.1 is assigned to the device by default, the login and password are the same – admin.
Switch to setup mode:
enable
config
Add the necessary VLANs:
vlan 207,226,228
exit
no interface vlan 1
Set up the Uplink port, out of habit I use the combo port GigaEthernet0/5:
interface GigaEthernet0/5
no shutdown
description UPLINK
switchport trunk vlan-allowed 207,226,228
switchport trunk vlan-untagged none
switchport mode trunk
dhcp snooping trust
You can create a profile for ONU auto-registration:
epon onu-config-template ixnfo
cmd-sequence 001 epon onu port 1 ctc vlan mode tag 228
cmd-sequence 002 epon onu port all-port ctc loopback detect
cmd-sequence 003 epon onu all-port storm-control mode 4 threshold 256
cmd-sequence 004 switchport port-security dynamic maximum 3
cmd-sequence 005 switchport port-security mode dynamic
Configure EPON ports, for example:
interface EPON0/1
description users
epon pre-config-template ixnfo binded-onu-llid 1-64
epon onu-always-laser-on disable
filter dhcp
switchport trunk vlan-allowed 226,228
switchport trunk vlan-untagged none
switchport mode trunk
switchport protected 1
no shutdown
exit
I used VLAN 207 for management, assign an IP address:
interface VLAN207
ip address 192.168.5.2 255.255.255.0
exit
Specify the default route so that you can connect to BDCOM from other networks:
ip route default 0.0.0.0 0.0.0.0 192.168.5.1
Create a list of IP addresses from which we later enable BDCOM control:
ip access-list standard MANAGEMENT
permit 192.168.2.2 255.255.255.255
permit 192.168.5.5 255.255.255.255
exit
Specify a list for telnet:
ip telnet access-class MANAGEMENT
Configure SNMP:
snmp-server community 0 public RO MANAGEMENT
snmp-server contact ixnfo.com
snmp-server location ixnfo.com
Specify the server for time synchronization:
time-zone Kyiv 2 0
ntp query-interval 3600
ntp server 192.168.2.2
Add an administrator:
aaa authentication login default local
aaa authentication enable default none
aaa authorization exec default local
username admin password 0 TEXT
enable password 0 TEXT
service password-encryption
Disable the HTTP server and spanning-tree:
no ip http server
no spanning-tree
If there is a problem with third-party ONUs, then we will execute the commands:
epon oam-version 1 0x30
epon oam-version 2 0x21
epon oam-version 3 0x20
Let us use some reserved MAC addresses:
epon local-mac forward
We exit the setup mode and save the configuration:
write all
Example of configuring a GigaEthernet port with vlan without a tag:
interface GigaEthernet0/6
switchport mode access
switchport pvid 301
switchport protected 1
See my other articles about BDCOM.
Adding ONU with trunk port
1 Gbps per ONU BDCOM