Настройка BDCOM P3310 EPON

Настроил очередные EPON OLT BDCOM P3310B-2AC и P3310C-2AC.

Как восстановить пароль или сбросить конфигурацию смотрите мою статью — Сброс конфигурации BDCOM P3310

Подключился к нему консольным кабелем со скоростью 9600.
Конфигурации не было, все порты выключены.
Может быть стандартный одинаковый логин и пароль admin

После подключения перейдем в режим настройки:

enable
config

Посмотрим какая есть конфигурация:

show configuration

Приступаем к настройке!
1) Удалим стандартный vlan 1 и добавим vlan управления (у меня он 207), vlan 301 (клиентский):

no interface vlan 1
vlan 207,301
exit
interface vlan 207
description core
ip address 192.168.1.3 255.255.255.0
exit
ip default-gateway 192.168.1.1

2) Пятый комбо порт я настроил как входящий (207 — vlan управления, 301 — клиентский):

interface gigaEthernet 0/5
description UPLINK
no shutdown
switchport trunk vlan-allowed 207
switchport trunk vlan-allowed add 301
switchport trunk vlan-untagged none
switchport mode trunk
exit

Выбрал комбо порт чтобы можно было включить входящий линк по меди либо SFP.

3) Напишем шаблон для онушек (в дальнейшем они сами будут регистрироваться, нужно будет только дописывать описание и сохранять конфиг):

epon onu-config-template user1
cmd-sequence 1 epon onu port 1 ctc vlan mode tag 301
cmd-sequence 2 epon onu port 1 ctc loopback detect
cmd-sequence 3 epon onu port 2 ctc vlan mode tag 301
cmd-sequence 4 epon onu port 2 ctc loopback detect
cmd-sequence 5 epon onu port 3 ctc vlan mode tag 301
cmd-sequence 6 epon onu port 3 ctc loopback detect
cmd-sequence 7 epon onu port 4 ctc vlan mode tag 301
cmd-sequence 8 epon onu port 4 ctc loopback detect
exit

4) Настроим первый Epon порт:

interface EPON0/1
no shutdown
description test
switchport trunk vlan-untagged none
switchport trunk vlan-allowed 301
switchport mode trunk
epon pre-config-template user1 binded-onu-llid 1-64
filter dhcp
switchport protected

5) Добавим админа и пароль:

aaa authentication login default local
aaa authentication enable default none
aaa authorization exec default local
username admin password 0 ПАРОЛЬ
enable password 0 ПАРОЛЬ
service password-encryption

6) Укажем с каких IP разрешено подключатся админу:

ip access-list standard MANAGEMENT
permit 192.168.1.2 255.255.255.255
exit
ip telnet access-class MANAGEMENT

7) Укажем часовой пояс и NTP-сервер с каким синхронизировать время (на новых прошивка вместо sntp нужно писать ntp):

time-zone Kyiv +2
sntp server 192.168.1.1
sntp query-interval 720

8) Настроим SNMP:

snmp-server location test
snmp-server contact test
snmp-server community public ro MANAGEMENT

9) Настроим имя устройства и длину консольной строки:

hostname TEST
terminal width 256
terminal length 256

10) Отключим HTTP:

no ip http server

Или настроим с доступом по IP из ранее созданного access-list:

ip http server
ip http access-class MANAGEMENT

Для теста взял ONU BDCOM P1501C1 (настраивать не нужно), FOXGATE 1001w и FOXGATE 1001c (настраивать не нужно), Foxgate NR1001 (стандартный IP 192.168.101.8 admin/admin) и TP-Link EP110 (нужно отключить DHCP зайдя по 192.168.1.1), подключил их через делитель 1*8 к первому PON порту.

Посмотреть зарегистрированные ONU можно командами:

show epon onu-information
show epon active-onu

Пример просмотра MAC-адресов на порту или onu:

show mac address-table interface EPON0/1
show mac address-table interface EPON0/1:5

Сохраним настройки:

write

На новых прошивках сохраняем так:

write all

Посмотрим какие ONU прописаны:

show configuration

Оптическую мощность ONU и портов можно посмотреть так:

show epon optical-transceiver-diagnosis
show epon optical-transceiver-diagnosis interface EPON 0/1

Выберем нужную ONU и добавим описание:

interface EPON0/1:1
description TEST

Можно огриничивать скорость на портах ONU в килобитах, для этого выполним команды (можно также указать их в шаблоне выше):

epon onu port 1 ctc rate-limit 15000 ingress
epon onu port 1 ctc rate-limit 15000 egress

На этом основная настройка завершена.
По желанию вместо telnet можно использовать SSH, который включается командой:

ip sshd enable

Смотрите также:
Обновление прошивки BDCOM P3310

Опишу список возможных команд/подкоманд по которым удобнее ориентироваться.
СТАНДАРТНЫЕ КОМАНДЫ
chinese — Справочные сообщения на китайском языке
connect адрес — Открытие внешнего соединения
disconnect — Отключение существующих внешних telnet соединений
enable — Включение привелигированных команд
english — Справочные сообщения на английском языке
enter — Включение привелигированных команд
exit — Выход
help — Описание интерактивной системы помощи
history — Просмотр истории введенных команд. Например отображение последних введенных команд: history -5
quit — Выход
resume — Продолжение работы с существующим внешним telnet соединением
ssh — Открытие SSH соединения (-l имя_пользователя, -d адрес)
su — Вход в режим супер пользователя
telnet адрес — Открытие telnet соединения
where — Показать все исходящее Telnet соединения

ПРИВЕЛИГИРОВАННЫЕ КОМАНДЫ
cd имя_директории — Переход в указанную директорию
clear arp-cache — Очистка ARP кеша
clear break — Switch breakpoint information
clear dhcp-relay — DHCP relay information
clear epon — Ethernet Passive Optical Network
clear ethernet — Clear Ethernet
clear hs — Clear hs version information
clear l2 — Reset link layer
clear line — TTY line information
clear lldp — Clear LLDP
clear logging — Clear logging buffer
clear mac — MAC forwarding table
clear mib — Clear port mib statistics
clear oir-information — Clear online insert remove information
clear task-cpu — CPU utilization for each task
clear tcp — Clear a TCP connection or statistics
clear telnet — Очистить входящие telnet соединения
config — Вход в конфигурационный режим
connect — Открытие внешнего соединения
copy — Копирование конфигурациии или файла с данными. Например с tftp на свич: copy tftp:switch.bin flash:switch.bin 192.168.2.1
date — Установка системной даты
debug — Функции отладки
delete — Удаление указанного файла, если имя не указано, то удаляется startup-config
diagnosis — Вход в режим диагностики
dir — Список файлов во флэш-памяти
enable — Включение привелигированных команд
enter — Включение привелигированных команд
epon — Ethernet Passive Optical System
ethernet — Ethernet операции
format — Форматирование файловой сисиемы
md — Создание директори
more — Отображение содержимого файла
no — Отрицание конфигурации
ping — Пинг внешнего устройства
pwd — Отображение текущей директории
rcommand — Выпонить команду на удаленном hs
rd — Удаление директории
reboot — Перезагрузка системы
rename — Переименование файла
show — Отображение конфигурации и статуса
terminal — Установка параметров терминала
traceroute — Трассировка маршрута к месту назначения
write — Сохранение текущей конфигурации в файл startup-config

КОНФИГУРАЦИОННЫЙ РЕЖИМ
aaa accounting commands — For exec (shell) commands
aaa accounting connection — For outbound connections
aaa accounting exec — For starting an exec (shell)
aaa accounting network — For network services (ppp, slip)
aaa accounting suppress — Do not generate accounting records for a specific type of user
aaa accounting update — Enable accounting update records

aaa authentication banner — Message to use when starting login/authentication
aaa authentication dot1x — Set authentication list for dot1x module
aaa authentication enable — Set authentication list for enable
aaa authentication fail-message — Message to use for failed login/authentication
aaa authentication login — Set authentication list for login
aaa authentication password-prompt — Text to use when prompting for a password
aaa authentication username-prompt — Text to use when prompting for a username

aaa authorization commands — For exec (shell) commands
aaa authorization config-commands — For configuration mode commands
aaa authorization exec — For starting an exec (shell)
aaa authorization network — For network services (ppp, slip)

aaa group server radius — Define radius server group
aaa group server tacacs+ — Define tacacs+ server group

aggregator-group — Конфигрурация агрегации
alias — Определение псевдонима для команды
arp — ARP конфигурации
banner — Set login banner
bcmp — B-STAR cluster management protocol
boot — Изменение параметров загрузки системы
cos — Конфигруация cos
default — Восстановление конфигурации по умолчанию
dot1q-tunnel — Enable dot1q tunnel globally
dot1x — IEEE 802.1X configuration
enable — Enable password configuration

epon ace-reset-delay — Configure reset delay time for ACE ONU
epon b-psg — B protection switch group
epon c-psg — C protection switch group
epon ctc-oam-discovery-timeout — Configure CTC OAM discovery timeout
epon dba — Dba config
epon dying-gasp-available-time — Configure onu dying-gasp available time
epon dying-gasp-log — Configure dying gasp log for ONU
epon dynamic-binding-timeout — Configure dynamic binding entry
epon encryption — Configure encryption parameters
epon fast-switch — Fast switch
epon loid-accounting-method — Configure LOID accounting method name
epon loid-authentication-method — Configure LOID autheticating method name
epon mpcp-timeout — MPCP timeout
epon oam-linkfault-timeout — Configure OAM linkfault timeout
epon oampkt-to-cpu — Oam packet to host cpu
epon onu-config-template — Create onu configuration template
epon onu-lost-time — Configure lost time for onu
epon onu-uni-link-status-on — Enable onu uni port link status notify
epon private-oam — Configure private OAM
epon snmp-ipaddress — Ip address used for SNMP service

error-disable-recovery — A period in seconds after which the port will recovery from error-disable state
error-frame-alarm — Parameter of error frame alarm
ether-ring — Ethernet Automatic Protection Switching Configuration
ethernet — Конфигурация Ethernet
filter — Global Filter configuration subcommands
ftp — Конфигурация пользователей FTP сервера
garp — Конфигурация garp параметров
greeting — Установка приветствия при логине
gvrp — Gvrp enable
hostname — Установка имени системы
interface — Конфигурация интерфейса

ip access-list — Named access-list
ip arp — ARP setting
ip checkoverlap — Deny ip network overlap
ip checkptop — Check point-to-point network address asign
ip default-gateway — Specify default gateway (if not routing IP)
ip dhcp-relay — Relay agent setting
ip domain-list — Suffix of unqualified host names
ip domain-lookup — Enable IP DNS hostname translation
ip host — Add an IP host name-address entry to map

ip icmp port-unreach — Send Destination Port Unreach Packet
ip icmp protocol-unreach — Send Destination Protocol Unreach Packet
ip icmp source-quench — Send Source Quench Packet

ip igmp-proxy — Config igmp-proxy
ip local — Local cmds concerned
ip mcst — Config multicast
ip mld-proxying — Config MLD Proxying
ip mld-snooping — Config MLD Snooping
ip name-server — Specify IP DNS server
ip pbr — Policy-based route
ip radius — RADIUS configuration commands
ip source — IP source
ip source-route — Process IP packets with source routing option
ip sshd — Config ssh deamon
ip tacacs — Config TACACS+ information

ip tcp synwait-time — Wait on new TCP connections time
ip tcp window-size — TCP dataflow window size

ip telnet — Specify telnet options
ip verify — IP verify

line — Configure a terminal line
link — Configure link infomation
lldp — LLDP configuration commands
local — Configuring for local user manager
localauthen — Configuring for local authentication
localauthor — Configuring for local authorization
localgroup — Localgroup configuration
localpass — Configuring for local password
logging — Set message logging facilities
mac — Global MAC configuration subcommands
mac-vlan — Config the entry of MAC-based VLAN
mirror — Configure mirror
policy-map — Config qos policy
privilege — Set privilege for command
protocol-vlan — Config the template of protocol-based VLAN
radius-server — RADIUS configuration
rcommand — Run command on remote hs
rmon — Remote Monitoring
scheduler — Global scheduler configuration
serial-bridge — Serial bridge configuration
service — Set system services
short-ifdescr — Use brief name as ifDescr

show aaa users — Show AAA user infomation
show aggregator-group — Link Aggregation information
show alias — Alias for command
show arp — ARP таблица
show break — Switch breakpoint information
show configuration — Show configuration in flash memory
show controler — Show the system controler infomation
show cpu — Информация использования CPU
show debug — State of each debugging option
show dot1x — IEEE 802.1X information

show epon active-onu — Active ONU information
show epon always-laser-on-onu — Always laser on ONU
show epon basic-info — Basic information of OLT
show epon encryption — Global-level encryption parameters for an OLT
show epon inactive-onu — Inactive ONU information

show epon interface epon 0/1:1 onu basic-info — ONU basic information
show epon interface epon 0/1:1 onu ctc — China TeleCom
show epon interface epon 0/1:1 onu ctc basic-info — ONU basic information
show epon interface epon 0/1:1 onu ctc dba — Show ONU DBA queue set config
show epon interface epon 0/1:1 onu ctc optical-transceiver-diagnosis — Show ONU optical transceive diagnosis
show epon interface epon 0/1:1 onu ctc snmp-info — ONU SNMP information

show epon interface epon 0/1:1 onu d-info — Olt information
show epon interface epon 0/1:1 onu laser-always-on-check — Support laser always on check or not
show epon interface epon 0/1:1 onu mac address-table — Show ONU MAC address table
show epon interface epon 0/1:1 onu mac-aging-time — Mac aging time
show epon interface epon 0/1:1 onu olt-info — Olt information
show epon interface epon 0/1:1 onu pon-port statistics — Show ONU interface statistics
show epon interface epon 0/1:1 onu pon-port state — Show ONU interface state

show epon interface epon 0/1:1 onu port 1-4 ctc auto-negotiation — Show ONU interface auto negotiation
show epon interface epon 0/1:1 onu port 1-4 ctc flow-control — Show ONU interface flow control
show epon interface epon 0/1:1 onu port 1-4 ctc mcst — Multicast
show epon interface epon 0/1:1 onu port 1-4 ctc qos — Show ONU interface qos
show epon interface epon 0/1:1 onu port 1-4 ctc ratelimit-ingress — Show ONU interface ingress rate limit
show epon interface epon 0/1:1 onu port 1-4 ctc vlan — VLAN

show epon interface epon 0/1:1 onu port 1-4 state — Show ONU interface state
show epon interface epon 0/1:1 onu port 1-4 statistics — Show ONU interface statistics

show epon interface epon 0/1:1 onu serial — Serial
show epon interface epon 0/1:1 onu standby-pon-status — Show onu standby pon status

show epon loid-bind-table — LOID bind table
show epon mpcp-registration-mode — Multipoint control protocol registration mode
show epon onu-authen-method — ONU authentication method
show epon onu-information — Информация о ONU
show epon optical-transceiver-diagnosis — Optical transceiver diagnosis

show ether-ring — Display EAPS information
show ethernet — Display Ethernet
show filesys-trace — File system trace information
show filter — Display filters
show garp — Show garp config information
show gvrp — Show gvrp info
show hosts — Host table
show hs — Show hs register/version information
show ifindex-information — Display ifindex information
show interface — Interface status and configuration

show ip access-lists — List IP access lists
show ip dhcp-relay — Show DHCP relay
show ip igmp-proxy — Show igmp-proxy nformation
show ip interface — IP information and configuration of interface
show ip local — Set local options
show ip mcst — Show multicast
show ip mld-proxying — Show MLD Proxying nformation
show ip mld-snooping — Show MLD Snooping information
show ip sockets — IP sockets information
show ip sshd — Sshd information
show ip traffic — IP Traffic statistics information

show line — TTY line information
show lldp — Show LLDP message
show local-users — Show local user infomation
show logging — Show the contents of logging buffers
show mac address-table — MAC forwarding table

show memory datab — Show all allocated dblk
show memory heap — General heap information
show memory mblk — Mblk info
show memory msgb — Show all allocated mblk
show memory partition — Partion memory info
show memory region — Memory heap info
show memory static — Static memory info

show mirror — Show a mirror session
show oir-information — Online insert remove information
show onu-config-template — Show onu config template
show policy-map — Show policy-map
show resource — Share resource information
show rmon — Rmon statistics
show running-config — Current configuration
show snmp — SNMP statistics
show sntp — SNTP information
show spanning-tree — Display spanning-tree state
show ssh — The LINES connected in
show statistics — Port packet statistics
show system — Show the system configuration
show task — Task info
show tcp — Информация о TCP соединениях
show telnet — Отображение входящих telnet соединений
show time-range — Time range
show timers — Timer info
show version — Отображение версии коммутатора
show vlan — Информация о Vlan

snmp-server community 0/7 имя ro/rw
snmp-server contact — Text for mib object sysContact
snmp-server host — Specify hosts to receive SNMP TRAPs
snmp-server location — Text for mib object sysLocation
snmp-server packetsize — Largest SNMP packet size
snmp-server queue-length — Message queue length for each TRAP host
snmp-server trap-source — Assign an interface for the source address of all traps
snmp-server trap-timeout — Set timeout for TRAP message retransmissions
snmp-server view — Define an SNMP MIB view
snmp-server source-addr — Set source IP Address
snmp-server udp-port — Set UDP port of SNMP Agent
snmp-server encryption — HIDDEN community string
snmp-server trap-add-hostname — Add hostname in trap bind list
snmp-server trap-logs — Add trap to logs
snmp-server set-snmp-dos-max — Set Max request NUM retry in 5 min
snmp-server keep-alive — Set keep alive trap period, default 5 min
snmp-server necode — Set snmp network element code

sntp master — Act as SNTP master clock
sntp query-interval — Set interval to query SNTP server
sntp server адрес — Configure SNTP server

spanning-tree backbonefast — Setup spanning-tree protocol backbonefast function
spanning-tree bpdu-terminal — Disable bpdu forwarding when no STP mode is running
spanning-tree fast-aging — Enable fast MAC-address aging in rapid spanning-tree modes
spanning-tree loopfast — Setup spanning-tree protocol loopfast function
spanning-tree loopguard — Setup spanning-tree protocol loopguard function
spanning-tree management — Configure SNMP management of Spanning-tree
spanning-tree mode — Setup spanning-tree protocol mode
spanning-tree mstp — Setup spanning-tree protocol on mstp mode
spanning-tree portfast — Setup spanning-tree protocol portfast function
spanning-tree rstp — Setup spanning-tree protocol on rstp mode
spanning-tree sstp — Setup spanning-tree protocol on sstp mode
spanning-tree uplinkfast — Setup spanning-tree protocol uplinkfast function

start-trap-delay — Delay befor send cold-/warm- start trap

switch check-link enable — Enable link status check
switch check-link disable — Disable link status check
switch check-link hold-time — Configure the hold time for the status check when a unstable link is detected

switch check-queues — Configure interval for queues check
switch drop-igmp-from-rps — Don’t snooping igmp packets recevied from protection switching rings
switch enhanced-link — Configure enhanced link status check for certain port types
switch forward-pdu — Configure forwarding of unresolved L2 PDUs
switch multicast-rps — Specify multicast routing is used on protection switching rings

system mtu — System MTU config

tacacs-server — TACACS+ configuration
tftp-server — Start tftp server
time-range — Define time range entries
time-zone город +2 — Установка временной зоны
update — Upgrade HS

username имя autocommand — Automatically issue a command after the user logs in
username имя bind-ip — Bind user’s ip address
username имя bind-mac — Bind user’s mac
username имя bind-pool — Bind user’s address pool
username имя bind-port — Bind user’s port
username имя callback-dialstring — Callback dialstring
username имя callback-line — Associate a specific line with this callback
username имя callback-rotary — Associate a rotary group with this callback
username имя authen-group — Associate a local authentication group for this user
username имя author-group — Associate a local authorization group for this user
username имя pass-group — Associate a local password group for this user
username имя maxlinks — Limit the user’s number of inbound links
username имя nocallback-verify — Do not require authentication after callback
username имя noescape — Prevent the user from using an escape character
username имя nohangup — Do not disconnect after an automatic command
username имя password — Specify the password for the user

vlan — Vlan команды

Добавить комментарий