Восстановление доступа к странице ВКонтакте

В первую очередь можно восстановить пароль от страницы на мобильный телефон который привязан к странице http://vk.com/restore
Если телефон не привязывался к странице или к нему нету доступа, нужно сообщить об этом в техническую поддержку следую инструкциям по ссылке http://vk.com/restore?act=return_page

В случае если появляется сообщение что страница заблокирована и для разблокировки необходимо перевести деньги или отправить смс, это значит что на компьютере вирусы. Почистить можно лечащей утилитой Dr.Web CureIt! либо открыть в любом текстовом редакторе файл C:\WINDOWS\system32\drivers\etc\hosts и удалить все/ненужное содержимое оставив только строчку 127.0.0.1 localhost.

Ускорение работы iOS7

1. Включить «Увеличение контраста».
Это позволит убрать эффект прозрачности и размытия.
Настройки – Универсальный доступ – Увеличение контраста

2. Включить «Уменьшение движения».
Это позволит уменьшить анимацию, отключить параллакс-эффекты на значках и предупреждениях.
Настройки – Универсальный доступ – Уменьшение движения

3. Выключить обновление приложений в фоновом режиме.
Настройки – Основные

4. Отключить автоматическое обновление и загрузки.
Настройки – iTunes и App Store

Определение DDOS

Примеры просмотра количества активных соединений:

netstat -an | wc -l
netstat -anop
cat /proc/net/ip_conntrack | wc -l
netstat -anp | grep 'tcp\|udp' | cut -d: -f1| sort | uniq -c
netstat -anp |grep 'tcp\|udp' | awk '{print $5}' | cut -d: -f1 | sort | uniq -c | sort -n

Примеры просмотра соединений на порт, например 80:

netstat -na | grep :80 | wc -l
netstat -na | grep :80 | grep syn
netstat -na | grep ":80\ " | grep syn
netstat -na | grep ":80\ " | grep SYN | wc -l
netstat -na | grep ":80\ " | grep SYN | sort -u | more
netstat -na | grep ":80\ " | grep SYN_RCVD
netstat -na | grep ":80\ " | sort | uniq -c | sort -nr | less

Определение SYN атаки:

netstat -n --tcp | grep SYN_RECV
netstat -n --tcp | grep SYN_RECV | wc -l

Просмотр количества процессов Апача:

ps aux | grep apache | wc -l

Статус Apache2:

apachectl status

Просмотреть логи Apache2 /var/log/apache2/error.log, /var/log/apache2/access.log, …
Просмотр в логах количества запросов с ip адресов:

cat /var/log/apache2/access.log | awk '{print $1}' | sort | uniq -c

На какой домен чаще идут запросы:

tcpdump -npi eth0 port domain

Просмотр загрузки сетевых интерфейсов:

sudo cat /proc/net/dev

Просмотр открытых портов:

netstat -na|grep LISTEN
nmap -r -v -O 127.0.0.1

Как удалить учетную запись Yahoo?

Для удаления учетной записи Yahoo необходимо перейти по указанной ниже ссылке и следовать инструкциям.
https://edit.yahoo.com/config/delete_user
на русском:
https://edit.yahoo.com/config/delete_user?.intl=ru

Mikrotik CLI

Приведу некоторые примеры команд:

ПОЛЬЗОВАТЕЛИ.
По умолчанию для входа используется логин admin без пароля.
Добавление пользователя:

use add name=имя password=пароль group=full

Отключаемся чтобы зайти под новым пользователем:

quit

Отключение пользователя:

user disable admin

Просмотр пользователей:

user print

ИНТЕРФЕЙСЫ.
Просмотр интерфейсов:

interface print

Активация интерфейса:

interface enable 0

Назначение интерфейсу IP адреса:

ip address add address 172.17.1.199/24 interface ether1

Просмотр IP адресов:

ip address print

Изменение MTU интерфейсов:

interface set 0,1,2 mtu=1500

Изменение mac адреса интерфеса:

/interface ethernet set ether1 mac-address=00:01:02:03:04:05

Сброс mac адреса интерфеса:

/interface ethernet reset-mac ether1

Установка шлюза по умолчанию:

ip route add gateway=172.16.1.131

Просмотр маршрутов:

ip route print

Устанавливаем первичный и вторичный адреса DNS серверов:

ip dns set primary-dns=8.8.8.8 secondary-dns=8.8.4.4 allow-remote-requests=yes

Просмотр DNS параметров:

ip dns print

БЕСПРОВОДНЫЕ ИНТЕРФЕЙСЫ.
Просмотр беспроводных интерфейсов:

/interface wireless print

ВРЕМЯ.
Установка часового пояса:

system clock set time-zone=+2

Установка ip адреса ntp сервера с которым будет сверяться время:

system ntp client set enabled=yes primary-ntp=172.16.1.131

Просмотр времени:

/system clock print

ФАЕРВОЛ.
Настройка маскарадинга, чтобы чтобы внутренняя сеть не была видна с WAN порта:

ip firewall nat add chain=srcnat action=masquerade out-interface=интерфейс провайдера

Просмотр правил:

ip firewall filter print

Пример ограничения количества соединений с одного IP:

/ip firewall rule forward add protocol=tcp tcp -options=syn-only connection-limit=5 action=drop

Пример блокировки всех TCP пакетов идущих на порт 135:

/ip firewall rule forward add dst -port=135 protocol=tcp action=drop

Пример проброса портов:

/ip firewall dst-nat add action=nat protocol=tcp dst-address=10.0.0.217/32:80 to-dst-address=192.168.0.4

СИСТЕМА:
Просмотр стандартных настроек:

/system default-configuration print

Сброс настроек:

/system reset-configuration

Просмотр истории:

/system history print

СЛУЖБЫ.
Просмотр служб:

/ip service print

ПРОЧЕЕ.
Переход на уровень выше:

/

Выполнение команды из другого уровня без смены текущего:

/.

Помощь:

?

Настройка маршрутизатора с помощью мастера настроек:

setup

Пинг:

ping 192.168.1.2 count 3 size 512

Ctrl+X — вход и выход из безопасного режима.

Официальная страница загрузок http://www.mikrotik.com/download

Отключение рекламы приходящей от МТС (UMS)

Заметил что при заблокированном экране в телефоне с SIM-картой MTS (UMS) постоянно появляется разного рода реклама. Что собственно раздражает и влияет на заряд аккумулятора. Для отключения необходимо открыть меню SIM-карты (Меню SIM) -> МТС Клик -> Активация -> Отключить.

Для отключения/включения смс рекламы приходящей от МТС необходимо отправить смс любого содержания на бесплатный номер 10250.

Проверка WMID (PHP)

Проверка WMID реализованная на языке веб-программирования PHP.
Автор: © Сергей eLRiz Козлов
Исходный код:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

    <title>Проверка WMID</title>

</head>

<body>

<?php

    if( isset( $_GET['wmid'] ) AND is_numeric( $_GET['wmid'] ) == TRUE AND strlen( $_GET['wmid'] ) == 12 )

    {

        $url = iconv( 'windows-1251', 'UTF-8', file_get_contents( 'http://passport.webmoney.ru/asp/certcard.asp?id='. $_GET['wmid'] ) );

        preg_match_all( "|</[^>]+>(.*)<[^>]+>|U", $url, $out, PREG_PATTERN_ORDER );

        if( isset( $out[0][4] ) )

            echo 'WMID#: '. $_GET['wmid'] .'<br />'.

                  strip_tags( $out[0][4] ) .'<br />

                  Бизнес-уровень: '. strip_tags( $out[0][8] ) .'<br />

                  Претензий: '. strip_tags( $out[0][10] ) .'<br />

                  <form action="http://arbitrage.webmoney.ru/asp/newclaims.asp" method="get">

                    <input type="submit" value="Оставить отзыв или претензию" />

                    <input type="hidden" name="procwmid" value="'. $_GET['wmid'] .'" />

                  </form>';

        else

            echo '<font color="#FF0000"><b>Ошибка! Такой WM-идентификатор незарегистрирован</b></font><br />';

        echo '<a href="wmid.php">Назад</a>';

    }

    else

        echo '<form action="wmid.php" method="get">

                WMID#: <br />

                <input type="text" name="wmid" maxlength="12" /><br />

                <input type="submit" value="Найти" /><br />

            </form>';

?>

</body>

</html>

Восстановление данных с помощью Foremost

Установка в Linux Ubuntu/Debian:

sudo aptitude install foremost

Справка:

foremost –h

Опишу некоторые ключи запуска:
-V Показывает информацию о версии программы и авторских правах.
-t Определяет расширения файлов для поиска.
-d Для файловых систем UNIX
-i Определяет устройство или образ.
-a Записывает все заголовки не выполняя обнаружение ошибок.
-w Не восстанавливать файлы, записать только файл с отчетом.
-o Директория для сохранения восстановленных файлов.
-c Указывает конфигурационный файл.
-q Быстрый режим. Могут быть пропущены файлы, так как поиск идет только в начале сектора, остальная его часть пропускается, также не рекомендуется использовать с файловой системой NTFS.
-Q Тихий режим, часть сообщений об ошибках не будут отображены.
-v Подробный режим, выводит все сообщения на экран.

Смотрим какие есть устройства:

sudo fdisk -l

Допустим у нас есть USB флешка и мы хотим сохранить у себя в файл ее образ:

sudo dd if=/dev/sdb1 of=fleshka.dd

Создадим где нам удобно директорию для восстановленных файлов:

mkdir ./out

Примеры запуска:

sudo foremost -t jpg -o ./out fleshka.dd
sudo foremost -t jpeg,png,gif -o ./out -v -i /dev/sda
sudo foremost -t all -d -o ./out -v -i /dev/sda

Обновление прошивки тюнеров PBI DMM-1400P

Прошивал как-то тюнера PBI DMM-1400P-S2 на 32 и 6 каналов.

Опишу порядок действий:
1) Скачаем архив с прошивкой и распакуем его. В архиве скорее всего будет два файла, target1.cod (обновления ядра Linux) и target2.cod (обновление ARM7+FPGA+IP-IN+IP-OUT). Их может быть и три или один, прошивать нужно будет по одному файлу. Прошивку можно найти на support.deps.ua после регистрации или вот здесь которой я прошивал Скачать прошивку для PBI DMM-1400P.

2) Подключим устройство витой парой к компьютеру или сети и включим его.

3) В браузере Internet Explorer или в проводнике в адресной строке наберем ftp://ip_адрес_устройства, чтобы открылась папка устройства (в других браузерах это скорей не получится сделать). Стандартный IP устройства 10.10.70.48.

4) Переместим мышкой первый файл target1.cod в открывшуюся папку.

5) Откроем командную строку (Пуск — выполнить — cmd.exe) и в ней наберем «telnet ip_адрес_устройства», далее введем логин «root», пароль «12345». Можно также использовать утилиту Putty для подключения через telnet.
Затем наберем команды:

KILL
upgrade target1.cod

Если команда KILL не работает или после её ввода ничего не отображается (а должно отобразится что-то на подобии «main_pid is 23 killing…», то вместо неё выполним:

ps

Посмотрим под каким pid работает первый /ramdisk/pbi и выполним команду ниже (где 23 — номер pid):

kill -9 23

После ввода команды upgrade подождем пока пройдет процесс обновления.
По окончанию устройство автоматически перезагрузится.

Если файлов прошивки несколько, то после перезапуска устройства повторим процедуру со следующим фалом, скинем файл target2.cod в устройство и выполним команды:

KILL
upgrade target2.cod

Все, настройки остались без изменений.
Каналы открытые CAM-мудулем начали идти без звука, по этому в настройках CI нужно поставить пункт Audio Descramble на Enable (по умолчанию Disable).

Смотрите также: Скачать HDMS — программа для удаленного управления и мониторинга оборудования PBI

Снял процесс обновления прошивки на видео:

IT сокращения

Ad — Advertisiment, Advertising, Реклама.
ADSL — Assymetrical Digital Subscriber Line, асимметричная цифровая абонентская линия. Технология передачи данных по телефонным линиям.
Admin — administrator, администратор.
AFK — Away from keyboard, далеко от клавиатуры, отошел от клавиатуры.
ANSI — American National Standart Institute, Американский национальный институт стандартов.
ASCII — American Standard Code for Information Interchange, Американский стандартный код для обмена информацией.
BRB — Be Right Back, отошел ненадолго, скоро вернусь.
Bug — Ошибка, сбой, дефект.
GUI — Graphic User Interface
Tbit — Terabit, Терабит
Gbit — Gigabit, Гигабит
Kbit — Kilobit, Килобит
ASP — Active Server Pages, активные серверные страницы.
CGI — Common Gateway Interface, интерфейс прикладного программирования.
CMYK — Cyan-Magneta-Yellow-blacK, голубой-пурпурный-желтый-черный.
CSS — Cascading Style Sheets, Таблицы Каскадных Стилей.
DNS — Domain Name System, служба имен доменов.
dpi — Dots per inch, число точек на дюйм.
FAQ — Frequently Asked Questions, часто задаваемые вопросы.
FTP — File Transfer Protocol, протокол передачи файлов.
GIF — Graphics Interchange Format, графический формат файла.
Html — Hypermarket MarkUp Language, язык гипертекстовой разметки.
HTTP — HyperText Transport Protocol, протокол для передачи гипертекста.
ID — IDentifier, идентиикатор.
IE — Internet Explorer.
IP — Internet Protocol, сетевой протокол передачи и машуртизации сообщений между Интернет узлами.
IRC — Internet Relay Chat, многопользовательская система общения.
ISO — The International Organization for Standardization, International Standarts Organization, международная организация по стандартизации.
IСQ — I seek you, программа, интернет-пейджер для общения друг с другом.
JPEG — Joint Photographics Experts Group, стандарт на сжатие полноцветных неподвижных изображений разработанный группой JPEG.
JPG — Графический файл в формате JPEG.
Logo — Logotype, логотип, фирменный знак.
lpi — Lines per inch, число строк (линий) на дюйм.
MIDI — Musical Instruments Digital Interface.
N/A — Not available, нет данных, не доступен.
Net — Network, сеть.
Nick — Nickname, псевдоним.
PC — Personal Computer, персональный компьютер.
Perl — Practical Extraction and Report Language.
Pic — Picture, изображение, картинка.
PING — Packet Internet Groper
POP — Post Office Protocol, почтовый протокол.
pt — point.
RGB — Red-Green-Blue, Красный — Зеленый — Синий, система цветопередачи.
RTFM — Read This Fucking Manual, прочтите эту чертову документацию (руководство).
SEO — Search Engine Optimization, поисковая оптимизация сайта.
SMTP — Simple Mile Transfer Protocol, простой протокол для передачи электронной почты.
SQL — Structured Query Language, язык структурированных запросов.
SSI — Server Side Includes, включения на стороне сервера.
THX — Thanks, спасибо.
TIFF — Tag Image File Format.
U — YOU.
URL — Uniform Resource Locator, стандартизованная строка символов, указывающая местонахождение документа или его части в Интернет.
W3C — World Wide Web Consortium, Организация занимающаяся разработкой стандартов и спецификаций для веб.
XML — eXtensible Markup Language, Расширяемый язык разметки гипертекста.