Решение «Port is not compatible with aggregators in channel 1 and cannot attach to them»

Однажды на Cisco Catalyst 6509-E, когда я собрал агрегацию из троих портов, трафик начал ходить только по двум портам и в логах появилось сообщение:

%EC-SP-5-CANNOT_BUNDLE_LACP: Gi1/7 is not compatible with aggregators in channel 1 and cannot attach to them (trunk mode of Gi1/7 is dynamic, Gi1/8 is trunk)

Все три порта были настроены одинаково:

interface GigabitEthernet1/6
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 228
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 lacp rate fast
 channel-protocol lacp
 channel-group 1 mode active
end

interface GigabitEthernet1/7
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 228
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 lacp rate fast
 channel-protocol lacp
 channel-group 1 mode active
end

interface GigabitEthernet1/8
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 228
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 lacp rate fast
 channel-protocol lacp
 channel-group 1 mode active
end

Проблему решил удалив порт из агрегации, повторил настройки и снова добавил порт в агрегацию:

interface GigabitEthernet1/7
shutdown
no channel-group 1 mode active
switchport mode trunk
channel-group 1 mode active
no shutdown

После этого трафик начал ходить по всем портам.
Подобная ошибка может также возникнуть из-за разной настройки портов, детальная причина обычно пишется в скобках, как у меня например «(trunk mode of Gi1/7 is dynamic, Gi1/8 is trunk)», хотя они и были настроены одинаково, возможно в моем случае был баг.

Смотрите также мою статью:
Настройка агрегации каналов на Cisco Catalyst 6500

Did my article help you? How about buying me a cup of coffee as an encouragement? Buy me a coffe.

Оставьте комментарий

Добавить комментарий