Solution “Port is not compatible with aggregators in channel 1 and cannot attach to them”

Once on Cisco Catalyst 6509-E, when I collected an aggregation of three ports, traffic began to go through only two ports and a message appeared in the logs:

%EC-SP-5-CANNOT_BUNDLE_LACP: Gi1/7 is not compatible with aggregators in channel 1 and cannot attach to them (trunk mode of Gi1/7 is dynamic, Gi1/8 is trunk)

All three ports were configured the same:

interface GigabitEthernet1/6
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 228
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 lacp rate fast
 channel-protocol lacp
 channel-group 1 mode active
end

interface GigabitEthernet1/7
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 228
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 lacp rate fast
 channel-protocol lacp
 channel-group 1 mode active
end

interface GigabitEthernet1/8
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 228
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 lacp rate fast
 channel-protocol lacp
 channel-group 1 mode active
end

I solved the problem by removing the port from the aggregation, repeated the settings and again added the port to the aggregation:

interface GigabitEthernet1/7
shutdown
no channel-group 1 mode active
switchport mode trunk
channel-group 1 mode active
no shutdown

After that, traffic began to go through all the ports.
Such an error can also occur due to different port settings, a detailed reason is usually written in brackets, as I have for example “(trunk mode of Gi1 / 7 is dynamic, Gi1 / 8 is trunk)”, although they were configured the same way, perhaps in my case there was a bug.

See also my article:
Configuring link aggregation on the Cisco Catalyst 6500

Did my article help you? How about buying me a cup of coffee as an encouragement? Buy me a coffe.

Leave a comment

Leave a Reply