Решение «Port is not compatible with aggregators in channel 1 and cannot attach to them»

Однажды на Cisco Catalyst 6509-E, когда я собрал агрегацию из троих портов, трафик начал ходить только по двум портам и в логах появилось сообщение:

Читать далее «Решение «Port is not compatible with aggregators in channel 1 and cannot attach to them»»

Настройка агрегации каналов на Cisco Catalyst 6500

Для теста настрою агрегацию на Cisco Catalyst 6509-E.

Допустим я настроил первый порт как мне нужно, прописал нужные VLAN, теперь последними командами добавим порт в канал агрегации:

interface GigabitEthernet1/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
no cdp enable
lacp rate fast
channel-protocol lacp
channel-group 1 mode active

Второй порт должен быть настроен аналогично и тоже последними командами добавим его в канал агрегации:

interface GigabitEthernet1/8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
no cdp enable
lacp rate fast
channel-protocol lacp
channel-group 1 mode active

После команд выше автоматически создался выключенный интерфейс Port-channel1, командой description добавим примечание и включим его:

interface Port-channel1
description GPON OLT link aggregation
no shutdown

Настройка агрегации портов завершена, к ним можно подключаться.
Замечу что агрегацию лучше настраивать с парным количеством линков, так как на не парный линк обычно меньше нагрузка.
Лично я предпочитаю не использовать агрегацию каналов, а использовать линки по 10Gb/s и 40Gb/s.

Если нужно удалить несколько VLAN, то достаточно удалить их на Port-channel1 (на портах входящих в агрегацию они удалятся автоматически):

interface Port-channel1
switchport trunk allowed vlan remove 180-190

Пример просмотра различной информации про агрегацию:

show lacp 1 internal
show etherchannel 1 detail
show etherchannel summary
show etherchannel load-balance
show interfaces gi1/7
show interfaces gi1/8
show ip int brief
show cdp neighbor
show lldp neighbor
show interfaces status err-disabled

Смотри также мои статьи:
Решение «Port is not compatible with aggregators in channel 1 and cannot attach to them»
Настройка агрегации каналов на Huawei SmartAX MA5600

Настройка агрегации каналов на Huawei SmartAX MA5600

На тесте настрою агрегацию на двух портах Huawei SmartAX MA5683T и Cisco Catalyst 6509-E.

Читать далее «Настройка агрегации каналов на Huawei SmartAX MA5600»

LACP. Настройка агрегации каналов на коммутаторах D-Link

Агрегация каналов (link aggregation) — технология позволяющая объединить несколько физических каналов в один логический, что увеличивает пропускную способность и надежность канала.

Читать далее «LACP. Настройка агрегации каналов на коммутаторах D-Link»