Настройка TP-Link EP110

На тесте буду подключать TP-Link EP110 ONT к BDCOM P3310B-2AC EPON OLT.

Чтобы настроить TP-Link EP110 необходимо подключить его к компьютеру кабелем и набрать адресной строке браузера http://192.168.1.1, далее отключить в меню DHCP сервер, сняв галочку с DHCP.

Также необходимо выбрать режим работы ONT как указано на рисунке ниже:
tp-link-ep110

После этого TP-Link EP110 будет работать и прописываться аналогично другим ONT, таким как BDCOM P1501C1, FOXGATE 1001w и т.д.

Смотрите также:
Настройка BDCOM P3310 EPON

Обновление прошивки коммутатора TP-Link TL-SG5412F

Сегодня решил обновить прошивку на коммутаторе TP-Link TL-SG5412F.

Подключился через telnet к коммутатору и посмотрел версию установленной прошивки (у меня она была 1.0.4 Build 20140430 Rel.40858):

show system-info

Также её можно посмотреть на главной странице веб-интерфейса коммутатора.

На официальном сайте http://www.tp-link.com/us/download/TL-SG5412F.html#Firmware нашел версию новее — 1.0.5 20150130 rel38923.
Скачал архив с прошивкой и распаковал его, файл прошивки назывался TL-SG5412Fv1_en_1.0.5_[20150130-rel38923]_up.bin.

Сделал копию конфигурации коммутатора на TFTP сервер (так как после обновления прошивки СБРОСЯТСЯ НАСТРОЙКИ!):

copy startup-config tftp ip-address 192.168.0.5 filename tplink.cfg

Смотрите мои статьи по TFTP:
Установка и настройка TFTP сервера в Ubuntu
Запуск TFTP сервера на Windows

Можно не использовать TFTP, а сохранить конфигурацию через веб-интерфейс, открыв System — System Tools — Config Backup.

Чтобы обновить прошивку коммутатора откроем System — System Tools — Firmware Upgrade, выберем файл и нажмем Upgrade для запуска процесса обновления.
Во время обновления прошивки коммутатора нельзя отключать питание, иначе он может не запустится.

Из терминала используя TFTP можно обновить так:

firmware upgrade ip-address 192.168.0.5 filename firmware.bin

Когда прошивка обновилась, подключимся к коммутатору по стандартному IP — 192.168.0.1 (логин и пароль admin) и восстановим конфигурацию если это необходимо.
Через веб-интерфейс System — System Tools — Config Restore.
Если через telnet или консоль:

copy tftp startup-config ip-address 192.168.0.5 filename tplink.cfg

Смотрите также:
Настройка коммутатора TP-Link TL-SG5412F

Прошивка TP-LINK TL-WR840N V2 от Kyivstar

На тесте буду прошивать TP-LINK TL-WR840N V2 от Kyivstar
С установленной следующей версией прошивки:

Версия встроенного ПО:
3.16.9 Build 160829 Rel.55894n
Версия оборудования:
WR840N v2 00000000

Сначала необходимо попробовать прошить через TFTP.
Как запустить на компьютере TFTP сервер я описывал в этих статьях:
Запуск TFTP сервера на Windows
Установка и настройка TFTP сервера в Ubuntu

Скачиваем архив с прошивками отсюда https://drive.google.com/open?id=0B6jR5-c775m9eERNc1h2b0NsVWM
Файл wr840nv2_tp_recovery.bin помещаем в директорию TFTP сервера.
Назначим компьютеру именно этот IP-адерс — 192.168.0.66 и маску 255.255.255.0, соединим его с маршрутизатором через любой LAN-порт.
Выключим питание маршрутизатора, нажмем кнопку reset на задней стенке маршрутизатора и продолжая держать включим питания, засветится замочек, reset отпускаем.
Этим мы перевели его в режим восстановления, в котором он начнет пытаться загрузить файл wr840nv2_tp_recovery.bin с TFTP-сервера 192.168.0.66.
После успешной загрузки прошивки маршрутизатор сам перезагрузится и запустится с данной прошивкой.
Если обновление прошло успешно, то откроем в браузере веб интерфейс маршрутизатора набрав 192.168.0.1 (логин и пароль admin) и обновим прошивку файлом wr840nv2_ru_3_16_9_up_boot(150929).bin.
Смотрите также — Обновление прошивки маршрутизатора TP-Link TL-WR840N

Если маршрутизатор остался на прошивке от Kyivstar c IP адресом 192.168.1.1 (логин и пароль kyivstar), то остается второй вариант — выпаять микросхему памяти, подключить её к программатору, сохранить копию данных (dump) на всякий случай и записать другой dump https://drive.google.com/open?id=0B6jR5-c775m9WFltcnVWRTdtVUU (заранее изменив в нем через HEX редактор на оригинальные — MAC (по адресу 1FC00) и PIN (по адресу 1FE00 )).
После этого обратно припаяем микросхему.

В моём случае маршрутизатор (с версией прошивки указанной в начале статьи) обновлялся по TFTP, но прошивка оставалась прежней от Kyivstar, поэтому пришлось воспользоваться программатором.
Однако ходят слухи что по TFTP можно прошить некоторые версии.

Смотрите также:
Прошивка TP-LINK TL-WR741ND(KS) V2 от Kyivstar
Прошивка TP-LINK TL-WR741ND(KS) V4 от Kyivstar
Восстановление маршрутизатора TP-Link TL-WR740N

Обновление прошивки маршрутизатора TP-Link TL-WR840N

Для теста буду обновлять маршрутизаторы TP-Link TL-WR840N V1 с прошивкой 13xxxx RU.


1) Посмотрим ревизию маршрутизатора, в моем случае это V1, и именно для неё скачаем архив с новой прошивкой с официального сайта http://www.tp-link.ua/ru/download/TL-WR840N.html. В моем случае последняя прошивка для V1 была TL-WR840N_V1_151023_RU. Если скачать прошивку не от той ревизии, то можно повредить маршрутизатор. Распакуем из скачанного архива файл прошивки.

2) Откроем настройки маршрутизатора набрав в браузере адрес http://192.168.0.1 и введем логин — admin, пароль — admin.

3) В меню выбираем «Системные инструменты» — «Обновление встроенного ПО», нажимаем кнопку «Обзор…» и выбираем ранее распакованный из архива файл прошивки. Далее нажмем кнопку «Обновить» и дождемся пока прошивка загрузится в маршрутизатор и он перезагрузится.

В момент обновления нельзя отключать питание маршрутизатора.
После обновления прошивки, настройки в маршрутизаторе не сбросились.

Смотрите также:
Прошивка TP-LINK TL-WR840N V2 от Kyivstar

Прошивка TP-LINK TX-6610

Для теста возьму TP-LINK TX-6610 Ver:2.0

Первым делом скачаем прошивку с официального сайта http://www.tp-linkru.com/download/TX-6610_V2.html

Если версия устройства не 2, то нужно выбрать необходимую иначе прошивка не от той версии может испортить устройство.

Пропишем компьютеру вручную IP-адрес например 192.168.1.2 и откроем в браузере 192.168.1.1, логин и пароль одинаковые — admin.

В открывшемся интерфейса TP-LINK TX-6610 выберем «Management» -> «Firmware Upgrade«, нажмем «Обзор«, укажем файл прошивки и запустим процесс обновления нажав «Upgrade«.

В процессе категорически нельзя отключать питание, по завершению устройство само перезагрузится.

Резервное копирование конфигурации TP-Link коммутаторов

Набросал скрипт для резервного копирования конфигурации TP-Link коммутаторов.
Скрипт выполняется на Linux где запущен TFTP сервер, он подключается по telnet к коммутатору и специальной командой конфигурация отправляется на указанный TFTP, по закрытию telnet соединения, файл перемещается в нужную директорию, а также последняя команда удаляет файлы которым больше 30 дней, так как больше их хранить мне не нужно.
Также можно ежемесячно делать например копию всех файлов в облако.
Как видно, перед вводом пароля в скрипте ставить паузу нельзя.

#!/bin/bash
{
echo "ПАРОЛЬ";
echo "enable";
echo "ПАРОЛЬ";
echo "copy startup-config tftp ip-address 192.168.0.5 filename tplink";
sleep 2;
echo "exit";
sleep 1;
echo "exit";
} | telnet 192.168.0.110

mv /srv/tftp/tplink.cfg /backups/devices/tplink/`date +%Y-%m-%d`_tplink.cfg
find /backups/devices/tplink/ -type f -mtime +30 -exec rm {} \;

Скрипт перезагрузки Wi-Fi маршрутизаторов TP-Link

Приведу ниже пример скрипта перезагрузки маршрутизаторов TP-Link, на тесте проверю его на TL-WR720N 2.0 из Ubuntu Server.

#!/bin/sh
ROUTER_IP="192.168.24.174"
USERNAME="admin"
PASSWORD="admin"

# exit if router is down
ping -q -c 1 "$ROUTER_IP" > /dev/null || exit

curl --basic --user "$USERNAME:$PASSWORD" -A "Mozilla/4.73 [en] (X11; U; Linux 2.2.15 i686)" --refer "http://$ROUTER_IP" "$ROUTER_IP/userRpm/SysRebootRpm.htm?Reboot=reboot"

Содержимое скрипта поместим в новый файл, например используя редактор nano («CTRL+X» для выходя и «y» для сохранения изменений):

nano file.sh

И сделаем его исполняемым:

chmod 777 file.sh

После этого выполним:

./file.sh

Аналогичным образом можно вместо перезагрузки выполнить другие функции.

Настройка коммутатора TP-Link TL-SG5412F

На тесте настрою новый коммутатор TP-Link TL-SG5412F

Напомню что скорость при подключении через консоль — 38400, стандартный IP — 192.168.0.1, логин — admin, пароль — admin.

После подключения через консоль перейдем в режим конфигурирования:

enable
config

Выполним начальные настройки чтобы можно было подключаться по telnet и укажем пароль при переходе в режим конфигурирования:

line vty 0 5
login local
exit
enable password ПАРОЛЬ

Изменим стандартный пароль запрашиваемый при подключении на такой же:

line vty 0 5
login
password ПАРОЛЬ
exit
enable password ПАРОЛЬ

Добавим VLAN для управления (у меня он 207):

vlan 207
name core
exit

И для пользователей (226):

vlan 226
name local_smart
exit

Укажем коммутатору IP адрес в управляемом VLAN (где 192.168.0.1 шлюз):

interface vlan 207
ip address 192.168.0.223 255.255.255.0 192.168.0.1
exit

Удалить VLAN или отключить какую либо функцию можно дописав слово no перед командой, например:

no vlan 207

Активируем функцию защиты от петель:

loopback-detection
loopback-detection interval 50
loopback-detection recovery-time 3
show loopback-detection global

Настроим порты для пользователей (у меня 9 порт uplink, остальные пользовательские):

interface range gigabitEthernet 1/0/1-8,1/0/10-12
switchport mode access
switchport access vlan 226
switchport pvid 226
storm-control broadcast
storm-control rate 1m
loopback-detection
loopback-detection config process-mode port-based recovery-mode auto
exit

Теперь настроим uplink порт (у меня он 9, с него будет приходить интернет) и укажем что с этого порта можно приходить DHCP пакетам:

interface gigabitEthernet 1/0/9
switchport mode trunk
switchport trunk allowed vlan 207,226
ip dhcp snooping trust
exit
ip management-vlan 207

Пример просмотра настроек dhcp snooping:

show ip dhcp snooping
show ip source binding
show ip dhcp snooping interface gigabitEthernet 1/0/9

Приведу пример манипуляций с портом (выключение, установка скорости подключения, восстановление после петли):

interface gigabitEthernet 1/0/1
shutdown
no shutdown
duplex full
speed auto
loopback-detection recover
exit

Чтобы настроить прохождение трафика с тегом и без тега выполним следующее:

interface gigabitEthernet 1/0/2
switchport mode general
switchport general allowed vlan 207 tagged
switchport general allowed vlan 226 untagged
exit

Посмотрим наши VLAN настройки:

show vlan

Ограничим доступ к управлению устройством по IP или MAC-адресу (заметил что можно прописать только один IP адрес, по этому разрешил на подсеть:

user access-control ip-based 192.168.0.0 255.255.255.0
user access-control mac-based 00:00:22:22:11:11

Укажем через сколько минут простоя отключать администраторов:

user idle-timeout 10
show user configuration

Настроим встроенную защиту от DoS атак:

ip dos-prevent
ip dos-prevent type xma-scan
ip dos-prevent type scan-synfin
ip dos-prevent type null-scan
ip dos-prevent type ping-flood
ip dos-prevent type syn-flood
show ip dos-prevent

Настроим логи (уровень логирования от 0 до 7, 7 — вся информация):

show logging local-config
logging buffer 6
logging flash 2

Для очистки логов используется команда:

clear logging buffer/flash

Настройка отправки логов 5 уровня на сервер:

logging host index 1 192.168.0.2 5
show logging loghost

Просмотр логов:

show logging buffer
show logging buffer level 4
show logging flash
show logging flash level 1

Время хранения mac-адреса в таблице коммутатора, стандартно 300 секунд (5 минут):

mac address-table aging-time 300

Пример просмотра таблицы mac-адресов:

show mac address-table address all
show mac address-table interface gigabitEthernet 1/0/1
show mac address-table vlan 207

Установим время:

system-time manual 09/21/2016-12:10:00
system-time ntp UTC+02:00 192.168.0.1 192.168.0.1 11
show system-time
show system-time ntp
show system-time dst

Настроим SNMP:

snmp-server
snmp-server community public read-write viewDefault
show snmp-server
show snmp-server view
show snmp-server group
show snmp-server user
show snmp-server community
show snmp-server host
show snmp-server engineID

Диагностика кабеля и просмотр некоторых параметров:

show cable-diagnostics interface gigabitEthernet 1/0/1
show interface status
show interface configuration
show storm-control
show bandwidth
show port isolation interface

Сохраним настройки выйдя из режима конфигурации:

exit
copy running-config startup-config

Можно также отправить файл настроек на TFTP сервер:

copy startup-config tftp ip-address 192.168.0.2 filename config.cfg

Чтобы загрузить в коммутатор файл настроек с TFTP сервера выполним:

copy tftp startup-config ip-address 192.168.0.2 filename config.cfg

Посмотреть конфигурацию можно командой:

show running-config

Перезагружается коммутатор командой:

reboot

Добавление ONU TP-LINK TX-6610 на Huawei SmartAX MA5683T

Предположим что мы заходили в веб-интерфейс onu TP-LINK TX-6610 (стандартный IP 192.168.0.1, логин admin, пароль admin) и указали в настройках транзитный режим (transparent mode).
Смотрите как это делается в видео:

Потом на Huawei SmartAX MA5683T добавили lineprofile/srvprofile профайлы onu по этой инструкции: Настройка Huawei SmartAX MA5683T через консоль

При первом подключении к настроенному Huawei SmartAX MA5683T для начала перейдем в режим конфигурации и режим настройки Gpon интерфейса:

enable
config
interface gpon 0/5

Теперь добавим онушку с указанием её серийного номера :

ont add 1 16 sn-auth "54504C47008974B2" omci ont-lineprofile-id 10 ont-srvprofile-id 10 desc "OPISANIE"
ont port native-vlan 1 16 eth 1 vlan 228 priority 0

Где цифра 1 означает номер Gpon порта на котором подключена онушка, серийный номер онушки мы узнаем набрав по очереди команды поиска новых не добавленных онушек:

display ont autofind 0
display ont autofind 1
...
display ont autofind 7

Цифра 16 означает ID онушки и указывается следующей свободной по очередности после добавленных в конфиге онушек, список занятых ID можно увидеть набрав команду отображающую конфиг (для каждого gpon порта свои ID онушек):

display current-configuration

Выйдем из режим конфигурации Gpon интерфейса:

quit

Добавим сервис-порт который будет выдавать не тегированный трафик на ону (цифра 177 означает номер сервис порта и берется из свободных по очередности):

service-port 177 vlan 228 gpon 0/5/1 ont 16 gemport 1 tag-transform default

Сохраним конфигурацию:

save

На этом все, онушка будет работать в качестве медиаконвертора.

Прошивка TP-LINK TL-WR741ND V2 с OpenWrt на заводскую

Прошивал как-то маршрутизатор TP-LINK TL-WR741ND V2 с прошивкой OpenWrt | Kamikaze (r25068).
Стандартный логин root без пароля. Пользователь установил какой-то свой пароль, по этому пришлось зажать reset на 15 секунд при включенном роутере чтобы сбросить настройки.

Для начала скачиваем специальную прошивку — wr741ndv1_ru_3_11_7_up(100925)-factory
И последнюю официальную — http://www.tp-linkru.com/download/TL-WR741ND_V2.html#Firmware

Подключимся к маршрутизатору через любой из LAN портов, заходим в настройки набрав в браузере http://192.168.1.1 (либо http://192.168.0.1) и вводим логин и пароль admin.
После того как открылись настройки, нажмем SystemFlash Firmware, выберем «Обзор» и укажем на распакованный из архива файл специальной прошивки, снимем галочку «Keep configuration«, клацнем «Upload» и «Proceed» для запуска процесса обновления.

По завершению процесса открываем веб-интерфейс маршрутизатора по тому же адресу http://192.168.1.1, с логином и паролем admin. В самом низу выберем «Системные инструменты» — «Обновление встроенного микро ПО«, нажмем «Обзор» и укажем уже самую новую скачанную с официального сайта прошивку,  жмем «Улучшить» и ждем завершения процесса.
Старые настройки после прошивки сбросятся на стандартные.

Все!