Question marks instead of Russian letters, a solution to the problem with Windows encoding

I noticed on one computer that instead of Russian letters on the command line and in some programs question marks are displayed.

First of all, you need to make sure that the language of the system is selected in Russian, for this, go to “Start” – “Control Panel” – “Clock, language and region” – “Language and regional standards”, tab “Advanced”, section “Program language, those that do not support Unicode, you must click “Change the system language” and select “Russian (Russia)” and click “OK” in all windows.

Also, to solve the problem, open the registry editor by typing “regedit.exe” at the command line.
You can open the command line by clicking on the shortcut in the “Start” menu – “All Programs” – “Standard” – “Command Prompt” or by typing “cmd” in the search bar of the “Start” menu.

In the registry editor, you must open the branch:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
and change the parameter values 1250 (from c_1250.nls to c_1251.nls), 1251 (make sure c_1251.nls), 1252 (from c_1252.nls to c_1251.nls).

Done, after restarting the computer, the Russian letters will be displayed correctly.

Leave a comment

Leave a Reply