The settings are essentially suitable for the entire Huawei Quidway S2300 series, but noticed that some commands may have small differences depending on the firmware version. If something does not work out, then you can look at the options for the commands by typing a question mark through a space after any command.
You can view the current configuration with the command:
display current-configuration
Go to the system environment from the user environment:
system-view
We write the name of the switch:
sysname TEXT
Add management vlan:
vlan 207
description TEXT
management-vlan
quit
Add vlan for users:
vlan 226
description TEXT
quit
If you need supervlan, then in any vlan we’ll add for example:
vlan 10
supervlan
aggregate-vlan
access-vlan VLANS
Add an interface in a managed vlan:
interface Vlanif 207
ip address 192.168.1.2 255.255.255.0
quit
Add the default route:
ip route 0.0.0.0 0.0.0.0 192.168.1.1
Set up the first SFP port as Uplink:
interface GigabitEthernet 0/0/1
port link-type trunk
port trunk allow-pass vlan 207 226
quit
If for example the user vlan comes untagged, and the management are tagged, then:
interface GigabitEthernet0/0/1
port hybrid pvid vlan 226
port hybrid tagged vlan 207
port hybrid untagged vlan 226
Configure ports for users, specify the desired vlan and port type, configure loopback-detect, limit broadcast traffic to 1% (other ports are similar):
interface Ethernet 0/0/1
port link-type access
port default vlan 226
loopback-detect enable
loopback-detect action shutdown
loopback-detect recovery-time 255
broadcast-suppression 1
Activate the loop protection function:
loopback-detect enable
Add an administrator:
user-interface vty 0 4
authentication-mode aaa
aaa
aaa
local-user admin privilege level 15
local-user admin password cipher TEXT
local-user admin service-type telnet web http ssh
quit
Specify the NTP server for time synchronization:
ntp-service unicast-server 192.168.1.1
Configure SNMP:
snmp-agent
snmp-agent sys-info version v2c
snmp community read TEXT
In order to be able to specify simple snmp communities, we enter the command:
snmp-agent community complexity-check disable
Turn off the web interface:
undo http secure-server enable
undo http server enable
display http server
See also my article:
How to enable the web interface on Huawei Quidway switches
When everyone has configured we will exit to the initial mode, save the configuration and indicate that it is bootable:
quit
save config.cfg
startup saved-configuration config.cfg[
Reboot the switch:
reboot
Examples of viewing the MAC address table:
display mac-address
display mac-address vlan 302
display mac-address Ethernet 0/0/1
display mac-address GigabitEthernet 0/0/1
display mac-address 0072-633d-b417
display mac-address summary
Example of viewing status and port statistics:
display interface Ethernet 0/0/6
See also my articles:
- Cable test
- How to configure DHCP client
- Restricting access to management
- Block third-party DHCP servers on the Huawei Quidway S2300 (DHCP Snooping)
- Port isolation on Huawei switches
- Quickly set up a range of ports
- Interface speed limit