Configuring link aggregation on Huawei SmartAX MA5600

On the test, I will configure aggregation on two ports of Huawei SmartAX MA5683T and Cisco Catalyst 6509-E.

Let’s see what boards are installed:

display board 0
display board 0/8

My traffic goes to one SFP port 0/8/0 (board H801GICF), I will configure the aggregation to it and the next free port 0/8/1:

link-aggregation 0/8 0 0/8 1 egress-ingress workmode lacp-static

Or we will configure one port, and then add the following:

link-aggregation 0/8 0 egress-ingress workmode lacp-static
link-aggregation add-member 0/8/0 0/8 1

If there is another H801GICF card, you can add its ports to the previously created aggregation, thereby increasing the uplink to 4Gb/s:

link-aggregation add-member 0/8/0 0/9 0,1

Let’s check:

display link-aggregation 0/8/0
display link-aggregation 0/8/1

You can cancel the aggregation as follows:

undo link-aggregation 0/8/0

Or, for example, remove port 0/9/1 from the aggregation:

link-aggregation delete-member 0/8/0 0/9 1

On Huawei SmartAX MA5683T, the aggregation configuration of the two ports is complete, there will be no configuration during the configuration and after the disruption of the traffic.

Now I’ll go to the port settings on the Cisco Catalyst 6509-E.

I configure the first port as I need, assign the necessary VLAN and add the port to the aggregation channel with the last command:

interface GigabitEthernet1/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active

The second port should be configured the same way, and also add the last command to the aggregation channel:

interface GigabitEthernet1/8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 111,144-190
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active

After the above commands, the Port-channel1 interface was automatically created, use the description command to add a note to it and enable it:

interface Port-channel1
description GPON OLT link aggregation
no shutdown

Now you can connect both Cisco ports to the OLT ports of the MA5683T.

Done.

See also my article:
Configuring Huawei SmartAX MA5683T through the console

Did my article help you? How about buying me a cup of coffee as an encouragement? Buy me a coffe.

Leave a comment

Leave a Reply