I will give an example of setting up the HP 5800 switch.

9600 Standard Console Port Speed
Ctrl+B Extended boot menu
Ctrl+D BASIC BOOT MENU
Ctrl+T memory test
Ctrl+X
Ctrl+Z
The default username is admin without a password.

Let’s switch to elevated privilege mode:

system-view

Specify sysname, enable telnet, ssh and web:

sysname TEXT
telnet server enable
ssh server enable
ip http port 8080
ip http enable

Add the necessary VLANs:

vlan 2
name TEXT
quit
vlan 3
name TEXT
quit
vlan 40 to 50
vlan 70 75 to 81 110 to 150 500

Add user:

super password level 3 cipher PASSWORD
local-user admin
password cipher PASSWORD
authorization-attribute level 3
service-type telnet
service-type portal
service-type web
quit
password-recovery enable
user-interface vty 0
authentication-mode scheme

DHCP Relay:

dhcp enable
dhcp-snooping
dhcp relay server-group 0 ip 10.0.0.3
dhcp relay server-detect

An example of adding VLAN interfaces:

interface Vlan-interface2
description CORE
ip address 192.168.1.5 255.255.255.0
dhcp select relay
quit

interface Vlan-interface3
description USERS
ip address 192.168.0.200 255.255.255.0
ip address 192.168.0.250 255.255.255.0 sub
dhcp select relay
dhcp relay server-select 0
quit

Default route:

router id 192.168.0.1
ip route-static 0.0.0.0 0.0.0.0 192.168.0.1

NTP:

ntp-service source-interface Vlan-interface2
ntp-service unicast-server 192.168.0.1

SNMP:

snmp-agent
snmp-agent community read public
snmp-agent sys-info contact test@ixnfo.com
snmp-agent sys-info location TEXT
snmp-agent sys-info version v2c

Enable loop detection:

loopback-detection enable

Example TRUNK port:

interface GigabitEthernet1/0/10
 port link-mode bridge
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 2 3 50 to 51

Example ACCESS port:

interface GigabitEthernet1/0/11
 port link-mode bridge
 port access vlan 2

Example of HYBRID port:

interface Ten-GigabitEthernet1/0/28
 port link-mode bridge
 port link-type hybrid
 undo port hybrid vlan 1
 port hybrid vlan 963 3500 to 3600 tagged
 port hybrid vlan 400 untagged
 port hybrid pvid vlan 400
 loopback-detection enable
 loopback-detection control enable
 loopback-detection per-vlan enable
 storm-constrain broadcast pps 200 150
 storm-constrain control block
 undo storm-constrain enable trap

Save the configuration:

save

See also my articles:
Configuring Authorized IP on HP 5800
Configure super VLAN on HP 5800
Configuring PIM on HP A5800 Switch
HP A5800 Firmware Upgrade
SNMP OIDs for the HP 5800 Switch
Solution of error “The transceiver type is not supported by port hardware”

Leave a comment

Leave a Reply