Configuring ports on Huawei switches

I will give an example of setting up ports on Huawei switches. For the test, I will execute commands on the Huawei Quidway S2326TP-EI.

After we connect to the switch, go to the configuration mode:

system-view

Example of setting access port (only one VLAN and no tag):

interface Ethernet0/0/1
 port link-type access
 port default vlan 226
 quit

Example of configuring the trunk port (all VLANs with tag only):

interface GigabitEthernet 0/0/1
port link-type trunk
port trunk allow-pass vlan 207 226
quit

An example of setting up a hybrid port (there may be several VLANs with a tag, and only one VLAN without a tag):

interface Ethernet0/0/1
port hybrid pvid vlan 226
port hybrid tagged vlan 207
port hybrid untagged vlan 226

Suppose you need to reconfigure the configured access port to hybrid, then you need to cancel the already specified commands:

interface Ethernet0/0/1
 undo port default vlan
 undo port link-type

After configuring the ports, check the configuration and save it:

quit
display current-configuration
save

See also my article:
Setting up a switch Huawei Quidway S2326TP-EI

Did my article help you? How about buying me a cup of coffee as an encouragement? Buy me a coffe.

Leave a comment

Leave a Reply